Results 1 to 4 of 4

Thread: clamav problems after nightly backups

  1. #1
    Join Date
    Jul 2008
    Posts
    44
    Rep Power
    7

    Default clamav problems after nightly backups

    i run nightly backups on my zimbra (5.0.14) by stopping zimbra, rsyncing and restarting zimbra.

    every couple of weeks or so, the antivirus fails to stars because the clamav database gets corrupted (and out of date), the error below is:

    Code:
    LibClamAV Warning: ***********************************************************
    LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    LibClamAV Warning: ***********************************************************
    LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ***********************************************************
    LibClamAV Error: cli_loadmd5: Problem parsing database at line 364543
    LibClamAV Error: Can't load main.mdb: Malformed database
    LibClamAV Error: cli_tgzload: Can't load main.mdb
    LibClamAV Error: Can't load /opt/zimbra/data/clamav/db/main.cld: Malformed database
    this seems to be caused directly by just startting and stopping zimbra, but i'm not sure what the bug is. it is likely some race condition.

    simply following the instructions here, will get things whipped into shape
    ClamAV - Reset Defs DB - Zimbra :: Wiki

    however, i would need to run this everytime i find my zimbra in this bad state, which is usually not until i have about 200 messages deferred (which is then when i realize zimbra is down)

    thus, i've modified my backup script to also restart the antivirus after backing up and restarting zimbra.

    Code:
    sudo -u zimbra /opt/zimbra/bin/zmcontrol stop
    rsync -avz /opt/zimbra /backups/zimbra
    sudo -u zimbra /opt/zimbra/bin/zmcontrol start
    sudo -u zimbra /opt/zimbra/bin/zmantivirusctl stop
    sudo -u zimbra /opt/zimbra/bin/zmantivirusctl start
    will this cause me even more problems? anyone have a better suggestion?

  2. #2
    Join Date
    May 2007
    Posts
    9
    Rep Power
    8

    Default New since .14

    I have had a nightly backup in place for almost two years and have not had a problem until updating to 5.0.14GA on Ubuntu 8.04LTS. I have the exact same problem. The odd thing about it is that if I start/stop/start again after the backup there is no issue, and if I restart the O/S there is no issue. It is only after I stop/backup/start that it happens.

    Anyone else?

    Jon

  3. #3
    Join Date
    Feb 2009
    Location
    Oxford, UK
    Posts
    9
    Rep Power
    6

    Default

    Yes I'm also getting this same problem on two Zimbra installs, both 5.0.14 and both on Ubuntu 8.04LTS

    Exactly the same issue with stop/backup/start causing the issue where there is no issue just stop/start

    On my major zimbra install I've simply switched off the AV until I have a fix as this server needs to be backed up every night. Any fix would be appreciated.

  4. #4
    Join Date
    Jun 2006
    Location
    Viseu
    Posts
    105
    Rep Power
    9

    Default

    Same issue here.. I've seen it happening both on Ubuntu or rhel 4x (ose or network edition)

Similar Threads

  1. Of backups and restoration
    By lcxe in forum Administrators
    Replies: 10
    Last Post: 11-20-2008, 09:13 AM
  2. multiserver backups question
    By Vladimir in forum Administrators
    Replies: 0
    Last Post: 10-14-2008, 12:37 PM
  3. Question about NE and Backups.
    By dougconley in forum Administrators
    Replies: 2
    Last Post: 12-17-2007, 11:56 PM
  4. [SOLVED] Howto: Update ClamAV
    By unilogic in forum Administrators
    Replies: 9
    Last Post: 12-12-2007, 04:28 AM
  5. Network Edition backups out of control
    By dameron in forum Administrators
    Replies: 1
    Last Post: 08-29-2007, 02:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •