Results 1 to 5 of 5

Thread: Bulk Provision on specific server node

  1. #1
    Join Date
    Mar 2009
    Posts
    6
    Rep Power
    6

    Default Bulk Provision on specific server node

    Does anyone know if there is a way to provision multiple accounts on a specific server?
    If I create accounts individually they are created on the server I am logged into, if I run the bulk provision by importing a CSV file all the accounts are created on the main server and I have to manually move each account to the node I need them on.
    Is this by design (an important reason behind it)? or is there a way around this?
    It is very time consuming to move 100's off accounts one at a time.

    Thanks

  2. #2
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    I hve done this in SOAP api..but not in CLI..qucik output from "zmprov ca" says:

    [zimbra@zimbra1 ~]$ zmprov ca
    usage: createAccount(ca) {name@domain} {password} [attr1 value1 [attr2 value2.. .]]

    zmprov [args] [cmd] [cmd-args ...]

    -h/--help display usage
    -f/--file use file as input stream
    -s/--server {host}[:{port}] server hostname and optional port
    -l/--ldap provision via LDAP instead of SOAP
    -L/--logpropertyfile log4j property file, valid only with -l
    -a/--account {name} account name to auth as
    -p/--password {pass} password for account
    -P/--passfile {file} read password from file
    -z/--zadmin use zimbra admin name/password from


    so may be you want to use he server switch and see if the user gets created on that server.
    something like:

    zmprov ca name@domain.com password -s host: port


    * host: port there is NO space after colon..i just did so it dont show up as smily :P
    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  3. #3
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    in SOAP api i do the following

    <CreateAccountRequest xmlns="urn:zimbraAdmin">
    <name>test@test.com</name>"
    <password>mypassword</password>
    <a xmlns="" n="displayName">Test Name</a>"
    <a xmlns="" n="givenName">Name</a>"
    <a xmlns="" n="zimbraMailQuota">10240</a>"
    <a xmlns="" n="zimbraMailHost">zimbrhost5.domain.com</a>
    </CreateAccountRequest>


    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  4. #4
    Join Date
    Mar 2009
    Posts
    6
    Rep Power
    6

    Default Web Interface?

    Thanks for the reply, I am not familiar with SOAP, maybe I should be. Is there any way to do this using the web interface "Bulk Provision" tool?

  5. #5
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    if you have 2 mailbox server i.e: mailserver1.domain.com and mailserver2.domain.com
    you can log into any one of the server and run your bulk commans on command line or in a .sh script
    command to create 1 user on MAILSERVER2:

    zmprov ca useronmailserver2@domain.com TestPassword zimbraMailHost mailserver2.domain.com


    zimbraMailHost is th attribute you were looking for which tell the server to create this users mailbox on mailserver2.

    All you need to do is create a file with 1 line each like above for each user and run once and it will create all the users for you.

    * i dont know if admin tool takes other attibutes like "zimbraMailHost" and stuff

    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

Similar Threads

  1. how to setup smtp server for sending bulk emails
    By chandu in forum Administrators
    Replies: 8
    Last Post: 08-09-2009, 05:07 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  4. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  5. Installation Problem - Possibly LDAP
    By geroshea in forum Installation
    Replies: 5
    Last Post: 03-16-2007, 04:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •