Results 1 to 3 of 3

Thread: [SOLVED] zimbra does not respect zimbraMtaRelayHost

  1. #1
    Join Date
    Dec 2008
    Rep Power

    Default [SOLVED] zimbra does not respect zimbraMtaRelayHost

    I've a curious problem here:

    I use a SmartRelay for my Zimbra and I set it a while ago and it worked fine. Now I wanted to change to a different SmartRelay (cause the old one is going to shut down in a few weeks) but whatever I do : Zimbra still uses the old one.

    ok: what I did:

    $zmprov mcf zimbraMtaRelayHost NEWSMTP.HOST.COM
    $zmprov gacf zimbraMtaRelayHost
    zimbraMtaRelayHost: NEWSMTP.HOST.COM

    Then I restarted zimbra (I even restarted the whole server !!) but outgoing mails are still relayed via OLDSMTP.HOST.COM

    NEWSMTP.HOST.COM is a simple A-Record with no extra MX-setup.

    To me it seems like there is another place in the config where a SmartRelay is defined and that my first call of zmprov mcf zimbraMtaRelayHost set this other place too or even I set it by myself and simply forgot about it.

    any hint welcome

  2. #2
    Join Date
    Oct 2005
    USA, Canada and India
    Rep Power


    just for the sake of trying:

    zmprov mcf zimbraMtaRelayHost '' <-- two single quotes.
    zmcontrol stop
    zmcontrol start

    and check if zimbraMtaRelayHost still exist..if not then set the new one as desired

    zmprov mcf zimbraMtaRelayHost NEWSMTP.HOST.COM

    * for the emails which are in your spool/deffered they may still be tried for the old smtp relay.

    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  3. #3
    Join Date
    Dec 2008
    Rep Power

    Default stupid me

    Thnx for your answer, but I just found the solution

    in the admin-interface -> configuration -> server -> MTA

    there you can set a different SmartRelay then the global one. There is even a button "reset to global"

    I'm sure I checked every setting in the admin-post 10 times before doing my post here in the forum, so I guess this settings just turned up after I posted

    No: After I resetted this value to the global value zimbra is relaying through my new smtp-server.


Similar Threads

  1. admin consol blank after 5.0.3 upgarde
    By maumar in forum Administrators
    Replies: 6
    Last Post: 03-21-2008, 05:16 AM
  2. Replies: 12
    Last Post: 02-25-2008, 06:28 PM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  4. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts