I'm running CentOS 4.3 and Zimbra 3.1. Everything was working well, and we were on the brink of going live, so I thought I would upgrade to 3.1.1... big mistake.

The upgrade was going as expected until:

Installing:
zimbra-core
zimbra-ldap
zimbra-logger
zimbra-mta
zimbra-snmp
zimbra-store
zimbra-apache
zimbra-spell

The system will be modified. Continue? [N] y

Shutting down zimbra mail

Removing existing packages

zimbra-mta...done
zimbra-core...done

Removing deployed webapp directories
Installing packages

zimbra-core......zimbra-core-3.1.1_GA_394.RHEL4-20060505121349.i386.rpm...FAILED
###ERROR###

zimbra-core-3.1.1_GA_394.RHEL4-20060505121349.i386.rpm installation failed

Installation cancelled

I tried ./install.sh -u and tried a complete re-install but when I start again I get:

Operations logged to /tmp/install.log.5914
Checking for existing installation...
zimbra-ldap...NOT FOUND
zimbra-logger...NOT FOUND
zimbra-mta...FOUND zimbra-mta-3.1.1_GA_394
zimbra-snmp...NOT FOUND
zimbra-store...NOT FOUND
zimbra-apache...NOT FOUND
zimbra-spell...NOT FOUND
zimbra-core...FOUND zimbra-core-3.1.1_GA_394

Saving existing configuration file to /opt/zimbra/.saveconfig
cp: cannot stat `/opt/zimbra/java/jre/lib/security/cacerts': No such file or directory

But zimbra-core and zimbra-mta are not installed, so I don't know how to get back to a working system without re-building the box?

I'm a bit desperate as the live date is looming and I'm worried that i'm going have problems when I come to upgrade the next time.

Thanks in advance

John