Results 1 to 9 of 9

Thread: Error: Manage Mail Queues

  1. #1
    Join Date
    Jan 2006
    Posts
    27
    Rep Power
    9

    Default Error: Manage Mail Queues

    Hi,

    Just installed Zimbra Community on a remote server.

    I was trying to access the mail queues manager, and got this error message:

    Code:
    Message:  system failure: exception during auth {RemoteManager: philanth.clusterspan.net->zimbra@philanth.clusterspan.net:22}
    com.zimbra.cs.service.ServiceException: system failure: exception during auth {RemoteManager: philanth.clusterspan.net->zimbra@philanth.clusterspan.net:22}
    	at com.zimbra.cs.service.ServiceException.FAILURE(ServiceException.java:131)
    	at com.zimbra.cs.rmgmt.RemoteManager.getSession(RemoteManager.java:192)
    	at com.zimbra.cs.rmgmt.RemoteManager.execute(RemoteManager.java:129)
    	at com.zimbra.cs.service.admin.GetMailQueueInfo.handle(GetMailQueueInfo.java:55)
    	at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:255)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:163)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:84)
    	at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:228)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
    	at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:154)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
    	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
    	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
    	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
    	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
    	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
    	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:541)
    	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
    	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
    	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:667)
    	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
    	at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
    	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
    	at java.lang.Thread.run(Thread.java:595)
    Caused by: java.io.IOException: Publickey authentication failed.
    	at ch.ethz.ssh2.auth.AuthenticationManager.authenticatePublicKey(AuthenticationManager.java:259)
    	at ch.ethz.ssh2.Connection.authenticateWithPublicKey(Connection.java:371)
    	at ch.ethz.ssh2.Connection.authenticateWithPublicKey(Connection.java:422)
    	at com.zimbra.cs.rmgmt.RemoteManager.getSession(RemoteManager.java:184)
    	... 24 more
    Caused by: java.io.IOException: Authentication method publickey not supported by the server at this stage.
    	at ch.ethz.ssh2.auth.AuthenticationManager.authenticatePublicKey(AuthenticationManager.java:166)
    	... 27 more
    
    Error code:  service.FAILURE
    Method:  ZmCsfeCommand.prototype.invoke
    Details:soap:Receiver
    Any advice about this?

    Thanks,

    F.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Have you changed the ssh port to something other than 22? If you have, that's the problem - have a look at this thread
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jan 2006
    Posts
    27
    Rep Power
    9

    Default Port 22

    Thanks for your reply.

    I set up Zimbra with some ports default (including 22), and some not.

    I tried opening all ports outbound and inbound (temporarly) on the Linux server, but same error. It's most certainly a port problem, but I still can't pinpoint it.

    François

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Do you have SElinux active? If you do then disable it and try again. ARe you trying to access the queus manager from another PC on the LAN or from outside the LAN? There's also a list of ports that need to be opened on the wiki, check there for the ones needed.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    9

    Default

    Is you SSH server setup to use Public Key Authentication???

    Caused by: java.io.IOException: Authentication method publickey not supported by the server at this stage.

  6. #6
    Join Date
    Jan 2006
    Posts
    27
    Rep Power
    9

    Default Key

    I thought this key was set up in the installation process of Zimbra... for the zimbra user. I'm not at all familiar with the key installation process, its end or mean. I'll look into that.

    Thanks

  7. #7
    Join Date
    Jan 2006
    Posts
    27
    Rep Power
    9

    Default selinux

    Tried: setenforce 0
    To set permissive mode for selinux: same error message with the Manage Mail Queue.

    To answer Phoenix' question: I'm trying to access the Queue Manager from outside the LAN.

    Thanks Phoenix

  8. #8
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    9

    Default

    Check your sshd_config file and see if you are allowing RSA authentication.

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Permissive mode doesn't always do what it should, I'd recommend disabling it while you try to fix this problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 03:34 PM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 08:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •