Results 1 to 10 of 10

Thread: How to add a second IP

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Posts
    16
    Rep Power
    10

    Default How to add a second IP

    I installed Zimbra on FC3 and had it all working beautifully.... then I added a second NIC to the machine (configured ifcfg, added hostname to hosts). Brought up the new nic (192.x.x.x subnet) and was able to connect via ssh. I attempted to connect to zimbra via https on the new ip and got server refused connection (assumed it was iptables). Thus I did the following:

    zmcontrol shutdown
    zmiptables -u
    zmiptables -i
    zmiptables -p (the new ip was listed)
    zmcontrol startup

    Now I get the following when doing the startup:

    RESPONSE: (Zimbra::Mon::serviceInfo)
    host
    ip
    name

    From the zimbra.log I am getting:

    Oct 6 14:44:28 zimbra zimbramon[2211]: 2211:info: Starting services
    Oct 6 14:44:28 zimbra zimbramon[2211]: 2211:info: STARTING ldap
    Oct 6 14:44:28 zimbra zimbramon[2211]: 2211:info: start service ldap
    Oct 6 14:44:28 zimbra zimbramon[2211]: 2211:info: start app ldap
    Oct 6 14:44:28 zimbra zimbramon[2211]: 2211:info: Starting child ldap: (20051006144428)
    Oct 6 14:44:37 zimbra zimbramon[2211]: 2211:info: STARTING services
    Oct 6 14:44:37 zimbra zimbramon[2211]: 2211:info: Doing startup
    Oct 6 14:44:38 zimbra zimbramon[2546]: 2546:info: Zimbra Monitor startup: 2546
    Oct 6 14:44:38 zimbra zimbramon[2546]: 2546:info: Process 894 not found - removing /opt/zimbra/zimbramon/FIFO/zm.pid
    Oct 6 14:44:38 zimbra zimbramon[2566]: 2566:info: Status monitor startup
    Oct 6 14:44:38 zimbra zimbramon[2567]: 2567:info: Creating soap server on port 7777

    I can access the Web Login, but am unable to login in. I get the following error:

    An unknown application error has occurred. Please correct any errors and retry. If the problem persists, please contact your System Aministrator. (AjxException.UNKNOWN_ERROR)

    but I do not see anything in the zimbra.log file when I attempt to log in.

    The admin console responds, but I do not see a login dialogue and thus am unable to login.

    Any suggestions? What would be the correct way to set up zimbra to listen on two hosts?

    Justin

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default iptables

    When you ran iptables -p, were BOTH ips listed, or just one? If just one, you'll need to modify the script to forward for both IPs.

  3. #3
    Join Date
    Oct 2005
    Posts
    16
    Rep Power
    10

    Default Output from iptables -p

    Here is the output from zmiptables -p (yes, it has the 2 ips [3 technically including the loopback])

    Port Mappings
    -------------
    25 --> 7075
    993 --> 7993
    443 --> 7443
    995 --> 7995
    389 --> 7389
    80 --> 7070
    110 --> 7110
    143 --> 7143

    IP Addresses
    ------------
    127.0.0.1
    10.0.0.33
    192.168.1.33
    Last edited by Justin Rock; 10-06-2005 at 03:10 PM. Reason: added detail

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default iptables

    Run (as root) iptables -t nat -L and post the output...

  5. #5
    Join Date
    Oct 2005
    Posts
    16
    Rep Power
    10

    Default Output from iptables as root

    # iptables -t nat -L

    Chain PREROUTING (policy ACCEPT)
    target prot opt source destination

    Chain POSTROUTING (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

  6. #6
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default No forwarding.

    Your post indicates that there's no port forwarding at all! Can you re-run zmiptables -i?

Similar Threads

  1. Replies: 32
    Last Post: 03-18-2011, 11:03 AM
  2. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 11:41 AM
  3. Zimbra + Samba LDAP, cannot add winxp
    By fajarpri in forum Installation
    Replies: 4
    Last Post: 07-08-2007, 11:45 AM
  4. Binding to Ports (per IP?)
    By jsx in forum Installation
    Replies: 3
    Last Post: 06-03-2007, 02:41 PM
  5. Using Zimlet to add zimbra account
    By dzed in forum Zimlets
    Replies: 2
    Last Post: 05-05-2006, 02:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •