Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: LDAP won't start

  1. #11
    Join Date
    May 2009
    Posts
    13
    Rep Power
    6

    Default

    i found this error
    Fatal error: exception while binding to ports


    how can i check that

  2. #12
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    It should tell you which ports it can't connect to, you've probably got another mail server (the most likely) or a pop3/imap server running.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #13
    Join Date
    May 2009
    Posts
    13
    Rep Power
    6

    Default

    ok how can i find out that which command have to run for it
    im using ubuntu server 8.04 hardy

  4. #14
    Join Date
    Nov 2007
    Location
    AZ, USA
    Posts
    205
    Rep Power
    8

    Default Status checking

    Try the command
    netstat -lp or
    netstat --listening --programs --tcp --udp

    That will report "ALL" ports that have a process "Listening for tcp & udp"

  5. #15
    Join Date
    May 2009
    Posts
    13
    Rep Power
    6

    Default

    this is the result but i cant find any port 81 i realy loosing my mind here wath do you recomend

    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 6919/nginx.conf
    tcp 0 0 *op3s *:* LISTEN 6919/nginx.conf
    tcp 0 0 *:7780 *:* LISTEN 6944/httpd
    tcp 0 0 esigt.com:ldap *:* LISTEN 4930/slapd
    tcp 0 0 localhost.localdo:10025 *:* LISTEN 7464/master
    tcp 0 0 localhost.localdom:7306 *:* LISTEN 5620/mysqld
    tcp 0 0 localhost.localdo:mysql *:* LISTEN 4629/mysqld
    tcp 0 0 *:11211 *:* LISTEN 6910/memcached
    tcp 0 0 localhost.localdom:7307 *:* LISTEN 5449/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN 4706/smbd
    tcp 0 0 *op3 *:* LISTEN 6919/nginx.conf
    tcp 0 0 *:imap2 *:* LISTEN 6919/nginx.conf
    tcp 0 0 *:webmin *:* LISTEN 4847/perl
    tcp 0 0 *:ssmtp *:* LISTEN 7464/master
    tcp 0 0 *:81 *:* LISTEN 4823/apache2
    tcp 0 0 esigt.com:domain *:* LISTEN 4506/named
    tcp 0 0 mail.esigt.com:domain *:* LISTEN 4506/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 4506/named
    tcp 0 0 esigt.com:3128 *:* LISTEN 4748/(squid)
    tcp 0 0 *:smtp *:* LISTEN 7464/master
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 4506/named
    tcp 0 0 *:microsoft-ds *:* LISTEN 4706/smbd
    tcp6 0 0 [::]:ssh [::]:* LISTEN 4531/sshd
    tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 4506/named
    udp 0 0 mail.esigt.c:netbios-ns *:* 4704/nmbd
    udp 0 0 esigt.com:netbios-ns *:* 4704/nmbd
    udp 0 0 *:netbios-ns *:* 4704/nmbd
    udp 0 0 mail.esigt.:netbios-dgm *:* 4704/nmbd
    udp 0 0 esigt.com:netbios-dgm *:* 4704/nmbd
    udp 0 0 *:netbios-dgm *:* 4704/nmbd
    udp 0 0 *:10000 *:* 4847/perl
    udp 0 0 *:domain *:* 4506/named
    udp 0 0 esigt.com:domain *:* 4506/named
    udp 0 0 mail.esigt.com:domain *:* 4506/named
    udp 0 0 localhost.locald:domain *:* 4506/named
    udp 0 0 *:icpv2 *:* 4748/(squid)
    udp 0 0 *:59503 *:* 4748/(squid)
    udp6 0 0 [::]:41670 [::]:* 4506/named

  6. #16
    Join Date
    Nov 2007
    Location
    AZ, USA
    Posts
    205
    Rep Power
    8

    Default Heading/reading

    Quote Originally Posted by gleiva View Post
    this is the result but i cant find any port 81 i realy loosing my mind here wath do you recomend
    Cut
    .
    .
    .
    .
    tcp 0 0 *:pop3 *:* LISTEN 6919/nginx.conf
    tcp 0 0 *:imap2 *:* LISTEN 6919/nginx.conf
    tcp 0 0 *:webmin *:* LISTEN 4847/perl
    tcp 0 0 *:ssmtp *:* LISTEN 7464/master
    tcp 0 0 *:81 *:* LISTEN 4823/apache2
    .
    .
    .
    .tcp6 0 0 [::]:ssh [::]:* LISTEN 4531/sshd
    .
    .
    .
    What are the services I just left in the above???
    I see at least a few of the problems that Phoenix pointed out as possible.

  7. #17
    Join Date
    May 2009
    Posts
    13
    Rep Power
    6

    Default

    hi tank you the 81 its the apache but ill stop it to try the zimbra isntallation ists on port 80 as i remember, but the other two i realy dont know what they are how can i remove that

    i did a locate of the file and this came back

    esi2008gt@esigt:/etc$ locate nginx.conf
    /opt/zimbra/conf/nginx.conf
    /opt/zimbra/conf/nginx.conf.in
    /opt/zimbra/nginx-0.5.30-zimbra/conf/nginx.conf
    /opt/zimbra/nginx-0.5.30-zimbra/conf/nginx.conf.default
    /opt/zimbra/zimbra/conf/nginx.conf
    /opt/zimbra/zimbra/conf/nginx.conf.in
    /opt/zimbra/zimbra/nginx-0.5.30-zimbra/conf/nginx.conf
    /opt/zimbra/zimbra/nginx-0.5.30-zimbra/conf/nginx.conf.default

  8. #18
    Join Date
    May 2009
    Posts
    13
    Rep Power
    6

    Default

    May 11 13:07:52 esigt zmmailboxdmgr[3814]: status requested
    May 11 13:07:52 esigt zmmailboxdmgr[3814]: stale pid 25506 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
    May 11 13:07:52 esigt zmmailboxdmgr[3814]: assuming no other instance is running
    May 11 13:07:52 esigt zmmailboxdmgr[3814]: file /opt/zimbra/log/zmmailboxd.pid does not exist


    i found this error message in log
    could this be my problem

  9. #19
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You should never have installed the proxy server if this is a single server install. Do the following:

    Check if the proxy is installed/running:

    Code:
    zmproxyctl status
    zmprov gs server.domain.com | grep zimbraServiceEnabled
    zmprov gs server.domain.com | grep zimbraServiceInstalled
    If it's in, then run this:

    Code:
    zmproxyctl stop
    zmprov ms server.domain.com -zimbraServiceEnabled imapproxy
    zmcontrol stop
    zmcontrol start
    To reset the ports run the following (on one line):

    Code:
    zmprov -l ms server.domain.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995 zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993
    then restart. Obviously use your own domain name in the commands.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #20
    Join Date
    May 2009
    Posts
    13
    Rep Power
    6

    Default

    i did run all the commands and this was the result

    zimbra@esigt:~$ zmprov gs esigt.com | grep zimbraServiceEnabled
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@esigt:~$ zmproxyctl status
    nginx is running
    memcached is running
    zimbra@esigt:~$ zmprov gs esigt.com | grep zimbraServiceInstalled
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@esigt:~$ zmproxyctl stop
    Stopping nginx
    Stopping memcached
    zimbra@esigt:~$ zmprov ms esigt.com -zimbraServiceEnabled imapproxy
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@esigt:~$
    zimbra@esigt:~$ zmproxyctl stop
    Stopping nginx
    Stopping memcached
    zimbra@esigt:~$ zmproxyctl start
    Mon May 11 13:32:09 2009 Service antivirus is not enabled. Skipping antivirus
    Mon May 11 13:32:09 2009 Service antispam is not enabled. Skipping antispam
    Mon May 11 13:32:09 2009 Service archiving is not enabled. Skipping archiving
    Mon May 11 13:32:09 2009 Rewrote: /opt/zimbra/conf/nginx.conf
    nginx is running
    memcached is running
    zimbra@esigt:~$ zmprov -l ms esigt.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995 zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993

    this is the response after restart the server

    Host esigt.com
    imapproxy Running
    ldap Running
    logger Running
    mailbox Stopped
    zmmailboxdctl is not running
    mta Running
    snmp Running
    spell Running
    stats Running


    il try to run the command again but i steel have the same response but it did fix somthin becouse now the server try to validate the user in my outlook


    zimbra@esigt:~$ zmprov gs esigt.com | grep zimbraServiceEnabled
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@esigt:~$ zmprov gs esigt.com | grep zimbraServiceInstalled
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    zimbra@esigt:~$ zmprov ms esigt.com -zimbraServiceEnabled imapproxy
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

Similar Threads

  1. Errors installing Outlook Connector
    By Tim G in forum Zimbra Connector for Outlook
    Replies: 57
    Last Post: 05-05-2011, 03:27 PM
  2. Replies: 8
    Last Post: 08-07-2008, 06:18 AM
  3. Error Installing Outlook Connector
    By DanO in forum Zimbra Connector for Outlook
    Replies: 17
    Last Post: 08-28-2007, 10:35 AM
  4. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •