Results 1 to 2 of 2

Thread: [SOLVED] Doc Problem with LDAP Replica Uninstall?

  1. #1
    Join Date
    May 2007
    Maryland, USA
    Rep Power

    Default [SOLVED] Doc Problem with LDAP Replica Uninstall?

    Was uninstalling an LDAP replica on my test system before doing production using the multi-server install guide as a ref. I think there may be a typo there that could cause a subsequent ldap stop/start to bomb.

    My test ldap had replication enabled based on what i found in slapd.conf, although there never actually was a replica. I made the edits to slapd.conf per the guide and all seemed ok, the ldap stop/start worked ok. I never checked slapd.conf or I would have seen that my edits got overwritten and the master was still enabled for replication. But a few days later I restarted the test server w/ldap on it and slapd didn't start. Took me bit to figure it out because the slapd error message returned is mostly associates with db corruption or permissions problems in the forums.

    If you follow the multi-guide to remove a replica, all appears fine but the master may still config'd for replication because edits should be to, not slapd.conf. And the next step in the guide, deleting accesslog dir, creates a situation where the next ldap stop/start will fail because the repilcation-enabled master looks for accesslog.

    So basically if your is set up for replication and you follow the multi-server guide to uninstall a replica, the second ldap stop/start after uninstalling the replica goes bang! and you get

    [zimbra@email1o conf]$ ldap stop;ldap start
    slapd not running
    Failed to start slapd. Attempting debug start to determine error.
    backend_startup_one: bi_db_open failed! (-1)

    I looked for a bugzilla on this, is that where doc RFE's are ?

  2. #2
    Join Date
    May 2006
    Rep Power


    Good catch, gets filed under component 'tech docs.'

    However, when you enter it make a note that it's just for previous doc consistency on /community/documentation_previous_releases.html as there there's an upcoming Bug 36174 - Doc updates for LDAP in GnR
    Quote Originally Posted by quanah
    The following references to "slapd.conf" need to be fixed, as it no longer exists in GnR.
    Administrators guide -- "ldap_root_password" description
    Multi-server admin guide -- "Disable LDAP replication on the Master server" There is no option to disable replication at this time, and there is no slapd.conf to edit.
    Quote Originally Posted by mmorse
    OpenLDAP now allows for some on-the-fly configuration changes with zmlocalconfig via a cn=config backend instead of slapd.conf text files for preservation across upgrades.

Similar Threads

  1. problem zimbra LDAP integrate to my app authentication
    By manier in forum Administrators
    Replies: 0
    Last Post: 03-08-2009, 07:07 PM
  2. 4.5.11 -> 5.0.6 NE & LDAP Replica
    By cjstone in forum Administrators
    Replies: 2
    Last Post: 06-24-2008, 11:54 AM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  4. Multi Server Installation
    By rsharpe in forum Installation
    Replies: 6
    Last Post: 07-11-2007, 09:53 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts