Hi,

Problem: mail sent internally (through the webmail interface) gets a positive score on RDNS_NONE. We have set RDNS_NONE to a score of 5, because mail from external mail servers without reverse DNS should be blocked.

Unfortunately, our internal email ends up in the junk box as well.

We have tried to figure out where/how to fix 127.0.0.1 getting a positive RDNS_NONE score, but so far have not found the right solution.


Ofcourse we could lower RDNS_NONE to less than 5, but that would be a dirty hack, not a fix.

Here is (part of) an affected email header.

X-Virus-Scanned: amavisd-new at
X-Spam-Flag: NO
X-Spam-Score: 4.277
X-Spam-Level: ****
X-Spam-Status: No, score=4.277 tagged_above=-10 required=6.6 tests=[AWL=0.003,
BAYES_00=-2.599, HTML_MESSAGE=0.001, RCVD_IN_PBL=0.995,
RCVD_IN_SORBS_DUL=0.877, RDNS_NONE=5]
Received: from mail.myserver.com ([127.0.0.1])

Problem appears to be that a reverse DNS lookup is done on 127.0.0.1 which fails. Any idea how/where to fix this so the Received: line would look like:

Received: from mail.myserver.com (localhost [127.0.0.1])

or

Received: from mail.myserver.com (mail.myserver.com [127.0.0.1])