Results 1 to 2 of 2

Thread: [SOLVED] Zimbra Backups Fail - SOAP GUI Error

  1. #1
    Join Date
    May 2006
    Location
    Portland, OR
    Posts
    4
    Rep Power
    9

    Default [SOLVED] Zimbra Backups Fail - SOAP GUI Error

    Release 5.0.11_GA_2695.UBUNTU8_64 UBUNTU8_64 NETWORK edition

    The error message in the GUI:

    Message: unknown document: BackupQueryRequest Error code: service.UNKNOWN_DOCUMENT Method: BackupQueryRequest Details:soap:Sender

    Description:

    Backups would not work after a migration from RHEL -> Ubuntu 8.04. Running 'zmbackup -f -a all' would result in a 3.3MB backup of what seemed like just ldap data. Accessing the backup section in the GUI Admin resulted in the above error message.

    Fix:

    Running strace on zmbackup, the script was trying to access /opt/zimbra/lib/ext/backup/zimbrabackup.jar, which did not exist. The fix was to unpack the zimbra-store deb and copy opt/zimbra/lib/ext/backup into place.

    Code:
    ar x zimbra-store_5.0.11_GA_2695.UBUNTU8_64_amd64.deb
    tar zxvf data.tar.gz
    rsync -aP opt/zimbra/lib/ext/backup /opt/zimbra/lib/ext/
    chown -R root.root /opt/zimbra/lib/ext/backup

    It was odd backups were working on the previous hosting provider's setup if this file was missing unless there was a fundamental difference between the files location between RHEL and Ubuntu.

  2. #2
    Join Date
    Jun 2008
    Location
    United Kingdom
    Posts
    30
    Rep Power
    7

    Default

    For clarity, I think it's worth mentioning that this fix seems to require a Zimbra restart for it to take effect.

    Jon

Similar Threads

  1. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 10:13 AM
  2. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  3. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  4. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •