Results 1 to 6 of 6

Thread: zmcontrol doesn't start mysql, apache or tomcat

Hybrid View

  1. #1
    Join Date
    May 2006
    Rep Power

    Default zmcontrol doesn't start mysql, apache or tomcat

    We have been working on installing and configuring 3.1.1 release of Zimbra and have noticed that the /etc/init.d/zimbra script calls the zimbra/bin/zmcontrol script that starts up only the mail related services. It doesn't seem to load mysql, apache or tomcat.

    Am I missing something or is this left up to the administrator to add the appropriate startup scripts?

    Let me mention that when we did the install (on a clean box) Zimbra was working perfectly. Once we rebooted the box, the above mentioned services don't start. Looking through the zmcontrol script, I don't reference to these services either.


    Last edited by pbwebguy; 05-15-2006 at 02:44 PM.

  2. #2
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    Hi John,
    zmcontrol start

    DSpam (or SPAM assassin)

    All of these are Zimbra's own flavor of the particular program.
    Make sure you are not starting any version of the above listed programs on your machine.

    What does a zmcontrol status return?

  3. #3
    Join Date
    Nov 2005
    London, ON
    Rep Power


    zmcontrol does an LDAP query to see which services need to be started on a server. If the server entry does not contain the appropriate services then neither zmcontrol or /etc/init.d/zimbra will attempt to start them. All the services you speak of invovle the mailstore, you can use zmprov to see if LDAP knows what is installed and enabled.

    zmprov gs | grep -i service ---- i think that will work.

  4. #4
    Join Date
    May 2006
    Rep Power


    Hi - I tried the command and it appears that mysql, tomcat and apache don't appear to be in the ldap database. Here are the results of the command.

    zimbraServiceEnabled: antivirus
    zimbraServiceEnabled: antispam
    zimbraServiceEnabled: logger
    zimbraServiceEnabled: mailbox
    zimbraServiceEnabled: mta
    zimbraServiceEnabled: snmp
    zimbraServiceEnabled: ldap
    zimbraServiceEnabled: spell
    zimbraServiceInstalled: antivirus
    zimbraServiceInstalled: antispam
    zimbraServiceInstalled: logger
    zimbraServiceInstalled: imapproxy
    zimbraServiceInstalled: mailbox
    zimbraServiceInstalled: mta
    zimbraServiceInstalled: snmp
    zimbraServiceInstalled: ldap
    zimbraServiceInstalled: spell

    Is there any way to add the missing services to LDAP ?


  5. #5
    Join Date
    Nov 2005
    London, ON
    Rep Power


    The services are actually there they are apart of the mailbox service. If the mailbox starts then tomcat has started mysql has started and apache has started.

  6. #6
    Join Date
    May 2006
    Rep Power


    Here is the > zmcontrol status
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running

    As you can see, all of these services start up but the database, tomcat and apache don't. When I do a 'ps -elf' I can see that httpd, java and tomcat are not running.

    To get things working, we had to directly cat the zimbra commands:

    tomcat start
    zmapachectl start
    mysql.server start

    We added calls to those scripts in our /etc/init.d/rc3.d directory appropriately.

    One note that I wanted to add was that when we attempted to do the install, there was one problem when we were trying to do the initial install. There is a test in the to check the /etc/hosts file to make sure that we have the hostname format correct. We tried for at least 1-2 hours toying with the variations but finally had to comment out that one test. Never could figure out why it was failing.

    The section of the script (line 229) has:

    if ! cat /etc/hosts | \
    perl -ne 'if (/^\s*\d+\.\d+\.\d+\.\d+\s+(\S+)/ && !/^\s*127\.0\.0\.1/) { my @foo = split (/\./,$1); if ($#foo == "0") {exit 11;} }'; then


    ERROR: Installation can not proceeed. Please fix your /etc/hosts file
    to contain:

    <ip> <FQHN> <HN>

    Where <IP> is the ip address of the host,
    <FQHN> is the FULLY QUALIFIED host name, and
    <HN> is the (optional) hostname-only portion


    # exit 1

    We commented out the 'exit 1' and the remainder of the script worked.

    Our /etc/hosts last configuration was:

    # hosts This file describes a number of hostname-to-address
    # mappings for the TCP/IP subsystem. It is mostly
    # used at boot time, when no name servers are running.
    # On small systems, this file can be used instead of a
    # "named" name server.
    # Syntax:
    # IP-Address Full-Qualified-Hostname Short-Hostname
    # localhost.localdomain localhost corona

    hostname of the server is 'corona'

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. After reboot mailbox and tomcat don't start
    By gon in forum Administrators
    Replies: 1
    Last Post: 11-02-2007, 11:50 AM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM
  4. Replies: 4
    Last Post: 01-18-2006, 10:58 AM
  5. Can't start MySQL to init db - Gentoo
    By fak3r in forum Installation
    Replies: 3
    Last Post: 10-10-2005, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts