Results 1 to 3 of 3

Thread: Problem with Zimbra Backup/Restore

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Rep Power

    Default Problem with Zimbra Backup/Restore


    Just spent 14 hrs trying to get the recommended route for backup restore to work and failed...

    Using 3.1.1 -394 ZCS stopped services. Checked all stopped. Copied by rsync the entire opt/zimbra directory to another server.

    Installed new server with same hostname and IP, same OS (FC4) fully updated and installed vanilla ZCS. Stopped services and moved required /opt/zimbra into positon and ran again. Also tried resetting permissions on opt/zimbra with zmfixperms but results were the same.

    System comes up, all accounts in place, all mail there, calendar etc. However try to send an email and I get dialogue box with:

    msg - system failure: IOException
    com.zimbra.cs.service.ServiceException: system failure: IOException
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M
    at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg. java:97)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:163)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:228)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at ternalDoFilter(
    at Filter(
    at org.apache.catalina.core.StandardWrapperValve.invo ke(
    at org.apache.catalina.core.StandardContextValve.invo ke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke (
    at org.apache.catalina.core.StandardEngineValve.invok e(
    at org.apache.catalina.valves.AccessLogValve.invoke(A
    at org.apache.catalina.connector.CoyoteAdapter.servic e(
    at org.apache.coyote.http11.Http11Processor.process(H
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt
    at Socket(
    at ead.runIt(
    at org.apache.tomcat.util.threads.ThreadPool$ControlR
    Caused by: /opt/zimbra/store/incoming/1147927093922-10.msg (Permission denied)
    at Method)
    at<init>(FileOutputStream.j ava:179)
    at<init>(FileOutputStream.j ava:131)
    at com.zimbra.cs.mailbox.Mailbox.addMessageInternal(M
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:2788)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:2760)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M
    ... 24 more

    code - service.FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Receiver

    Only clue I can find is in zimbra.log

    at Socket(
    at ead.runIt(
    at org.apache.tomcat.util.threads.ThreadPool$ControlR
    Caused by: /opt/zimbra/store/incoming/1147927093922-10.msg (Permission denied)

    Any clues as to why? Orginal system still works fine so back to that for now but it concerns me that there is no way to back up a working system.

    Happy to send attch logs as needed but not sure which!

  2. #2
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    Yup. Your problem is that zimbra doesn't have permission to read the message store.

    You can fix this by running the following command:

    chown -R zimbra:zimbra /opt/zimbra/st*
    Good Luck!

    PS: By the way, I wrote a little tutorial on how to restore and back up in the wiki: Open Source Edition Backup Procedure
    Last edited by jholder; 05-17-2006 at 10:25 PM.

  3. #3
    Join Date
    Oct 2005
    Rep Power

    Default And breathe.... Many Thanks....

    Thats the bleary eyed moment.... ;-) Yes it does now work. What I dont know is why the zmpermsfix doesnt reset that - looks like it is doing so in the script - Ill need some sleep before I get to that again.... I had before, in the multiple changes/installs, tried manually changing the permissions as you suggested but there must have been more hangovers from the failures that time.

    I read your wiki entry and a large number of other posts and pdfs but the 'std' approach of using zmpermsfix is the herring of a reddening finish!

    Many thanks wannabetenor, early or late riser? I can rest easy now.... off to get the train home... ewww its 7am


Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 07:21 PM
  2. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  3. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  4. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts