Results 1 to 2 of 2

Thread: Antispam problems

  1. #1
    Join Date
    Oct 2007
    Location
    Detroit Michigan
    Posts
    10
    Rep Power
    8

    Default Antispam problems

    I am having problems with 5.0.15 Network Edition.

    I am having several problems with the antispam system in Zimbra. First of all, the spam headers are not being added to the emails even though they are set to be added:

    Code:
    zimbraSpamCheckEnabled: TRUE
    zimbraSpamHeader: X-Spam-Flag
    zimbraSpamHeaderValue: YES
    zimbraSpamIsNotSpamAccount: ham.1uzczl0s5u@example.com
    zimbraSpamIsSpamAccount: spam.bvjos87bf@example.com
    zimbraSpamKillPercent: 75
    zimbraSpamReportSenderHeader: X-Zimbra-Spam-Report-Sender
    zimbraSpamReportTypeHam: ham
    zimbraSpamReportTypeHeader: X-Zimbra-Spam-Report-Type
    zimbraSpamReportTypeSpam: spam
    zimbraSpamSubjectTag: ***SPAM***
    zimbraSpamTagPercent: 18
    The only header that is being added:
    Code:
    X-Virus-Scanned: amavisd-new at mx1.example.com
    I have also checked the local MyNetworks settings:
    Code:
    [zimbra@mx1 ~]$ zmprov gs mx1.example.com zimbraMtaMyNetworks
    # name mx1.example.com
    zimbraMtaMyNetworks: 127.0.0.0/8 8.2.183.0/26 10.200.200.0/24
    And yes, the antivirus and the antispam apps are running:
    Code:
    [zimbra@mx1 ~]$ zmcontrol status
    Host mx1.workforcesoftware.com
            antispam                Running
            antivirus               Running
            ldap                    Running
            mta                     Running
            stats                   Running
    Second problem: I've added some extra rules to /opt/zimbra/conf/spamassassin/local.cf:
    Code:
    body WFS_BODY_****** =~ /\b******./i
    describe WFS_BODY_****** ****** in the body
    score WFS_BODY_****** 100
    
    header WFS_HEADER_****** ALL Subject =~ /\b******./i
    describe WFS_HEADER_****** ****** in the header
    score WFS_HEADER_****** 100
    
    header WFS_HEADER_PFIZER ALL Subject =~ /\bpfizer./i
    describe WFS_HEADER_PFIZER Pfizer in the header
    score WFS_HEADER_PFIZER 100
    
    header WFS_HEADER_FROM_WFS From =~ /wfs-livonia@example.com/\i
    describe WFS_HEADER_FROM_WFS Message sent from WFS mailing list
    score WFS_HEADER_FROM_WFS 100
    These rules do not appear to be working since emails are still being received with "wfs-livonia@example.com" in the From: header.


    Is there any way to 'lint' the spamassassin rules on Zimbra?


    Ron Gage

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Why not install SpamAssassin from the O/S repos ? This should not effect the ZCS SA install. You would then be able to lint your config.

    Oh, and it looks like the backslash on your last rule is the wrong way around

Similar Threads

  1. Some problems
    By druid in forum Installation
    Replies: 5
    Last Post: 08-31-2007, 01:31 PM
  2. Tomcat, Java VM Problems - RAM related? Help
    By Mo_Hong in forum Administrators
    Replies: 3
    Last Post: 03-28-2007, 03:00 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. antispam not working?
    By moebis in forum Installation
    Replies: 16
    Last Post: 12-03-2005, 08:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •