Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] Webmail password change.

  1. #1
    Join Date
    Jul 2008
    Location
    Montevideo - Uruguay
    Posts
    106
    Rep Power
    7

    Default [SOLVED] Webmail password change.

    Hi,

    I want to allow the users to change their password throw the webmail.
    The access to the webmail is form webmail.mydomain.com but the Zimbra domain name is mail.mydomain.com.

    The thing is when I logon and the go to preferences -> "change password", the popup windows wants to open mail.mydomain.com insted of webmail.mydomain.com and gives an error.

    What could it be?

    Thanks.
    Andres
    --
    AGD

  2. #2
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    What does your mailbox.log say ?

  3. #3
    Join Date
    Jul 2008
    Location
    Montevideo - Uruguay
    Posts
    106
    Rep Power
    7

    Default

    2009-06-10 14:55:51,018 INFO [Pop3Server-20528] [] ProtocolHandler - Handler exiting normally
    2009-06-10 14:55:54,964 INFO [btpool0-16] [ip=192.168.1.230;] soap - AuthRequest
    2009-06-10 14:55:56,720 INFO [IndexWritersSweeperThread] [] index - open index writers sweep: before=15, closed=3, after=12 (208ms)
    2009-06-10 14:55:58,914 INFO [btpool0-8] [oip=190.134.165.108;ua=zclient/5.0.14_GA_2850.RHEL5;] soap - AuthRequest
    2009-06-10 14:55:59,587 INFO [btpool0-8] [oip=190.134.165.108;ua=zclient/5.0.14_GA_2850.RHEL5;] soap - AuthRequest
    2009-06-10 14:55:59,605 INFO [btpool0-8] [name=recepcion@mydomain.com;mid=132;oip=190.134.16 5.108;ua=zclient/5.0.14_GA_2850.RHEL5;] soap - BatchRequest
    2009-06-10 14:55:59,605 INFO [btpool0-8] [name=recepcion@mydomain.com;mid=132;oip=190.134.16 5.108;ua=zclient/5.0.14_GA_2850.RHEL5;] soap - (batch) GetInfoRequest
    2009-06-10 14:56:00,022 INFO [btpool0-8] [name=recepcion@mydomain.com;mid=132;oip=190.134.16 5.108;ua=zclient/5.0.14_GA_2850.RHEL5;] soap - (batch) SearchRequest
    2009-06-10 14:56:20,960 INFO [btpool0-13] [name=recepcion@mydomain.com;mid=132;ip=190.134.165 .108;ua=ZimbraWebClient - FF3.0 (Win)/5.0.14_GA_2850.RHEL5;] soap - SearchRequest
    --
    AGD

  4. #4
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    > The thing is when I logon and the go to preferences -> "change password", the popup windows wants to open mail.mydomain.com insted of webmail.mydomain.com and gives an error.

    Well if you want to open as webmail.mydomain.com the better set your public service hostname to webmail.mydomain.com and then it will open with public service hostname

  5. #5
    Join Date
    Jul 2008
    Location
    Montevideo - Uruguay
    Posts
    106
    Rep Power
    7

    Default

    Ok, sounds that's the solution.
    You mean DNS config. or Zimbra ??
    --
    AGD

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Or add it as a virtual host in the Admin GUI->Domains->Virtual Hosts tab.

  7. #7
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Post

    I happen to test with virtual hostname but somehow it doesnot take virtual hostname, rather takes hostname of machine. Setting Public service hostname does work.

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Cool which is odd though as I do similar myself but use Virtual Hosts.

  9. #9
    Join Date
    Jul 2008
    Location
    Montevideo - Uruguay
    Posts
    106
    Rep Power
    7

    Default

    I added the virtual host, but is still doesn't working.
    The thing I can access to webmail.mydomain.com, but when I log in at the webmail and try to change de password (from preferences) the password change window popup redirect to mail.mydomain.com and ask to authenticate again. The popup should remain at webmail.mydomain.com.
    --
    AGD

  10. #10
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    zmprov md mydomain.com zimbraPublicServiceHostname webmail.mydomain.com

    This works on 5.0.16 with or without setting a zimbraVirtualHostname.

    Bug 31844 - change password ignores zimbraPublicService* was supposed to be fixed in 5.0.10 (ironical same as your profile string). I'll fire up a vm to double check if it doesn't work for you.


    Also of note if you use multiple domains: Per Bug 36224 - Hosted: Change Password Form Problems you might have to switch the field 'user' to 'user@domain.com'.
    Last edited by mmorse; 06-13-2009 at 12:37 AM.

Similar Threads

  1. New User/Must Change Password oddity...
    By ssatre in forum Administrators
    Replies: 5
    Last Post: 07-26-2009, 12:19 AM
  2. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 05:42 PM
  3. [SOLVED] "zimbra" user password change.
    By nishith in forum Administrators
    Replies: 3
    Last Post: 08-27-2008, 02:27 AM
  4. Replies: 4
    Last Post: 12-13-2007, 10:18 AM
  5. AD Ctrl-alt-del Change Password Breaks Zimbra
    By pgp4privacy in forum Administrators
    Replies: 3
    Last Post: 10-12-2007, 03:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •