Results 1 to 7 of 7

Thread: why won't ldap start?

Threaded View

  1. #1
    Join Date
    Apr 2006
    Posts
    13
    Rep Power
    9

    Default why won't ldap start?

    ok something is really screwed up now.

    I just got finished working trying to get my MRTG graphs fixed. Then some of our users where having trouble logging into IMAP through SSL (it would time out and report to the client that SSL was not running when it was). So I went to the admin console and enabled clear text logins while I tried to figure out why ssl was messed up. I did this for the IMAP settings both in the global config and server config. Then I restarted zimbra and I get this message.

    Host *.*.*
    Starting ldap...Done.
    FAILED
    db_recover: Finding last valid log LSN: file: 1 offset 5488091
    db_recover: Recovery starting from [1][5487967]
    db_recover: Recovery complete at Thu May 18 14:45:47 2006
    db_recover: Maximum transaction ID 80000016 Recovery checkpoint [1][5488091]
    ERROR - failed to start slapd

    What I try to run zmcontrol start this is what /var/log/zimbra.log shows:

    May 18 14:54:02 lima zimbramon[3608]: 3608:info: Starting services
    May 18 14:54:04 lima slapd[3674]: @(#) $OpenLDAP: slapd 2.3.20 (Mar 9 2006 15:10:13) $ root@build.liquidsys.com:/hom
    e/build/p4/main/ThirdParty/openldap/openldap-2.3.20/servers/slapd

    I think that is the only file with anything reporting as to zimbra's boot status.

    What the heck just happened?

    p.s. I've also been wondering, and have not yet found, is there any solid documentation on that what log files report what for zimbra?

    Edit: If it's any help this is the output of sh -x /zimbrahome/bin/ldap start

    [zimbra@lima ~]$ sh -x bin/ldap start
    + PID=
    + PIDFILE=/opt/zimbra/openldap/var/run/slapd.pid
    + mkdir -p /opt/zimbra/openldap/var/run/
    + case "$1" in
    + start
    + checkrunning
    + getpid
    + '[' -f /opt/zimbra/openldap/var/run/slapd.pid ']'
    + '[' x = x ']'
    + RUNNING=0
    + '[' 0 = 0 ']'
    + '[' '!' -f /opt/zimbra/openldap-data/DB_CONFIG ']'
    + /opt/zimbra/libexec/zmconfigure /opt/zimbra/conf/slapd.conf.in /opt/zimbra/conf/slapd.conf
    + '[' -x /opt/zimbra/sleepycat/bin/db_recover ']'
    + /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data -v
    db_recover: Finding last valid log LSN: file: 1 offset 5488355
    db_recover: Recovery starting from [1][5488231]
    db_recover: Recovery complete at Thu May 18 15:05:40 2006
    db_recover: Maximum transaction ID 80000016 Recovery checkpoint [1][5488355]
    + sudo /opt/zimbra/openldap-2.3.20/libexec/slapd -l LOCAL0 -4 -u zimbra -h 'ldaps:// ldap://:389/' -f /opt/zimbra/conf/slapd.conf
    + sleep 2
    + getpid
    + '[' -f /opt/zimbra/openldap/var/run/slapd.pid ']'
    + '[' x = x ']'
    + echo 'ERROR - failed to start slapd'
    ERROR - failed to start slapd
    + echo ''

    + exit 1
    Last edited by vaneck; 05-18-2006 at 01:04 PM.

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  3. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 02:39 PM
  4. LDAP won't start after reboot
    By cdyer in forum Administrators
    Replies: 0
    Last Post: 06-13-2006, 12:52 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •