Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 52

Thread: [SOLVED] Cant send mail-Pls help

  1. #31
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    Quote Originally Posted by ask2me007 View Post
    Dear Phoenix

    As you said i checked firewall ,and there is no firewall loaded here.

    root@pop:~# sudo ufw status
    Firewall not loaded
    And the apparmor disabled by using the following commands

    sudo /etc/init.d/apparmor stop
    sudo update-rc.d -f apparmor remove

    Any way the problem i still there

    Jun 19 19:05:04 pop postfix/smtp[11562]: EAD18802336: to=<ask2me007@gmail.com>, relay=none, delay=0.08, delays=0.08/0.01/0/0, dsn=4.4.1, status=deferred (connect to 59.93.43.183[59.93.43.183]: Connection refused)


    zimbra@pop:/root$ cat /etc/nsswitch.conf
    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.

    passwd: compat
    group: compat
    shadow: compat

    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
    networks: files

    protocols: db files
    services: db files
    ethers: db files
    rpc: db files

    netgroup: nis

  2. #32
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    In your /etc/nsswitch.conf file I'd suggest you modify this line:

    Code:
    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
    to look like this:

    Code:
    hosts:   files dns
    then reboot your server and see if that fixes the problem.

    If that works then you should change the following service in Ubuntu: mDNS/ZeroConf/Bonjour (or whatever it's called), disable or uninstall it as that's causing the problem of the modified nsswitch.conf file. If you do remove it make sure you check the nsswitch.conf file and that it's still set correctly to the new line I've given you above.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #33
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    In your /etc/nsswitch.conf file I'd suggest you modify this line:

    Code:
    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
    to look like this:

    Code:
    hosts:   files dns
    then reboot your server and see if that fixes the problem.

    If that works then you should change the following service in Ubuntu: mDNS/ZeroConf/Bonjour (or whatever it's called), disable or uninstall it as that's causing the problem of the modified nsswitch.conf file. If you do remove it make sure you check the nsswitch.conf file and that it's still set correctly to the new line I've given you above.


    Bad luck again

    Jun 19 20:46:01 pop postfix/smtp[10470]: 29839802337: to=<ask2me007@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=5.8, delays=0.14/0.01/0.01/5.6, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as C70D4802338)
    Jun 19 20:46:01 pop postfix/qmgr[7332]: 29839802337: removed
    Jun 19 20:46:01 pop amavis[6666]: (06666-01) extra modules loaded: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/LDAP/Extension.pm, Net/SSLeay.pm
    Jun 19 20:46:01 pop postfix/smtp[10518]: C70D4802338: to=<ask2me007@gmail.com>, relay=none, delay=0.09, delays=0.08/0.01/0/0, dsn=4.4.1, status=deferred (connect to 59.93.43.183[59.93.43.183]: Connection refused)

  4. #34
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    Quote Originally Posted by ask2me007 View Post
    Bad luck again

    Jun 19 20:46:01 pop postfix/smtp[10470]: 29839802337: to=<ask2me007@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=5.8, delays=0.14/0.01/0.01/5.6, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as C70D4802338)
    Jun 19 20:46:01 pop postfix/qmgr[7332]: 29839802337: removed
    Jun 19 20:46:01 pop amavis[6666]: (06666-01) extra modules loaded: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/LDAP/Extension.pm, Net/SSLeay.pm
    Jun 19 20:46:01 pop postfix/smtp[10518]: C70D4802338: to=<ask2me007@gmail.com>, relay=none, delay=0.09, delays=0.08/0.01/0/0, dsn=4.4.1, status=deferred (connect to 59.93.43.183[59.93.43.183]: Connection refused)

    One more thing i have to say.It first says sentOk.Then the log again says connection refused.



    Jun 19 21:07:13 pop amavis[6673]: (06673-01) Passed CLEAN, LOCAL [192.168.10.5] [192.168.10.5] <ask@ksfe.com> -> <xxxxx@gmail.com>, Message-ID: <19167401.121245425828618.JavaMail.root@pop.ksfe.c om>, mail_id: CYmb4EdfKgoO, Hits: 3.805, size: 608, queued_as: C4DFC802340, 4947 ms
    Jun 19 21:07:13 pop postfix/smtp[19711]: DAF4380233F: to=<xxxxx@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=5, delays=0.08/0.01/0.01/4.9, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as C4DFC802340)
    Jun 19 21:07:13 pop postfix/qmgr[7332]: DAF4380233F: removed
    Jun 19 21:07:13 pop amavis[6673]: (06673-01) extra modules loaded: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/LDAP/Extension.pm, Net/SSLeay.pm
    Jun 19 21:07:14 pop postfix/smtp[19716]: C4DFC802340: to=<xxxxxx@gmail.com>, relay=none, delay=0.12, delays=0.11/0/0/0, dsn=4.4.1, status=deferred (connect to 59.93.43.183[59.93.43.183]: Connection refused)

  5. #35
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    Dear Phoenix

    whether it may be a postfix problem?????
    How can i get a detailed log from zimbra

  6. #36
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by ask2me007 View Post
    Dear Phoenix

    whether it may be a postfix problem?????
    How can i get a detailed log from zimbra
    No, this isn't likely to be a postfix problem. Did you disable the mDNS/ZeroConf/Bonjour service as I mentioned earlier?

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes
    What happens when you run both of these commands (please post the output) on the Zimbra server:

    Code:
    telnet 192.168.10.5 25
    telnet  pop.ksfe.com 25
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #37
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    No, this isn't likely to be a postfix problem. Did you disable the mDNS/ZeroConf/Bonjour service as I mentioned earlier?

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes
    What happens when you run both of these commands (please post the output) on the Zimbra server:

    Code:
    telnet 192.168.10.5 25
    telnet  pop.ksfe.com 25
    I couldnt find any of them as you told.
    ie mDNS/ZeroConf/Bonjour
    i have listed by the command
    sudo aptitude search all
    but dodnt find anything.

    root@pop:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.10.5 pop.domain.com pop
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts


    root@pop:~# cat /etc/resolv.conf
    // replace example.com with your domain name, and 192.168.0.1 with the address of your new DNS server.
    //search domain.com
    nameserver 192.168.10.5



    ; <<>> DiG 9.4.2 <<>>domain mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 14709
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;
    ;; AUTHORITY SECTION:
    domain.com. 604800 IN SOA pop.domain.com. root.domain.com. 70745 604800 86400 2419200 604800

    ;; Query time: 0 msec
    ;; SERVER: 192.168.10.5#53(192.168.10.5)
    ;; WHEN: Fri Jun 19 23:23:49 2009
    ;; MSG SIZE rcvd: 75


    root@pop:~# dig domain any

    ; <<>> DiG 9.4.2 <<>> domain any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 27610
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;domain. IN ANY

    ;; AUTHORITY SECTION:
    domain.com. 604800 IN SOA pop.domain.com. root.domain.com. 70745 604800 86400 2419200 604800

    ;; Query time: 0 msec
    ;; SERVER: 192.168.10.5#53(192.168.10.5)
    ;; WHEN: Fri Jun 19 23:25:35 2009
    ;; MSG SIZE rcvd: 75



    root@pop:~# host `hostname`
    pop.domain.com has address 192.168.10.5


    root@pop:~# telnet 192.168.10.5 25
    Trying 192.168.10.5...
    Connected to 192.168.10.5.
    Escape character is '^]'.
    220 pop.domain.com ESMTP Postfix


    root@pop:~# telnet pop.domain.com 25
    Trying 192.168.10.5...
    Connected to pop.domain.com.
    Escape character is '^]'.
    220 pop.domain.com ESMTP Postfix
    Last edited by ask2me007; 06-19-2009 at 12:03 PM.

  8. #38
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by ask2me007 View Post
    root@pop:~# telnet 192.168.10.5 25
    Trying 192.168.10.5...
    Connected to 192.168.10.5.
    Escape character is '^]'.
    220 pop.domain.com ESMTP Postfix


    root@pop:~# telnet pop.domain.com 25
    Trying 192.168.10.5...
    Connected to pop.domain.com.
    Escape character is '^]'.
    220 pop.domain.com ESMTP Postfix
    OK, the output of these two commands indicate that you have Zimbra up and running OK on your server because you can connect to it.

    Quote Originally Posted by ask2me007 View Post
    root@pop:~# host `hostname`
    pop.domain.com has address 192.168.10.5
    The output of this command indicates that you can find the server correctly by it's FQDN.

    What is confusing is the fact that your dig commands aren't returning any valid A & MX records. Can you just post the exact command that you're using for the dig domain.com commands?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #39
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    I can send/receive mail locally.I can receive from outside.The only problem is i cant send to outside domain.

    Again it may be a DNS?????

  10. #40
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    zimbra@pop:/root$ dig domain.com mx

    ; <<>> DiG 9.4.2 <<>> domain.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14282
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;domain.com. IN MX

    ;; ANSWER SECTION:
    domain.com. 604800 IN MX 10 pop.domain.com.

    ;; AUTHORITY SECTION:
    domain.com. 604800 IN NS pop.domain.com.

    ;; ADDITIONAL SECTION:
    pop.domain.com. 604800 IN A 192.168.10.5

    ;; Query time: 0 msec
    ;; SERVER: 192.168.10.5#53(192.168.10.5)
    ;; WHEN: Fri Jun 19 23:45:19 2009
    ;; MSG SIZE rcvd: 76



    root@pop:~# dig domain.com any

    ; <<>> DiG 9.4.2 <<>> domain.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 56591
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;domain.com. IN ANY

    ;; AUTHORITY SECTION:
    domain.com. 604800 IN SOA pop.domain.com. root.domain.com. 70745 604800 86400 2419200 604800

    ;; Query time: 0 msec
    ;; SERVER: 192.168.10.5#53(192.168.10.5)
    ;; WHEN: Fri Jun 19 23:47:57 2009
    ;; MSG SIZE rcvd: 75



    root@pop:~# host `hostname`
    pop.domain.com has address 192.168.10.5

Similar Threads

  1. [SOLVED] mailbox and apache not running
    By rtwick in forum Administrators
    Replies: 4
    Last Post: 11-15-2008, 08:21 AM
  2. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 01:41 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  4. Tomcat broken after upgrade to 4
    By dotslashroot in forum Migration
    Replies: 13
    Last Post: 01-31-2007, 06:05 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •