Page 1 of 6 123 ... LastLast
Results 1 to 10 of 52

Thread: [SOLVED] Cant send mail-Pls help

  1. #1
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default [SOLVED] Cant send mail-Pls help

    I configured Zimbra in Ubuntu 8.0.4.Te zimbra version is

    My problem is when i send mail the zimbra log is as follows

    Jun 17 04:02:30 pop postfix/smtp[18737]: 4A1E980228E: to=<ask2me007@gmail.com>, relay=none, delay=334, delays=334/0.05/0/0, dsn=4.4.1, status=deferred (connect to 59.93.43.183[59.93.43.183]: Connection refused)

    I can send mail locally.

    The mx check using the Admin control panel was successful.
    The zimbra version is Release 5.0.16_GA_2921.UBUNTU8 UBUNTU8 FOSS edition.
    Pls help me.I have been trying to settle this problem for the past 28 hours.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

  3. #3
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    Quote Originally Posted by uxbod View Post
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes
    root@pop:~# cat /etc/hosts

    127.0.0.1 localhost.localdomain localhost
    #127.0.1.1 pop.omain.com pop
    192.168.10.5 pop.domain.com pop
    10.10.0.13 pop.domain.com pop


    $ cat /etc/resolv.conf
    nameserver 192.168.10.5




    root@pop:~# dig domain.com mx

    ; <<>> DiG 9.4.2 <<>> domain.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59052
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 3, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;domain.com. IN MX

    ;; ANSWER SECTION:
    domain.com. 1 IN MX 0 pop.domain.com.
    domain.com. 1 IN MX 10 pop.domain.com.

    ;; AUTHORITY SECTION:
    domain.com. 1 IN NS ns2.cdit.org.
    domain.com. 1 IN NS ns3.cdit.org.
    domain.com. 1 IN NS ns4.cdit.org.

    ;; ADDITIONAL SECTION:
    pop.domain.com. 1 IN A 59.93.43.183

    ;; Query time: 290 msec
    ;; SERVER: 192.168.10.5#53(192.168.10.5)
    ;; WHEN: Thu Jun 18 18:52:53 2009
    ;; MSG SIZE rcvd: 140


    root@pop:~# dig domain.com any

    ; <<>> DiG 9.4.2 <<>> domain.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 3447
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 7, AUTHORITY: 3, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;domain.com. IN ANY

    ;; ANSWER SECTION:
    domain.com. 1 IN SOA ns3.cdit.org. hostmaster.cdit.org. 2002121945 10800 3600 604800 1
    domain.com. 1 IN A 216.55.97.83
    domain.com. 1 IN NS ns3.cdit.org.
    domain.com. 1 IN NS ns4.cdit.org.
    domain.com. 1 IN NS ns2.cdit.org.
    domain.com. 1 IN MX 0 pop.domain.com.
    domain.com. 1 IN MX 10 pop.domain.com.

    ;; AUTHORITY SECTION:
    domain.com. 1 IN NS ns3.cdit.org.
    domain.com. 1 IN NS ns4.cdit.org.
    domain.com. 1 IN NS ns2.cdit.org.

    ;; ADDITIONAL SECTION:
    pop.domain.com. 1 IN A 59.93.43.183

    ;; Query time: 311 msec
    ;; SERVER: 192.168.10.5#53(192.168.10.5)
    ;; WHEN: Thu Jun 18 18:55:31 2009
    ;; MSG SIZE rcvd: 245


    root@pop:~# host `hostname`
    pop.domain.com has address 59.93.43.183

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    This record should point to your LAN IP address:

    Code:
    pop.domain.com. 1 IN A 59.93.43.183
    You also don't need two MX records for the same server, remove the first one:

    Code:
    domain.com. 1 IN MX 0 pop.domain.com.
    domain.com. 1 IN MX 10 pop.domain.com.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Smile

    Quote Originally Posted by phoenix View Post
    This record should point to your LAN IP address:

    Code:
    pop.domain.com. 1 IN A 59.93.43.183
    You also don't need two MX records for the same server, remove the first one:

    Code:
    domain.com. 1 IN MX 0 pop.domain.com.
    domain.com. 1 IN MX 10 pop.domain.com.
    Can you specify that where is the problem?
    is it DNS?
    or how can i get rid of this??
    Thanks in advance....

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I've just told you what needs changing in your DNS records.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    I've just told you what needs changing in your DNS records.

    Sorry for the trouble.

    Iam a newbie in linux.could you pls tell me any howtos/link, to configure DNS under NAT???
    Awaiting your reply........

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Who configured the DNS server in your LAN?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    Who configured the DNS server in your LAN?
    I tried a how to from net to configure dns.Since it was a failure as you said,today i tried this one
    Ubuntu DNS Server Guide - BIND Caching Name Server Setup : Zaphu

    But thats again a flop.

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by ask2me007 View Post
    I tried a how to from net to configure dns.Since it was a failure as you said,today i tried this one
    Ubuntu DNS Server Guide - BIND Caching Name Server Setup : Zaphu

    But thats again a flop.
    No, I didn't say it was a failure it's only slightly wrong but just enough to cause a problem. Have a look at this article and see if you can find the files needed to make the changes I've mentioned.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. [SOLVED] mailbox and apache not running
    By rtwick in forum Administrators
    Replies: 4
    Last Post: 11-15-2008, 08:21 AM
  2. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 01:41 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  4. Tomcat broken after upgrade to 4
    By dotslashroot in forum Migration
    Replies: 13
    Last Post: 01-31-2007, 06:05 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •