Results 1 to 7 of 7

Thread: [SOLVED] Change Password Not Working

  1. #1
    Join Date
    Mar 2009
    Posts
    11
    Rep Power
    6

    Default [SOLVED] Change Password Not Working

    Hello All,

    Hope someone can help. My user complain the Change Password not working and here is the scenario.

    My server is only accessible using https://webmail.foobar.com, when user click on Change Password, it link to https://pop.foobar.com (where pop.foobar.com is the actual server hostname). With this, it open a new window and ask user to login again instead of the change password screen appear. The workaround now is to ask user to login again using this popup window, thereafter close it and click the change password again on the old window and it will work.

    I have DNS pointing to webmail and pop, but we want the user to use the webmail URL instead of the pop URL. I do not want to change the hostname to webmail worrying it will crash the whole server.

    Anyway that this can be resolve? Appreciate any advice. I am running 5.0.16-64-bit Opensource Edition.

    Thanks,
    SY

  2. #2
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    You really should have the dns and hostname the same, as it avoids the problem you are experiencing. I'd suggest changing one or the other.

  3. #3
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    You need to set zimbraPublicServiceName. The "change password" page would then be accessible by your zimbraPublicServiceName.

  4. #4
    Join Date
    Mar 2009
    Posts
    11
    Rep Power
    6

    Default

    Hello,

    How to set the zimbraPublicServiceName? I run the zmprov getAllConfig and don't see this setting in there? Please advise.

  5. #5
    Join Date
    Mar 2009
    Posts
    11
    Rep Power
    6

    Default

    I found the setting in the Admin console, it is blank, so I presume it uses the server hostname.

    I change to webmail.foobar.com and now my Change Password is accessing through http protocol, but my server only serve https. When it is the original pop.foobar.com, I can see it is accessing using https.

    Please help.

  6. #6
    Join Date
    Mar 2009
    Posts
    11
    Rep Power
    6

    Default

    Help...My management is coming after me because change password cannot work!!!

    Appreciate any help. Thanks.

  7. #7
    Join Date
    Jan 2008
    Posts
    658
    Rep Power
    8

    Default

    Sounds like you also need to set the zimbraPublicServiceProtocol for your domain as well. As the Zimbra user:

    Code:
    zmprov md <domain> zimbraPublicServiceProtocol https

Similar Threads

  1. Change Password not working with Active Directory
    By pornsakb in forum Administrators
    Replies: 8
    Last Post: 05-15-2011, 12:41 AM
  2. New User/Must Change Password oddity...
    By ssatre in forum Administrators
    Replies: 5
    Last Post: 07-25-2009, 11:19 PM
  3. Change password not working ?
    By Klug in forum General Questions
    Replies: 1
    Last Post: 03-18-2008, 09:44 AM
  4. [SOLVED] Change password not working in https
    By acdc1982 in forum Administrators
    Replies: 12
    Last Post: 12-30-2007, 10:15 PM
  5. Replies: 4
    Last Post: 12-13-2007, 09:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •