Results 1 to 3 of 3

Thread: mailboxd_java_heap_memory_percent for 32GB ram server?

  1. #1
    Join Date
    Mar 2007
    Posts
    95
    Rep Power
    8

    Default mailboxd_java_heap_memory_percent for 32GB ram; constant load of 3 to 3.5

    We've noticed that top reports back a steady load of 3 since we migrated about 50+ accounts over from postfix to this new zimbra server. It's been working like a champ, I just want to tidy up things if possible or maybe just optimize/lower the load/memory/cpu usage for Mother Earth.

    My questions are:

    1) why the constant load of 3?

    2) since I have 32GB, maybe lowering mailboxd_java_heap_memory_percent to say 20 or 15 percent would make sense? The last server I worked on, had lesser hardware and 4x the number of users.

    3) memory usage is constantly about 90% -- IIRC this is "by design" but I forget the correct reasons. Something to do with how java works and how it needs to cache a lot of memory to speed up java'ish stuff.

    4) we have heavy IMAP usage here (only one outlook user to my relief), is there anything I should consider tweaking? Nothing is broke so for this question, I'm mostly looking for what I can think over, not really take action on.

    Specs of the box are:

    32GB memory
    RAID 10
    kernel 2.6.24-23
    zcs-NETWORK-5.0.15_GA_2851.UBUNTU8_64.20090310194234

    Usage observed at 2pm on a weekday last week was 81 IMAP, 10 web.

    Here's some of the settings I have, all of which are default from zimbra:

    Code:
    data_source_max_message_memory_size = 2097152
    mailboxd_java_heap_memory_percent = 30
    mysql_memory_percent = 40
    javamail_imap_debug = false
    javamail_imap_enable_starttls = true
    javamail_imap_timeout = 60
    javamail_pop3_debug = false
    javamail_pop3_enable_starttls = true
    javamail_pop3_timeout = 60
    javamail_smtp_debug = false
    javamail_smtp_enable_starttls = true
    javamail_smtp_timeout = 60
    mailboxd_java_heap_memory_percent = 30
    mailboxd_java_home = ${zimbra_java_home}
    mailboxd_java_options = -client -XX:NewRatio=2 -Djava.awt.headless=true -XX:MaxPermSize=128m -XX:SoftRefLRUPolicyMSPerMB=1
    mailboxd_truststore = ${zimbra_java_home}/lib/security/cacerts
    zimbra_java_home = ${zimbra_home}/${zimbra_java_path}
    zimbra_java_path = java
    Last edited by gettyless; 06-22-2009 at 11:23 AM. Reason: unclear title

  2. #2
    Join Date
    Mar 2007
    Posts
    95
    Rep Power
    8

    Default

    also here's my innodb stats:

    Code:
    ----------------------
    BUFFER POOL AND MEMORY
    ----------------------
    Total memory allocated 8463462130; in additional pool allocated 1048576
    Buffer pool size   464192
    Free buffers       397272
    Database pages     63535
    Modified db pages  0
    Pending reads 0
    Pending writes: LRU 0, flush list 0, single page 0
    Pages read 51518, created 12040, written 3238310
    0.00 reads/s, 0.00 creates/s, 18.44 writes/s
    Buffer pool hit rate 1000 / 1000

  3. #3
    Join Date
    Mar 2007
    Posts
    95
    Rep Power
    8

    Default

    I guess this is some random java memory usage/leak issue? I upgraded to zcs-NETWORK-5.0.16_GA_2921.UBUNTU8_64.20090429025807 on July 3rd and since then load is way down to under 1 even during peak hours (at least for today, the first normal business day afterwards).

    No other settings were changed. I probably should have just rebooted before I upgraded to verify behavior.

    hmmm.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Error after installation
    By robsontuxlinux in forum Installation
    Replies: 13
    Last Post: 09-11-2008, 09:48 PM
  3. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  4. Replies: 0
    Last Post: 07-17-2007, 07:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •