Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Start services on boot

  1. #1
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default Start services on boot

    Hi, quick easy question for you all.

    I've a Zimbra 3.1.1 installation on Suse10.0

    When I reboot the server, the zimbra services do not start. In order to get them running, I log in and type
    su - zimbra
    zmcontrol start


    I've had a look around the forum for other mentions of this and found very little. Other than this issue, the server seems to be working great, I'd just like the services to start when the computer does, just incase of a power outage or something like it.

    Any advice?

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Hi,
    This is a known bug.
    http://bugzilla.zimbra.com/show_bug.cgi?id=7259

    You can subscribe to the bug to know it's status.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Does this thread answer your question?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Thanks guys, I actualy found the quoted thread but didnt check bugzilla for the details, so I incorrectly assumed that it was a bug specific to the installation on CentOS.

    I guess we all wait for version 3.1.2 then?

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Well, you can fix it yourself, if you wish.

    Other than that....yup wait for the latest release

  6. #6
    Join Date
    Jun 2006
    Posts
    6
    Rep Power
    9

    Default

    I just installed Zimbra on SuSE 10 and found out the following:

    In my opinion, the reason why zimbra does not start correctly after reboot is,
    that the previous PID-file is still there.
    SuSE seems to think that zimbra hang up.

    Nevertheless, i just placed my own /etc/init.d/zimbra file containing the following:

    if /path/to/zimbra/libexec/zimbra restart
    then
    exit 0
    else
    exit 1
    fi

    and it seems to work fine.
    It's importand to to say "restart" and not "start" there.

  7. #7
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    An update on this one, I still dont have a zimbra server that starts on boot.

    I have the one in work, and the one at home, neither auto start the zimbra services when rebooted. The home server has taken to rebooting itself in the middle of the night (or day for that matter) so having zimbra start is now important.

    Both servers run Suse 10.0 and Zimbra 3.1.4

    I have seached the forum, I've read the bugzilla entries, I've read the threads. I cant work it out.

    Could someone please tell me what needs to be done? I know it's not simply a case of adding the line <tt>zmcontrol start</tt> to the end of a script somewhere because I'm guessing the boot scripts run as root, and zimbra wont start that way.

    I'd really appreciate an easy to follow and complete answer on this one, as I was hoping that when we upgraded to 3.1.2 that would have fixed the issue.

  8. #8
    Join Date
    May 2006
    Location
    Espírito Santo - Brasil
    Posts
    39
    Rep Power
    9

    Default

    In the Fedora Core 4, we are using in the following way:

    It creates an archive with the name zimbra-init, in the diretorio /etc/init.d with the following content:

    #!/bin/bash
    #
    # zimbra This shell script takes care of starting and stopping
    # zimbra.

    # chkconfig: 235 65 40
    # description: Esse script é apenas um exemplo de scripts SYSV
    #


    # Source function library.
    . /etc/rc.d/init.d/functions

    # Source networking configuration.
    [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network

    # Check that networking is up.
    [ "${NETWORKING}" = "no" ] && exit 0

    RETVAL=0
    prog="zimbra"

    start() {
    # Start daemons.

    echo -n $"Starting $prog: "
    su -l zimbra -c '/opt/zimbra/bin/zmcontrol start'

    }

    maintenance() {
    # Stop daemons.
    echo -n $"Maintenance $prog: "
    su -l zimbra -c '/opt/zimbra/bin/zmcontrol maintenance'

    }

    stop() {
    # Stop daemons.
    echo -n $"Shutting down $prog: "
    su -l zimbra -c '/opt/zimbra/bin/zmcontrol stop'
    }

    status() {
    # Stop daemons.
    echo $"$prog status"
    su -l zimbra -c '/opt/zimbra/bin/zmcontrol status'
    }

    # See how we were called.
    case "$1" in
    start|startup)
    start
    ;;
    stop|shutdown)
    stop
    ;;
    restart)
    stop
    start
    ;;
    status)
    status
    ;;
    esac

    With the command, ntsysv, marks the option “Zimbra”, e in boot anger to initiate.

    It forgives my English, I used a translation tool.

  9. #9
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Thanks aabreu2005, I appreciate it - unfortunatly it's all greek to me.

    I'll start doing some more research into this as it currently makes no sense. I can start zimbra with a single command, from a specific user, so I dont understand why I cant do it like in DOS, simply adding the lines
    Code:
    su zimbra
    zmcontrol start
    to the end of an existing file (autoexec.bat in the case of DOS)

    I know things are different in linux, different is fine, does it have to be hard too?

  10. #10
    Join Date
    May 2006
    Location
    Espírito Santo - Brasil
    Posts
    39
    Rep Power
    9

    Default

    You need create an archive with the name zimbra-init, in the diretorio /etc/init.d with the following content:

    #!/bin/bash
    #
    # zimbra This shell script takes care of starting and stopping
    # zimbra.

    # chkconfig: 235 65 40
    # description: Esse script é apenas um exemplo de scripts SYSV
    #


    # Source function library.
    . /etc/rc.d/init.d/functions

    # Source networking configuration.
    [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network

    # Check that networking is up.
    [ "${NETWORKING}" = "no" ] && exit 0

    RETVAL=0
    prog="zimbra"

    start() {
    # Start daemons.

    echo -n $"Starting $prog: "
    su -l zimbra -c '/opt/zimbra/bin/zmcontrol start'

    }

    maintenance() {
    # Stop daemons.
    echo -n $"Maintenance $prog: "
    su -l zimbra -c '/opt/zimbra/bin/zmcontrol maintenance'

    }

    stop() {
    # Stop daemons.
    echo -n $"Shutting down $prog: "
    su -l zimbra -c '/opt/zimbra/bin/zmcontrol stop'
    }

    status() {
    # Stop daemons.
    echo $"$prog status"
    su -l zimbra -c '/opt/zimbra/bin/zmcontrol status'
    }

    # See how we were called.
    case "$1" in
    start|startup)
    start
    ;;
    stop|shutdown)
    stop
    ;;
    restart)
    stop
    start
    ;;
    status)
    status
    ;;
    esac


    With the command, ntsysv, marks the option “Zimbra”, and then reboot the machine. The Zimbra must be initiate automatically ...

    It´s really different in Linux World...

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Zimbra .pids / service monitoring
    By bin2hex in forum Administrators
    Replies: 24
    Last Post: 04-03-2010, 10:12 PM
  3. Unable to start services.
    By Russellstrei in forum Installation
    Replies: 5
    Last Post: 06-15-2007, 03:34 PM
  4. start on boot problem
    By vaneck in forum Administrators
    Replies: 6
    Last Post: 05-03-2006, 02:40 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •