Results 1 to 4 of 4

Thread: Delete lost messages

  1. #1
    Join Date
    Dec 2008
    Posts
    6
    Rep Power
    7

    Question Delete lost messages

    Hi There,
    During a failed attempt to upgrade the hardware of the production server I have lost the HSM drive to a nasty crush.
    It is not a disaster to the company, but I have to tidy up things in order to let the users carry on working without errors.
    Currently if they go back in their inbox previous to the HSM cutover date, they can see messages which they cannot open, since the BLOB of the message is lost.
    This is obvious however, I tried few mailboxes and done the reindex mailbox, however it didn't solve the problem. It still doesn't delete these messages or pointers to the messages.

    Does anyone have an idea of how to remove all the "lost" messages from all the mailboxes in one process?

    Thank you very much for your help,
    Best Regards,
    Dvir

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Well, first of all to ascertain the full impact you could run
    Code:
    su - zimbra
    zmblobchk
    It would also be helpful if you would update your profile with the following output so we know which version of ZCS you are running
    Code:
    su - zimbra
    zmcontrol -v
    Well, there is probably a easier way of doing what I am going to describe but here goes anyway
    Code:
    su - zimbra
    zmvolume -l    * this will list all your volumes so you can see which is your HSM
    mysql
    use mboxgroup1;
    select * from mail_item where volume_id = '3'   * obviously change the volume_id to be your HSM one.
    You could then delete all the mail items that are in your HSM but do not have any data files. You will need to do this for all the 10 mboxgroups and then re-index once completed. Alternatively, you may just be able to remove the HSM store and all the referencial data will be updated accordingly.

    NO warranty comes with any of this as I personally keep good backups
    Last edited by uxbod; 07-04-2009 at 04:54 AM.

  3. #3
    Join Date
    Dec 2008
    Posts
    6
    Rep Power
    7

    Default Zimbra Version...

    Using the latest NE Version.

    5.0.16

    On RHEL 4 Machine.

    Will the blob check also remove or only display the problem?
    Is there a flag to activating a removal of invalid blobs?

  4. #4
    Join Date
    Dec 2008
    Posts
    6
    Rep Power
    7

    Default Backups

    Quote Originally Posted by uxbod View Post
    NO warranty comes with any of this as I personally keep good backups
    You right, me too, it's all backed up on the users' machines and already done archiving on these machines. That's why I wrote that it is not really a problem that the information is lost.
    I didn't expect the storage device to fail on me like that, but nothing really important is lost, as all the important mailboxes are backuped seperately.

    Thank you for the input, will give it a shot on Monday.

Similar Threads

  1. [SOLVED] Re-creating the spam training e-mail account
    By richard-hdd in forum Administrators
    Replies: 21
    Last Post: 03-20-2012, 08:34 AM
  2. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  3. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  4. Spam assassain not traiing properly!
    By Mike T in forum Administrators
    Replies: 1
    Last Post: 10-09-2006, 02:34 PM
  5. Can't delete messages in Outlook Express
    By mond in forum Administrators
    Replies: 2
    Last Post: 10-05-2006, 03:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •