Hello Guys,

I am being bothered by this problem of our zimbra server. Once upon a time, this server is working properly. But now all the I email that I try to send out goes into the Junk mail of the recipient. Can someone help me on this. I am not sure where to start. Here is the Header from yahoo mail

Return-Path: <xxxxx@zimbraserver.com>
Authentication-Results: mta194.mail.sp2.yahoo.com from=zimbraserver.com; domainkeys=neutral (no sig); from=zimbraserver.com; dkim=neutral (no sig)
Received: from 98.137.54.227 (EHLO mail.zimbraserver.com) (X.X.X.X) by mta194.mail.sp2.yahoo.com with SMTP; Thu, 09 Jul 2009 23:39:09 -0700
Received: from localhost (localhost.localdomain [127.0.0.1]) by mail.zimbraserver.com (Postfix) with ESMTP id 177D042C0301 for <idunnohow@yahoo.com>; Fri, 10 Jul 2009 14:33:37 +0800 (PHT) tests=[ALL_TRUSTED=-1.8, AWL=0.518, BAYES_00=-2.599]
Received: from mail.zimbraserver.com ([127.0.0.1]) by localhost (mail.zimbraserver.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ZoUeaguc6Aw9 for <idunnohow@yahoo.com>; Fri, 10 Jul 2009 14:33:26 +0800 (PHT)
Received: from mail.zimbraserver.com (mail.zimbraserver.com [X.X.X.X]) by mail.zimbraserver.com (Postfix) with ESMTP id AB60042C02EA for <idunnohow@yahoo.com>; Fri, 10 Jul 2009 14:33:26 +0800 (PHT)
Date: Fri, 10 Jul 2009 14:33:26 +0800 (PHT)
From:
"YYYYYYY" <yyyy@zimbraserver.com>
Add sender to Contacts
To: idunnohow@yahoo.com
Message-ID: <26517993.91247207606638.JavaMail.root@mail.zimbra server.com>
Subject: Schedule of Meeting for tomorrow
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 7bit
Content-Length: 53