Reporting back on my results.

I tried one last thing before doing the whole reinstall + change of mx which solved my issue.

I had changed the master.cf.in file of postfix to make it listen on a different port (in this case 2025). I made the mistake of commenting out the smtp port.

I realized today that the webmail mta port did not change to follow that port but had remained on port 25 so, since I read up yesterday on the zimbra desktop software and realized it used the web interface in a disguised fashion, I thought uncommenting smtp might solve the problem and it did.

So my mx record all work as they should as I had initially thought (and after double checking, the instructions about the "domain" mx came from a blog post from John on the zimbra blog) as I did not think changing the listening port would affect send capabilities.

So thanks for the help regardless. I appreciate it.

Hopefully, this can help others avoid my own mistakes - I'll edit the thread title to reflect the real problem for searches.