Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Send Problem after Upgrade

  1. #1
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default Send Problem after Upgrade

    I don't think my upgrade went all that smoothly even though I did not notice any errors and all services seem to start OK.

    Now I am getting this when I try and send to an external e-mail address. The message failes with a critical alert and this is in 'zimbra.log':

    2006-05-25 09:33:34,072 WARN [http-80-Processor99] [mid=150;ip=10.2.8.6;name=tbullock@avmax.ca;] MailSender - exception ocurred during SendMsg
    javax.mail.SendFailedException: Invalid Addresses;
    nested exception is:
    class com.sun.mail.smtp.SMTPAddressFailedException: 554 <rrriver31@yahoo.ca>: Relay access denied

    at com.sun.mail.smtp.SMTPTransport.rcptTo(SMTPTranspo rt.java:1141)
    at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTr ansport.java:536)
    at javax.mail.Transport.send0(Transport.java:151)
    at javax.mail.Transport.send(Transport.java:80)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:199)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:122)
    at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg. java:97)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:255)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:163)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:228)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:154)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)


    Any ideas?

    Cheers,

    Travis

  2. #2
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    Here is my main.cf

    content_filter = smtp-amavis:[127.0.0.1]:10024
    myhostname = webmail.avmax-internal.net
    recipient_delimiter =
    smtpd_sasl_auth_enable = yes
    smtpd_tls_auth_only = yes
    smtpd_use_tls = yes
    disable_dns_lookups = no
    message_size_limit = 20480000
    relayhost =
    mynetworks = 10.2.0.0/20, 10.2.16.0/20, 10.2.32.0/20, 10.3.0.0/20, 10.4.0.0/20, 10.0.0.0/16
    smtpd_recipient_restrictions = reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, permit
    alias_maps = hash:/etc/aliases
    broken_sasl_auth_clients = yes
    command_directory = /opt/zimbra/postfix-2.2.9/sbin
    daemon_directory = /opt/zimbra/postfix-2.2.9/libexec
    header_checks = pcre:/opt/zimbra/conf/postfix_header_checks
    mailq_path = /opt/zimbra/postfix-2.2.9/sbin/mailq
    manpage_directory = /opt/zimbra/postfix-2.2.9/man
    newaliases_path = /opt/zimbra/postfix-2.2.9/sbin/newaliases
    queue_directory = /opt/zimbra/postfix-2.2.9/spool
    sender_canonical_maps = ldap:/opt/zimbra/conf/ldap-scm.cf
    sendmail_path = /opt/zimbra/postfix-2.2.9/sbin/sendmail
    smtpd_client_restrictions = reject_unauth_pipelining
    smtpd_data_restrictions = reject_unauth_pipelining
    smtpd_helo_required = yes
    smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
    smtpd_tls_key_file = /opt/zimbra/conf/smtpd.key
    smtpd_tls_loglevel = 3
    transport_maps = ldap:/opt/zimbra/conf/ldap-transport.cf
    version = 2.2.9
    virtual_alias_domains = ldap://opt/zimbra/conf/ldap-vad.cf
    virtual_alias_maps = ldap:/opt/zimbra/conf/ldap-vam.cf
    virtual_mailbox_domains = ldap:/opt/zimbra/conf/ldap-vmd.cf
    virtual_mailbox_maps = ldap:/opt/zimbra/conf/ldap-vmm.cf
    virtual_transport = error

  3. #3
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    9

    Default

    It looks to me that postfix is having a problem sending to yahoo. Are you able to sent to other domains or do they all give that error?

  4. #4
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    I have tried two of my external accounts both with the same result. They were:

    rrriver31@yahoo.ca
    tbullock@telusplanet.net

    The zimbra.log shows the Relay Denied for both attempts.

    Now here is a brain fryer for you.

    I called up one of my users who is still using MS Outlook via POP3 and SMTP config to the Zimbra box. He successfully sent a test message to the rrriver31@yahoo.ca account.

    What do ya'all think?

    Cheers,

    Travis

  5. #5
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    I also had the same user use his Outlook to send to the @telusplanet.net account and the message arrives OK.

    When I tried the same from my Zimbra Firefox client, I get the reject message.

  6. #6
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    Ok.

    I had the same user who can successfully send to my external accounts previously mentioned, from Outlook, log into his Zimbra web client and try to send from there. When using his webclient, the messages fail with the same Relay Errors as stated before.

    Wierd and wild stuff.....

    Cheers,

    Travis

  7. #7
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    What's in /var/log/zimbra.log? Do you have customizations to the postfix config?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #8
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    Kevin,

    My first post has a extract from the 'zimbra.log' file. Is there something else I should check and post from that file?

    I also posted the 'main.cf' from the /opt/zimbra/postfix/config directory. The only customization I made there was the addition of the 'mynetworks = ' statement.

    Please help....

    Cheers,

    Travis

  9. #9
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default Please Help....Please...Help...Please Help....

    Can anyone help me with this?

    Problem summary:

    1. Upgraded to Release 3.1.1_GA_394.FC3_20060505121237 FC3 FOSS edition
    2. Clients using a Web interface cannot send e-mail to "external"addresses.
    3. Clients using Outlook and Outlook Express via SMTP can send to "external" address no problem.
    4. I don't want to feel like a complete idiot for telling all the people I talked into using the Zimbra web interface (because it rocks), that they have to now start using Outlook again.

    Cheers,

    Travis

  10. #10
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    10

    Default

    I comment the "mynetworks =" out of the 'main.cf' file and I am able to send out of my web interface.

Similar Threads

  1. Replies: 0
    Last Post: 03-26-2007, 03:12 AM
  2. 4.01 to 4.02 upgrade problem (with solution)
    By criley in forum Migration
    Replies: 2
    Last Post: 09-28-2006, 11:36 PM
  3. 3.1.3OS Upgrade Problem
    By mcevoys in forum Installation
    Replies: 7
    Last Post: 06-16-2006, 09:47 AM
  4. Mail send problem after upgrade
    By cutigersfan in forum Administrators
    Replies: 2
    Last Post: 05-13-2006, 06:28 PM
  5. Odd GA upgrade problem
    By drewage in forum Installation
    Replies: 2
    Last Post: 02-08-2006, 09:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •