Results 1 to 9 of 9

Thread: "NO APPEND failed" message when migrating mails

Hybrid View

  1. #1
    Join Date
    May 2006
    Posts
    2
    Rep Power
    9

    Default "NO APPEND failed" message when migrating mails

    Hi,

    We're currently trying to migrate all of aour mails from an existing Groupwise (linux) system to a newly installed trial edition of Zimbra NE.

    We are using imapsync to move mails via IMAP from one server to another. Unfortunately when running imapsync, we get failures on as much as 2/3's of the mails fro a given account, all failing with:

    Couldn't append msg #32 (Subject:XXXXXXX) to folder ZZZZ/yyyyy: Error trying to append: 1320 NO APPEND failed

    If I rerun imapsync on the same account it manages to copy some more of the mails, but still fails on some. For one account, I had to run the same imapsync script about 10 times, and that left a couple of mails that were impossible to copy. We get the same behaviour when trying to drag-and-drop mails from one imap account on one server to an account on zimbra, as soon as we take more than 3-5 mails in a single operation, so this error seems to be independent of the imapsync programme.

    The server is running on CentOS

    The only error messages I get in zimbra.log seem to be these:

    ######################################
    2006-05-28 16:50:08,482 WARN [LmtpServer-58] [] ParsedMessage - Parse error on MIME part 1 (text/plain, Message-ID: <20060528145001.BB10392C71@backup.lssj.dk>)
    com.zimbra.cs.mime.MimeHandlerException: cannot extract text
    at com.zimbra.cs.mime.handler.DefaultHandler.getConte ntImpl(DefaultHandler.java:92)
    at com.zimbra.cs.mime.MimeHandler.getContent(MimeHand ler.java:254)
    at com.zimbra.cs.mime.ParsedMessage.analyzePart(Parse dMessage.java:589)
    at com.zimbra.cs.mime.ParsedMessage.analyzeMessage(Pa rsedMessage.java:508)
    at com.zimbra.cs.mime.ParsedMessage.analyze(ParsedMes sage.java:252)
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:235 )
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver (ZimbraLmtpBackend.java:121)
    at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHa ndler.java:420)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:197)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:231)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:198)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: com.zimbra.cs.convert.ConversionException: Error loading shared library kvfilter.
    at com.zimbra.cs.convert.TransformationClient.extract (TransformationClient.java:179)
    at com.zimbra.cs.convert.SocketTransformationStub.doE xtract(SocketTransformationStub.java:99)
    at com.zimbra.cs.convert.SocketTransformationStub.ext ract(SocketTransformationStub.java:158)
    at com.zimbra.cs.mime.handler.DefaultHandler.getConte ntImpl(DefaultHandler.java:85)
    ######################################
    but I am unsure if they are in any way related.

    Any tips would be most welcome, as this could easily become a show-stopper to our migration plans.

    cheers

    /tomas

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Your missing a lib or two. Search on kvfilter or see the answer at the end of this thread.

    http://www.zimbra.com/forums/showthr...light=kvfilter
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Oct 2006
    Posts
    3
    Rep Power
    9

    Default Problem on Debian

    Hi, I also have the "NO APPEND" problem.
    I've read I had to install 'compat-libstdc++', but a apt-cache search compat-libstdc++ doesn't give me any results.

    I have also read things about kvfilter, but I have no clue what that is.

    Could you guys please give me any advice on what to do?

    These are some lines from /opt/zimbra/log/zimbra.log:
    (I've replaced my valid domain with 'mydomain.local')

    Code:
    2006-10-12 13:45:11,248 INFO  [ImapSSLServer-13] [ip=127.0.0.1;name=admin@mydomain.local;] FileBlobStore - deleting blob 1322 in mailbox 2
    2006-10-12 13:45:11,249 WARN  [ImapSSLServer-13] [ip=127.0.0.1;name=admin@mydomain.local;] imap - APPEND failed
    com.zimbra.cs.service.ServiceException: system failure: indexMessage caught IOException
            at com.zimbra.cs.service.ServiceException.FAILURE(ServiceException.java:174)
            at com.zimbra.cs.index.Indexer.indexMessage(Indexer.java:161)
            at com.zimbra.cs.mailbox.Message.reindex(Message.java:439)
            at com.zimbra.cs.mailbox.Mailbox.endTransaction(Mailbox.java:4303)
            at com.zimbra.cs.mailbox.Mailbox.addMessageInternal(Mailbox.java:3262)
            at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.java:3042)
            at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.java:3020)
            at com.zimbra.cs.imap.ImapAppendOperation.callback(ImapAppendOperation.java:114)
            at com.zimbra.cs.operation.Operation.schedule(Operation.java:190)
            at com.zimbra.cs.imap.ImapHandler.doAPPEND(ImapHandler.java:1160)
            at com.zimbra.cs.imap.ImapHandler.executeRequest(ImapHandler.java:342)
            at com.zimbra.cs.imap.ImapHandler.processCommand(ImapHandler.java:227)
            at com.zimbra.cs.tcpserver.ProtocolHandler.processConnection(ProtocolHandler.java:231)
            at com.zimbra.cs.tcpserver.ProtocolHandler.run(ProtocolHandler.java:198)
            at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Thread.java:595)
    Caused by: java.io.IOException: Could not create index /opt/zimbra/index/0/2/index/0 (directory already exists)
            at com.zimbra.cs.index.MailboxIndex.openIndexWriter(MailboxIndex.java:906)
            at com.zimbra.cs.index.MailboxIndex.addDocument(MailboxIndex.java:349)
            at com.zimbra.cs.index.Indexer.addDocument(Indexer.java:354)
            at com.zimbra.cs.index.Indexer.addDocument(Indexer.java:324)
            at com.zimbra.cs.index.Indexer.indexMessage(Indexer.java:156)
            ... 14 more
    Caused by: java.io.FileNotFoundException: /opt/zimbra/index/0/2/index/0/segments (Permission denied)
            at java.io.RandomAccessFile.open(Native Method)
            at java.io.RandomAccessFile.<init>(RandomAccessFile.java:212)
            at org.apache.lucene.store.FSInputStream$Descriptor.<init>(FSDirectory.java:376)
            at org.apache.lucene.store.FSInputStream.<init>(FSDirectory.java:405)
            at org.apache.lucene.store.FSDirectory.openFile(FSDirectory.java:268)
            at org.apache.lucene.index.SegmentInfos.read(SegmentInfos.java:40)
            at org.apache.lucene.index.IndexWriter$1.doBody(IndexWriter.java:233)
            at org.apache.lucene.store.Lock$With.run(Lock.java:109)
            at org.apache.lucene.index.IndexWriter.<init>(IndexWriter.java:228)
            at org.apache.lucene.index.IndexWriter.<init>(IndexWriter.java:173)
            at com.zimbra.cs.index.MailboxIndex.openIndexWriter(MailboxIndex.java:887)
            ... 18 more
    2006-10-12 13:45:11,263 INFO  [ImapSSLServer-13] [] ProtocolHandler - Handler exiting normally
    2006-10-12 13:45:50,857 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=1, after=0 (0ms)
    2006-10-12 13:48:43,797 INFO  [ImapSSLServer-5] [ip=10.10.1.50;name=admin@mydomain.local;] cache - Initializing folder and tag caches for mailbox 2
    zimbra:~#

  4. #4
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default Permissions issue

    TvL, you have a permissions problem:
    Code:
    Caused by: java.io.FileNotFoundException: /opt/zimbra/index/0/2/index/0/segments (Permission denied)
    Search the forums for the script that'll fix that...
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Join Date
    Oct 2006
    Posts
    3
    Rep Power
    9

    Default

    You are right!!!

    I was using imapsync and cancelled with CTRL+C.
    The segments file was owned by "root root".
    I have no clue why.
    I have changed the owner to zimbra:zimbra and it seems OK now...

  6. #6
    Join Date
    Sep 2005
    Posts
    20
    Rep Power
    10

    Default

    Are you using Debian ?

    raj
    Release 4.0.2_GA_362.RHEL4_20060924201056 CentOS4 FOSS edition

Similar Threads

  1. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  2. Replies: 42
    Last Post: 08-11-2006, 10:50 AM
  3. Replies: 4
    Last Post: 08-10-2006, 11:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •