Results 1 to 6 of 6

Thread: zimbra 5.0.18 lightning 0.9 on tb 2.0.0.22 - Modification Failed

Hybrid View

  1. #1
    Join Date
    Sep 2008
    Posts
    134
    Rep Power
    7

    Default zimbra 5.0.18 lightning 0.9 on tb 2.0.0.22 - Modification Failed

    Hi,

    i am running Zimbra 5.0.18 on Ubuntu8.04 amd64.
    having Thunderbird 2.0.0.22 with Lightning 0.9 clients.

    the Urls are connected via https Apache Reverse Proxy.

    Read/write works with ics and caldav for the own calendar.

    There aren't any write's possible to a shared Calendar, it had fist a space included with %20 which i removed.

    Read's are possible on the shared calendar, but when modify i get:
    MODIFICATION_FAILED

    But the Calendar has write permission, as it works within the Webui.

    in Lightning i removed currently the private Calendar as there seems to be an bug within TB, when using HTTPS and more than one Calendar to the same server?

    but still no write permission.

    any ideas?
    thomas
    zmcontrol -v
    1x Release 6.0.10_GA_2692.UBUNTU8_64 NETWORK edition.
    1x Release 6.0.14_GA_2928.UBUNTU8_64 NETWORK edition
    2x Release 7.1.3_GA_3346.UBUNTU10_64 NETWORK edition, Patch 7.1.3_P1
    1x Release 8.0.2.GA.5569.UBUNTU12.64 NETWORK edition

    2x Release 6.0.10_GA_2692.UBUNTU8_64 FOSS edition
    2x Release 7.2.2_GA_2852.UBUNTU10_64 FOSS edition
    1x Release 7.1.4_GA_2555.UBUNTU10_64 FOSS
    1x Release 8.0.3.GA.5664.UBUNTU12.64 FOSS edition

  2. #2
    Join Date
    Oct 2006
    Location
    Montana
    Posts
    38
    Rep Power
    9

    Default Possible work around.

    > MODIFICATION_FAILED

    No ideas, but maybe a work around.
    I have the same symptoms--does the same thing using Thunderbird 3.04b4pre and Lightning 1.0pre (18-Aug-2009 build). Directly connected (no proxy, same subnet).

    It works fine, however, with the Zimbra desktop client application. That tells me it can be done, and it probably isnt' Zimbra that 's the problem.

    Here's how I got it working (about 5 minutes ago) I deleted all my remote calendars and started over. Further testing on a cow-orker has shown that wasn't needed, I just needed to delete and recreate the shared calendar in Tbird, not my own.

    First I added the shared calendar to my web interface (send the share notice, from the OtherPerson's account, and then accept the share from the web gui. Name it something simple like SharedCalendar).


    Next, I set it up in Tbird but I didn't use the "proper" path to the shared calendar ics. The normal path--the one that the sharing person's Zimbra interface says to use for the share--would be something like
    Code:
     https://mail.mydomain.com/home/OtherPerson@mydomain.com/Calendar
    If I put that into Thunderbird's Location field, I'm able to read but not write.
    Instead, I use this in the location:
    Code:
     https://mail.mydomain.com/home/MyName@mydomain.com/SharedCalendar
    This lets me modify the shared calendar. Further I put my private calendar back into Thunderbird, and I can still use it. The key seems to be having the shared calendars all set up in my account via web gui, and then using MyName@mydomain in the path instead of the actual SomeOneElse@mydomain when setting it up in Thunderbird

  3. #3
    Join Date
    Jul 2009
    Posts
    2
    Rep Power
    6

    Default

    After upgrade from 5.0.15 to 5.0.18 I can no longer dismiss appointment alarms nor add new appointments. Lightning errors saying calendar can not write to calendar.

    Error Number: MODIFICATION_FAILED

    I have deleted my calendars and recreated only my own.

    The link I was using changed.

    Before change I was using the following.
    Code:
    https://zimbra8.wiu.edu/home/ke-mccormick/Calendar
    After change Zimbra tells me to use the following.
    Code:
    https://zimbra8.wiu.edu/home/ke-mccormick@wiu.edu/Calendar
    This looks to be a Zimbra bug to me.

    I am using Thunderbird 2.0.0.23 and Lightning 0.9 build 2008091719
    Last edited by kmccomick; 08-24-2009 at 10:50 AM.

  4. #4
    Join Date
    Jul 2009
    Posts
    2
    Rep Power
    6

  5. #5
    Join Date
    Sep 2008
    Posts
    134
    Rep Power
    7

    Default solved partially - maybe a Lightning Bug?

    Hi all,

    i doing some search again and found an error on my configuration.

    there does exist a apache reverse-proxy in-front of the zimbra.

    there was only forwarded
    /zimbra
    /home
    /service

    -> /dav was missing

    now i am able to add a caldav calendar against zimbra 5.0.18 with lightning 0.9 and thunderbird 2.0.0.23



    but there is a "new" issue, i currently do not know.

    when having the caldav calendar aktivated and i restart thunderbird. tb wont be able to open the imap-folder's and zindus wont be able to authenticate.
    this problem happens also, when deaktivating zindus.

    the "solution" is:
    deactivate the calendar (in options of lightning-calendar, not the marker before the calendar-name!), restart thunderbird, then zindus and imap works fine.

    now activate caldav. it takes a while until all my calender items are loaded.


    will try to setup the caldav directly to zimbra instead of the apache reverse-Proxy and update this thread afterwards.

    greetings
    thomas
    zmcontrol -v
    1x Release 6.0.10_GA_2692.UBUNTU8_64 NETWORK edition.
    1x Release 6.0.14_GA_2928.UBUNTU8_64 NETWORK edition
    2x Release 7.1.3_GA_3346.UBUNTU10_64 NETWORK edition, Patch 7.1.3_P1
    1x Release 8.0.2.GA.5569.UBUNTU12.64 NETWORK edition

    2x Release 6.0.10_GA_2692.UBUNTU8_64 FOSS edition
    2x Release 7.2.2_GA_2852.UBUNTU10_64 FOSS edition
    1x Release 7.1.4_GA_2555.UBUNTU10_64 FOSS
    1x Release 8.0.3.GA.5664.UBUNTU12.64 FOSS edition

  6. #6
    Join Date
    Sep 2008
    Posts
    134
    Rep Power
    7

    Default

    Quote Originally Posted by stegbth View Post
    but there is a "new" issue, i currently do not know.

    when having the caldav calendar aktivated and i restart thunderbird. tb wont be able to open the imap-folder's and zindus wont be able to authenticate.
    this problem happens also, when deaktivating zindus.
    new Information:

    this seems to be a bug of Thunderbird2 and SSL

    https://bugzilla.mozilla.org/show_bug.cgi?id=390036

    with a short test with TB3b4 and Lightning1pre it didn't happen at a short test about two hour's. Went backup to tb2 as Zindus doesn't work on TB3b4
    zmcontrol -v
    1x Release 6.0.10_GA_2692.UBUNTU8_64 NETWORK edition.
    1x Release 6.0.14_GA_2928.UBUNTU8_64 NETWORK edition
    2x Release 7.1.3_GA_3346.UBUNTU10_64 NETWORK edition, Patch 7.1.3_P1
    1x Release 8.0.2.GA.5569.UBUNTU12.64 NETWORK edition

    2x Release 6.0.10_GA_2692.UBUNTU8_64 FOSS edition
    2x Release 7.2.2_GA_2852.UBUNTU10_64 FOSS edition
    1x Release 7.1.4_GA_2555.UBUNTU10_64 FOSS
    1x Release 8.0.3.GA.5664.UBUNTU12.64 FOSS edition

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 05:42 PM
  2. Upgrade to ZCS 5.10
    By blozancic in forum Installation
    Replies: 0
    Last Post: 10-21-2008, 09:03 AM
  3. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 03:37 AM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •