Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: zmamavisdctl stopped

  1. #1
    Join Date
    Dec 2008
    Location
    North Bay, CA
    Posts
    31
    Rep Power
    6

    Default zmamavisdctl stopped

    Hi Everyone,

    Last night, a service (zmamadvistctl) stopped on our production server. It then stops delivering any messages. I restarted this service using:
    > zmamavisdctl start

    This started the service but bogs down the server to the extent that I cant even SSH into it. I started it once this morning and it died 10 minutes later.

    I was finally able to get through to it using ssh, and restarting zimbra through "zmcontrol stop" and "zmcontrol start" seems to have fixed the issue. (for now).

    Is there a reason that this service would stop all emails from being received or delivered to individual mailboxes?

  2. #2
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    I would take a look at /var/log/zimbra.log for any amavis error messages that would indicate why it stopped or crashed.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    Might this be another instance of what I posted here?

    http://www.zimbra.com/forums/adminis...tml#post145647
    Cheers,

    Dan

  4. #4
    Join Date
    Dec 2008
    Location
    North Bay, CA
    Posts
    31
    Rep Power
    6

    Default

    I'm going through the log and some of the things that jump out at me are:

    Aug 3 22:34:01 <host> amavis[29010]: (29010-04) (!!)TROUBLE in check_mail: parts_decode_ext FAILED: file(1) utility (/usr/bin/file) error: run_command (open pipe): Can't fork at /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/IO/File.pm line 188. at /opt/zimbra/amavisd/sbin/amavisd line 2603.
    Aug 3 22:34:01 <host> amavis[29010]: (29010-04) (!)PRESERVING EVIDENCE in /opt/zimbra/data/amavisd/tmp/amavis-20090803T223042-29010
    Aug 3 22:39:53 <host> amavis[5814]: (05814-20) (!)lookup_ldap: timed out at (eval 73) line 138, <GEN196> line 5.
    Aug 3 22:41:21 <host> amavis[5814]: (05814-20) (!)Requesting process rundown, task exceeded allowed time
    Aug 3 22:41:22 <host> zimbramon[11220]: 11220:info: zmstatuslog timeout after 60 seconds
    Aug 3 22:41:23 <host> zimbramon[11203]: 11203:info: zmstatuslog timeout after 60 seconds
    Aug 3 22:57:44 <host> slapd[28459]: => bdb_idl_delete_key: c_del id failed: DB_LOCK_DEADLOCK: Locker killed to resolve a deadlock (-30995)

  5. #5
    Join Date
    Dec 2008
    Location
    North Bay, CA
    Posts
    31
    Rep Power
    6

    Default

    I think the amavis error is what caused this problem.

    I found someone else who had a similar issue (this is a non-zimbra server).

    Can anyone tell me the zimbra way to fix this problem?

  6. #6
    Join Date
    Dec 2008
    Location
    North Bay, CA
    Posts
    31
    Rep Power
    6

    Default

    Dan...I dont think this problem is the same as the one you posted.

    Can anyone give me any direction on this? I would like to get this solved.

    For now, I created a zimbra monitoring service on another server which queries the status of my servers and emails/txts me whenever a service stops running. I run this service every 15 minutes and I also use an external delivery smtp (google) to send me those error messages. Although this is nice to have, it still doesnt explain what happened to our servers a few days ago. If anyone else is interested in monitoring their server this way, I can add them to my monitoring service.

  7. #7
    Join Date
    Dec 2008
    Location
    North Bay, CA
    Posts
    31
    Rep Power
    6

    Default

    Is there anyone from zimbra who can reply to this? Any feedback is appreciated. We have ZCS NE.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Search the forums for 'parts_decode_ext FAILED fork', see if the solved solution fixes your problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Dec 2008
    Location
    North Bay, CA
    Posts
    31
    Rep Power
    6

    Default

    Hi Bill...I looked at the following links:

    1) http://www.zimbra.com/forums/adminis...ext-error.html
    http://www.zimbra.com/forums/adminis...il-report.html

    I have all three of those packages installed.


    2) http://www.zimbra.com/forums/install...ork-error.html

    This thread seems unresolved



    I think this line "amavis[5814]: (05814-20) (!)Requesting process rundown, task exceeded allowed time" is where amavis actually died.

    So far, after the restart it seems to be running fine.

  10. #10
    Join Date
    Jan 2010
    Posts
    2
    Rep Power
    5

    Default zmamavisdctl is not running

    Hi,

    I am using Zimbra, version of my zimbra is Release 5.0.9_GA_2533.RHEL5_20080815132719 RHEL5 FOSS edition and when I am checking zimbra zimbra service status showing
    [zimbra@test ~]$ zmcontrol status
    Host test.mydomain.com
    antispam Stopped
    zmamavisdctl is not running
    antivirus Stopped
    zmamavisdctl is not running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running

    I have start stop Zimbra service's and even restsrta Zimbra but no benefit.

Similar Threads

  1. [SOLVED] zmamavisdctl start
    By acti0n in forum Installation
    Replies: 5
    Last Post: 06-08-2009, 06:01 AM
  2. After Installation Errors
    By shrry8 in forum Installation
    Replies: 1
    Last Post: 09-22-2008, 10:49 PM
  3. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 12:41 AM
  4. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •