Results 1 to 4 of 4

Thread: zimbra restoring problem: mails are up-to-date but the preference settings are not.

  1. #1
    Join Date
    Jun 2009
    Posts
    21
    Rep Power
    6

    Default zimbra restoring problem: mails are up-to-date but the preference settings are not.

    Yesterday I tested the restoring of zimbra and found something strange.

    I used A Simple Shell Script Method to backup zimbra every night by cron. And yesterday I built another zimbra server to test the backup-restoring of zimbra. Everything seemed OK untill I tried to login to my account. I got a wrong username/password error. I tried my old password that I changed it a month ago and entered successfully! After checking my mailbox I found that all the mails is up-to-date(I have all the mails just before the backup yesterday), but the Preference settings are not! I remembered I changed the password/theme/layout a month ago but I could not find them in the mailbox restored from yesterday's backup!

    So why the backup of zimbra can restore all the mails but can not hold any new Preference setting? Is anything wrong when backup?

  2. #2
    Join Date
    Jun 2009
    Posts
    21
    Rep Power
    6

    Default

    Anyone can help?

  3. #3
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default

    That data lives in

    /opt/zimbra/openldap-data/

    But the referenced script should have backed that up along with everything else.

  4. #4
    Join Date
    Jun 2009
    Posts
    21
    Rep Power
    6

    Default

    I deleted everything in /backup/zimbra yesterday and got a fresh backup this morning.
    After I restored the zimbra with this backup, everything is OK.

    I checked the backup shell script.
    The shell script does twice sync with the following command:

    rsync -avHK --delete /opt/zimbra/ /backup/zimbra

    One time is executed when zimbra is alive and the other time is executed after zimbra is stopped.

    Is there any problem in this Simple Shell Script ?

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  3. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  4. Replies: 16
    Last Post: 09-07-2006, 07:39 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •