Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Samba Group...?

  1. #11
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    It got deleted cause the tutorial says:
    You should see the Zimbra accounts that you just created in the list.

    Next, log in to Zimbra Admin UI, click on Aliases and remove root @ tm.local alias. Then run the following on the Samba server.

    smbpasswd -a root
    Hmmm....

    Now when I test the login with:
    Now test if Samba authenticates your new user correctly. In this example I went to the shell on my Zimbra server box and ran this command (as root):

    smbclient -U ubuntu2 //gregzimbra2.zimbra.com/ubuntu2
    I get:
    NT_STATUS_BAD_NETWORK_NAME
    What does that mean!?!

    Thanks!

  2. #12
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Remove the alias, not the account. You appear to have removed the entire admin@ account rather then just the root@ alias that is created on that account.

    Check to make sure that the NMB daemon is running on your samba server, this is the process responsible for broadcasting and maintaining the presence of the samba server on the network.
    (Probably /etc/init.d/nmb start)

  3. #13
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Actually did a bit of research and it appears that that error could be caused by a "msdfs proxy = no" line in your smb.conf file. See 0002554: "msdfs proxy = no" in smb.conf causes shares to be unavailable. - CentOS Bug Tracker

    Try removing that line and see if that fixes the problem (I had originally assumed that the error meant that it couldn't find the name of the server on the network)

  4. #14
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    woops...Hmm...I'll try to recreate the admin account heh....

    Yea, it's starting...

    Code:
    [root@mail /]# service smb restart
    Shutting down SMB services:                                [  OK  ]
    Shutting down NMB services:                                [  OK  ]
    Starting SMB services:                                     [  OK  ]
    Starting NMB services:                                     [  OK  ]
    Any other ideas...?

  5. #15
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    Hmmm...I don't have that line in there:

    my smb.conf file
    Code:
    [global]
    	netbios name = email server
    	server string = email server
    	workgroup = domain
    	os level = 33
    	enable privileges = yes
    	wins support =yes
    	name resolve order = wins bcast hosts
    	log file = /var/log/samba/log.%m
    	log level = 3
    	max log size = 1000
    	syslog only = no
    	syslog = 0
    	security = user
    	encrypt passwords = true
    	ldap passwd sync = yes
    	passdb backend = ldapsam:ldap://mail.domain.com/
    	ldap admin dn = "cn=config"
    	ldap suffix = dc=domain,dc=com
    	ldap group suffix = ou=groups
    	ldap user suffix = ou=people
    	ldap machine suffix = ou=machines
    	obey pam restrictions = no
    	passwd program = /usr/bin/passwd %u
    	passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
    	domain logons = yes
    	logon path = \\mail.domain.com\%U\profile
    	logon home = \\mail.domain.com\%U
    	logon script = logon.cmd
    	add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u
    	add machine script = /usr/sbin/adduser --shell /bin/false --disabled-password --quiet --gecos "machine account" --force-badname %u
    	socket options = TCP_NODELAY
    	domain master = yes
    	local master = yes
    [netlogon]
      comment = Network Logon Service
      path = /var/lib/samba/netlogon
      guest ok = yes
      locking = no
    [profiles]
      comment = Users profiles
      path = /var/lib/samba/profiles
      read only = No
    [profdata]
      comment = Profile Data Share
      path = /var/lib/samba/profdata
      read only = No
      profile acls = Yes

  6. #16
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    *bump*

    Still unresolved...interested in any ideas people may have to the issue...

  7. #17
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Looking at some more of the results for that error on google it looks like some other possible causes for this error are improper permissions on the share directory, or selinux blocking things.

  8. #18
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    Woops! My fault! I started going back through my conf files, and found a typo!

    Works like a charm now!

    Thanks for ALL the help!

    Much appreciated

    Thank you!

  9. #19
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Awesome, glad you got it working

Similar Threads

  1. Compartmentalized groups or locations sharing a domain
    By dstoliker in forum Administrators
    Replies: 5
    Last Post: 07-14-2008, 01:06 PM
  2. [SOLVED] URGENT: Tomcat Not Starting On Reboot
    By AlexanderH in forum Administrators
    Replies: 19
    Last Post: 08-22-2007, 01:42 PM
  3. Zimbra + Samba LDAP auth problems
    By fajarpri in forum Installation
    Replies: 3
    Last Post: 07-05-2007, 12:39 AM
  4. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •