Results 1 to 4 of 4

Thread: [SOLVED] What is zmconvertd? It is failing.

  1. #1
    Join Date
    Nov 2007
    Location
    Austin, TX
    Posts
    15
    Rep Power
    8

    Question [SOLVED] What is zmconvertd? It is failing.

    since:
    Code:
    Fri Aug 21 21:51:47 2009: Pinging convertd.
    zmconvertd hasn't been running, or able to start. I can't even tell what the service is. Searching for 'zmconvertd' doesn't come up with much, but I see it listed as 'conversion server monitor'. Is this a problem? If not, why is it spamming these logs then?

    Code:
    Mon Aug 24 15:30:44 2009: Pinging convertd.
    Mon Aug 24 15:30:44 2009: Cannot connect to convertd at localhost:7047: Connection refused
    Mon Aug 24 15:30:44 2009: Could not connect to convertd.
    Mon Aug 24 15:30:44 2009: Running /opt/zimbra/libexec/zmconvertd
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Mon Aug 24 15:30:44 2009: Started convertd.
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

  2. #2
    Join Date
    Nov 2007
    Location
    Austin, TX
    Posts
    15
    Rep Power
    8

    Default

    I figured out zmconvertd is the service that indexes attachments in a mailbox (and perhaps other stuff too, but *shrug*). When doing a partial restart by restarting mailboxd with support in regards to a different issue, zmconvertd appeared to fail and did not start back up with zomconvertctl. When I started zmconvertd directly, attachments were indexed again (regarding logs in mailboxd.log). Still waiting back to hear from the user that it was affecting, but I expect the problem was resolved.

    The symptom was if they wrote a message in Thunderbird and clicked 'send', it would take 46 seconds to complete the send in the client. The email was delivered and received in the first 4 seconds, but when the client tried to copy the message to 'sent messages' on the server there were 45seconds or so of error messages before the copy completed, which left the user waiting for these errors to finish before closing the connection.

  3. #3
    Join Date
    Oct 2009
    Posts
    1
    Rep Power
    6

    Default Similar problem, can't help you, but maybe you can help me.

    Hi Burnmage,

    I'm sort of in the same boat as you. It took me a while to figure out what convertd even did.

    I've been trying to migrate the zimbra data to a new server. (The old server is still good, just upgrading hardware).

    Right after the clean install, convertd doesn't start when I run #zmcontrol start.

    It says 'starting convertd...skipped. missing or not executable'.

    You mentioned in your post that you started convertd directly. Is that through the use of zmconvertctl? Also, is there any output when you type #zmconvertctl status. I don't get anything.

    Appreciate the help. Sorry I can't help you.

  4. #4
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Quote Originally Posted by scico View Post
    Right after the clean install, convertd doesn't start when I run #zmcontrol start.

    It says 'starting convertd...skipped. missing or not executable'.

    You mentioned in your post that you started convertd directly. Is that through the use of zmconvertctl? Also, is there any output when you type #zmconvertctl status. I don't get anything.
    Most of the zm*ctl commands don't give any visual output, instead outputting their status in the exit code, so to get the status you would want to run something like
    Code:
    zmconvertctl | echo $?
    but in this case it looks like the package didn't install properly. Were there any errors during install? Since this seems to be a test install you might want to just try a reinstall.


    Since the original poster solver their issue I am marking this thread solved, if you don't see something obvious to solve your problem try creating a new thread.
    (Wish I could be more help but I run the FOSS edition which doesn't have convertd)

Similar Threads

  1. ClamAV Failing
    By dorgan1983 in forum Administrators
    Replies: 5
    Last Post: 11-14-2008, 02:16 PM
  2. [SOLVED] Mail failing for servers with no A record
    By timwiel in forum Administrators
    Replies: 3
    Last Post: 02-26-2008, 06:07 AM
  3. Replies: 5
    Last Post: 11-09-2007, 01:59 PM
  4. Remote LDAP query failing
    By mjs in forum Administrators
    Replies: 8
    Last Post: 06-28-2007, 11:02 AM
  5. iCal sync failing with shared calendars
    By travisbell in forum CalDAV / CardDAV / iSync
    Replies: 10
    Last Post: 10-19-2006, 09:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •