Results 1 to 3 of 3

Thread: zmmaintaintables

  1. #1
    Join Date
    May 2006
    Posts
    41
    Rep Power
    9

    Default zmmaintaintables

    Hi,

    here the trace result of the script zmmaintaintables in crontab of my server in debian 3.1

    /opt/zimbra/libexec/zmmaintaintables
    Can't load '/opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/XML/Parser/Expat/Expat.so' for module XML::Parser::Expat: libexpat.so.1: cannot open shared object file: No such file or directory at /usr/lib/perl/5.8/DynaLoader.pm line 225.
    at /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/XML/Parser.pm line 14
    Compilation failed in require at /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/XML/Parser.pm line 14.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/XML/Parser.pm line 18.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/SOAP/XmlElement.pm line 30.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/SOAP/XmlElement.pm line 30.
    Compilation failed in require at /opt/zimbra/libexec/zmmaintaintables line 40.
    BEGIN failed--compilation aborted at /opt/zimbra/libexec/zmmaintaintables line 40.

    How can I fix that?

    Thanks

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Is this a new install or an upgrade? Can you confirm that DynaLoader.pm in installed on your system? Which version of Zimbra? Which operating system? Is this a 64bit install? If it is, that's not supported and you'll need 32 bit libraries.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    May 2006
    Posts
    41
    Rep Power
    9

    Default

    this is a new install
    the OS version is debian 3.1
    the zimbra version is 3.1.2
    the file DynaLoader is installed on my system
    32 bit librairies is installed on my system

    i have the same problem in zimbra version 3.1.1

    i have found that the file libexpat.so.1 not exist on my system
    the directory /opt/zimbra/httpd-2.0.54/lib contents:

    -rw-r--r-- 1 zimbra zimbra 262840 Jan 15 03:04 libexpat.a
    -rwxr-xr-x 1 zimbra zimbra 813 Jan 15 03:04 libexpat.la
    lrwxrwxrwx 1 zimbra zimbra 17 May 10 18:59 libexpat.so -> libexpat.so.0.1.0
    lrwxrwxrwx 1 zimbra zimbra 17 May 10 18:59 libexpat.so.0 -> libexpat.so.0.1.0
    -rwxr-xr-x 1 zimbra zimbra 238885 Jan 15 03:04 libexpat.so.0.1.0

    i have create the link
    ln -s libexpat.so.0.1.0 libexpat.so.1

    and add /opt/zimbra/httpd/lib in LD_LIBRARY_PATH

    now the script zmmaintaintables seems working and respond the line
    <ns0:MaintainTablesResponse numTables="0" xmlns:ns0="urn:zimbraAdmin"/>

    is that correct?
    excuse me for my bad english
    Last edited by mikets; 06-04-2006 at 02:54 PM.

Similar Threads

  1. Cleaning up store/index/db
    By rodrigoccurvo in forum Administrators
    Replies: 7
    Last Post: 03-09-2007, 11:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •