Results 1 to 3 of 3

Thread: Copy everybody's contacts to the back-up installation.

  1. #1
    Join Date
    Sep 2009
    Posts
    4
    Rep Power
    6

    Default Copy everybody's contacts to the back-up installation.

    Hi everyone.

    We are using Zimbra, and we want to copy over everyone's contact list to our off-site data-recovery location, which also has Zimbra installed and running. It is not a "sync". It is just copying over (and maybe removing what got removed).

    Any ideas? I think the zmmailbox is the command to use, but how exactly? Do I have to log in on the remote site to run a local command there, or can I push everything there from my main server here?

    Thanks a lot!

    --
    Tim

  2. #2
    Join Date
    Sep 2009
    Posts
    4
    Rep Power
    6

    Default Is this a bug?

    As far as I can tell, these two commands will retrieve a list of contacts from the local system, and them push them to the remote system.

    /opt/zimbra/bin/zmmailbox -u https://localhost -a admin -p *adminpassword* -m tkoop@example.com getRestURL "/Contacts" > "contacts.tmp"

    /opt/zimbra/bin/zmmailbox -u https://1.2.3.4 -p *timspassword* -m tkoop postRestURL "/Contacts?resolve=replace" "contacts.tmp"


    However, it doesn't work. It actually pushes the list back to the local system, effectively duplicating the list of contacts. Is this a bug or am I missing something?

    Thanks.

    --
    Tim

  3. #3
    Join Date
    Mar 2012
    Posts
    1
    Rep Power
    3

    Unhappy It might be a bug

    Tim,

    I have the exact same issue that I've been trying to resolve for quite a while now. No matter what resolve value I use, "skip", "reset", "replace", or "modify", none of them seem to do anything and the contacts are duplicated. Even when I omit the declaration, "skip", which is the default, still doesn't seem to work. I've tried other things like changing the case of "contacts" or "resolve", but still nothing.

    Is this a bug? I haven't been able to find any reference to anyone else having this problem, but it appears to exist in some form, at least when importing contacts for an individual user in my case.

    --
    Kristoff

Similar Threads

  1. loops back to myself
    By cubitus91 in forum Installation
    Replies: 16
    Last Post: 05-12-2008, 01:49 PM
  2. Replies: 5
    Last Post: 05-12-2008, 06:32 AM
  3. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  4. Extracting contacts and calendar from old installation
    By robscovell in forum Administrators
    Replies: 2
    Last Post: 03-12-2007, 06:19 PM
  5. Copy mail, calendar and contacts
    By FunkyPenguin in forum Installation
    Replies: 1
    Last Post: 01-22-2006, 03:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •