Results 1 to 6 of 6

Thread: zimbradomainadmins in 6.0

  1. #1
    Join Date
    Jan 2009
    Posts
    60
    Rep Power
    6

    Default zimbradomainadmins in 6.0

    Hi,
    We just upgraded to 6.0 and are having some problems defining new domain admins. In the help section I found out that I just should choose Administrator and admin role: zimbradomainadmins. The only zimbradomainadmin i can use is zimbradomainadmin@serverFQDN but then the account will be domain admin of serverFQDN, not the accounts domain. What to do?

  2. #2
    Join Date
    Mar 2009
    Location
    UK
    Posts
    2
    Rep Power
    6

    Default

    We are having the same problem. Did you find a solution please?

  3. #3
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    I looked at the zmsetup.log to know how it's done.

    So, for domain pwait.com, here's what I did :
    Code:
    /opt/zimbra/bin/zmprov -m -l cdl zimbraDomainAdmins@pwait.com zimbraIsAdminGroup TRUE zimbraMailStatus disabled zimbraAdminConsoleUIComponents accountListView zimbraAdminConsoleUIComponents aliasListView zimbraAdminConsoleUIComponents DLListViewzimbraAdminConsoleUIComponents resourceListView zimbraAdminConsoleUIComponents saveSearch
    /opt/zimbra/bin/zmprov -m -l grr domain pwait.com grp zimbraDomainAdmins@pwait.com +domainAdminConsoleRights
    /opt/zimbra/bin/zmprov -m -l grr global grp zimbraDomainAdmins@pwait.com +domainAdminZimletRights
    This is supposed to create a zimbraDomainAdmins Distribution List in which I'll be able to put my domain admins for this domain.

    When I do so (checking the user as "administrator" and giving him the "Administrator Role" zimbraDomainAdmins@pwait.com), the user is able to log in the admin UI.

    But...
    Everything is empty.

    Exactly like this bug that is supposed to be fixed/verified: Bug 38588 : zimbradomainadmins group isn't assigning any views to an admin

  4. #4
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Posts
    291
    Rep Power
    10

    Default

    I had to configure some direct grants for the domainadmin for him to be useful.
    for each domain admin, you need to add these grants in the grants tab:
    adminconsoleresourcerights
    domainadminaccountrights
    adminconsoledlrights
    createaccount
    and set the target name to the domain you want to grant the user access too.
    http://www.solutionsfirst.com.au/hosting/zimbra/
    Australia's premier Zimbra Hosting Partner
    Resellers wanted!

  5. #5
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    I'll try that, Dave, thank you.

    I posted a comment in the bug but can not re-open it 8-(

  6. #6
    Join Date
    Mar 2008
    Location
    Canada
    Posts
    148
    Rep Power
    7

    Default

    Oh this is proving rather messy. I just setup a client on here after months of trying to convince them how good this setup is. Now I have had to tell them the admin function doesn't work correctly right now.

Similar Threads

  1. Unable to access Yahoo account via Zimbra Desktop
    By drdrem in forum Error Reports
    Replies: 10
    Last Post: 10-13-2009, 01:30 PM
  2. Possible problems with attachments - Zimbra 6.0 & EAS
    By bradb21 in forum Zimbra Mobile
    Replies: 2
    Last Post: 09-14-2009, 02:41 PM
  3. ZCS 6.0 NE Private Beta!
    By jholder in forum Announcements
    Replies: 0
    Last Post: 05-22-2009, 10:20 AM
  4. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 01:01 PM
  5. .53 Will Not "Launch" in FF 2.0.0.6
    By jhoelz in forum Installation Help
    Replies: 4
    Last Post: 08-04-2007, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •