Results 1 to 5 of 5

Thread: ZMrestore not working

  1. #1
    Join Date
    Sep 2008
    Posts
    23
    Rep Power
    7

    Default ZMrestore not working

    Hi, I just downloaded a version of ZCS 5.0.18 Network Edi. for try the backup/restore online...

    Well, i created a new domain, and an account and sent many mails to this account.... after that make the first full backup... so later deleted all the messages for the account.. and then try to restore from the backup that already created.. but that did not work.

    So i said... ah ok, maybe i have to delete the account.. so i deleted... and then restored again.. with this time it restored the account but with out any mails...

    I did it from the GUI and the CLI and both times were the same.

    pd: I tried before the ZCS 6.0 and i got the same problems... that's why i downloaded the other one.

    When i see the file: accounts.xml i see the account that i backup... and in the directory session i see all the mails....


    So... please any help would be great.

    Thanks...

    Michael.-

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    What options did you provide to zmrestore on the CLI ?

  3. #3
    Join Date
    Sep 2008
    Posts
    23
    Rep Power
    7

    Default

    Hi...

    I try this:

    zmrestore -s znetworked.domain.cl -lb full-20090914.213505.552 -a michael@lol.cl

    But did not work..

    When i run: zmbackupquery i see the backup-

    [zimbra@znetworked ~]$ zmbackupquery
    Label: full-20090914.213505.552
    Type: full
    Status: completed
    Started: Mon, 2009/09/14 17:35:05.552 CLT
    Ended: Mon, 2009/09/14 17:35:08.997 CLT
    Redo log sequence range: 1 .. 1
    Number of accounts: 1

    Is there anything else that i have to do?

    Thanks a lot.

    Michael.-

  4. #4
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    if you deleted all the e-mail of the account, and you restore the account i think it will restore and re-apply the redologs which will in turn delete all teh e-mail of the account. try restoring the account to a time before you deleted all the e-mail.

  5. #5
    Join Date
    Sep 2008
    Posts
    23
    Rep Power
    7

    Default

    Well...

    Actually i do not understand this...

    I deleted the full backup and created other account with many mails and did a new full backup....

    If i see the backup just created:

    [zimbra@znetworked 0]$ zmbackupquery
    Label: full-20090916.194019.062
    Type: full
    Status: completed
    Started: Wed, 2009/09/16 15:40:19.062 CLT
    Ended: Wed, 2009/09/16 15:40:28.932 CLT
    Redo log sequence range: 8 .. 8
    Number of accounts: 6

    the File: accounts.xml show all the accounts in the backup....

    <account zimbraId="2673602f-de79-4ff3-be97-7935b8c4cdc3" email="rodrigo@lol.cl" latestFullBackupLabel="full-20090916.194019.062">
    </account>

    and in the directory:
    /opt/zimbra/backup/sessions/full-20090916.194019.062/accounts/267/360/2673602f-de79-4ff3-be97-7935b8c4cdc3/blobs/1/0 there are all the messages.... generated from the backup.

    So... this time i delete de account rodrigo@lol.cl and then run in the CLI:

    zmrestore -s znetworked.microserv.cl -lb full-20090916.194019.062 -a rodrigo@lol.cl

    And that command created the LDAP entry with the same ZimbraID and restored the messages to /opt/zimbra/store/0/6/msg/0 (the directory where the originals mails were,... before i deleted the account)--- however the messages have only a part of them, i mean like this:


    [zimbra@znetworked 0]$ cat 257-2.msg
    Date: Wed, 16 Sep 2009 15:31:33 -0400 (CLT)
    From: rodrigo Fernandez <rodrigo@lol.cl>
    To: rodrigo Fernandez <rodrigo@lol.cl>
    Message-ID: <11031144.01253129493675.JavaMail.root@znetworked. microserv.cl>
    Subject: prueba 1
    MIME-Version: 1.0
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: 7bit
    X-Originating-IP: [191.9.200.52]
    X-Mailer: Zimbra 5.0.18_GA_3011.RHEL5 (ZimbraWebClient - IE6 (Win)/5.0.18_GA_3011.RHEL5)

    Please, any help would be great.

    Michael.-

Similar Threads

  1. Search not working in contacts
    By shillhsr in forum Error Reports
    Replies: 2
    Last Post: 05-08-2009, 12:09 PM
  2. zmrestore point-in-time recovery not working
    By Rich Graves in forum Administrators
    Replies: 9
    Last Post: 12-12-2007, 07:47 PM
  3. zmrestore -restoreToTime not working
    By jeffw in forum Administrators
    Replies: 2
    Last Post: 12-11-2007, 08:13 AM
  4. Zimlets all not working?
    By jadestorm in forum Administrators
    Replies: 16
    Last Post: 10-28-2007, 07:25 PM
  5. zmrestore restoreToTime problem
    By magsuser2007 in forum Administrators
    Replies: 5
    Last Post: 10-15-2007, 01:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •