Results 1 to 2 of 2

Thread: Free/Busy queries kill the mailbox service

Hybrid View

  1. #1
    Join Date
    Feb 2008
    Asheville, North Carolina
    Rep Power

    Default Free/Busy queries kill the mailbox service

    Today I have seen the mailbox service restart itself numerous times today. Example form /var/log/zimbra.log:
    Sep 21 09:09:39 serenity zmmailboxdmgr[16975]: manager woke up from wait on mailboxd/JVM with pid 9391
    Sep 21 09:09:39 serenity zmmailboxdmgr[11904]: wrote java pid 11904 to /opt/zimbra/log/
    Sep 21 09:09:39 serenity zmmailboxdmgr[16975]: manager started mailboxd/JVM with pid 11904
    /opt/zimbra/log/mailbox.log shows the following:
    2009-09-21 09:09:38,757 FATAL [btpool0-81] [] system - Unable to commit database transaction.  Forcing server to abort
    I have been able to cause this behavior directly by attempting to view the free/busy info for one particular user. Here's the steps:
    1) create a new mtg in Outlook (ZCO
    2) add some other user (verify that we view another users' free/busy)
    3) try to add the problem user
    result: mailboxd immediately fails and I am unable to view the problem users' calendar info

    The problem isn't limited to Outlook, however. If I login to the user's account via the Zimbra web client, as soon as I click on the Calendar tab, the mailbox service fails.

    Any advice on what to do to resolve this problem?

  2. #2
    Join Date
    Feb 2008
    Asheville, North Carolina
    Rep Power


    After further troubleshooting, it looks like there are some problems in the database. The user's account that I'm having difficulty with is in mailbox group 43. Based on some information I found in /opt/zimbra/log/mailbox.log and /opt/zimbra/log/mysql_error.log, I tried the following:
    mysql> use mboxgroup43;
    mysql> select * from mail_item where mailbox_id=243;
    MySQL crashed when I attempted this query. It appears the table is corrupt, even though zmdbintegrityreport (calling mysqlcheck) reports no problems:
    [zimbra@mailhost libexec]$ /opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf -S /opt/zimbra/db/mysql.sock -c -e -u root --password=fubar mboxgroup43
    mboxgroup43.appointment                            OK
    mboxgroup43.data_source_item                       OK
    mboxgroup43.imap_folder                            OK
    mboxgroup43.imap_message                           OK
    mboxgroup43.mail_item                              OK
    mboxgroup43.open_conversation                      OK
    mboxgroup43.pop3_message                           OK
    mboxgroup43.revision                               OK
    mboxgroup43.tombstone                              OK
    I tried to delete the offending item - this failed as well:
    [zimbra@mailhost log]$ mysql mboxgroup43;
    mysql> select CONCAT(id, '-', mod_content) as itemId from mail_item where id = 18011;
    | itemId       |
    | 18011-106100 | 
    1 row in set (0.02 sec)
    [zimbra@mailhost log]$ zmmailbox -z      
    mbox> selectMailbox
    mailbox:, size: 2.22 GB, messages: 16493, unread: 174
    mbox> deleteItem  18011-106100
    ERROR: service.FAILURE (system failure: fetching item 18011)
    Do I have any options besides database recovery to resolve this?

Similar Threads

  1. Replies: 5
    Last Post: 05-28-2009, 12:53 AM
  2. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  3. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 05:53 PM
  4. [SOLVED] Web Service to create mailbox account
    By jv1410 in forum Developers
    Replies: 1
    Last Post: 10-19-2007, 04:31 PM
  5. What does the mailbox service do?
    By iain in forum Administrators
    Replies: 1
    Last Post: 06-17-2007, 04:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts