Results 1 to 2 of 2

Thread: zmmailbox - ERROR: service.UNKNOWN_DOCUMENT (unknown document: GetFilterRulesRequest)

  1. #1
    Join Date
    Feb 2007
    Location
    Austin, TX
    Posts
    110
    Rep Power
    8

    Default zmmailbox - ERROR: service.UNKNOWN_DOCUMENT (unknown document: GetFilterRulesRequest)

    I am having a wierd problem when trying to export filter rules via zmmailbox accross servers. I am using the following zmmailbox command

    zmmailbox -u https://server:7071 -a admin@domain.com -p p4$$w0rd -m user@domain.com gfrl

    ServerA - ZCS 5.0.9
    ServerB - ZCS 6.0.1

    From Server A I can run the command fine either against Server B or itself or any of the other members of the 5.0.9 cluster. From Server B however I can run the command against itself, but if I try Server A or any of the 5.0.9 machines in that cluster I get this:

    ERROR: service.UNKNOWN_DOCUMENT (unknown document: GetFilterRulesRequest)

    Any help as to why this is happening would be appreciated.
    Peter LeBlond
    Product Development Engineer
    http://www.mxtoolbox.com


  2. #2
    Join Date
    Feb 2007
    Location
    Austin, TX
    Posts
    110
    Rep Power
    8

    Default

    When I opened the hood and looked at the SOAP requests it looks like 5.0.9 performs a "GetRulesRequest" while 6.0.1 performs a "GetFilterRulesRequest":

    Does this mean that you just can't make zmmailbox calls from a newer version to an older version like this?
    Peter LeBlond
    Product Development Engineer
    http://www.mxtoolbox.com


Similar Threads

  1. [SOLVED] zmbackupquery unknown document failure
    By jmarriott in forum Administrators
    Replies: 5
    Last Post: 09-01-2009, 12:45 AM
  2. unknown document: CreateFolderRequest ???
    By brianader in forum Developers
    Replies: 1
    Last Post: 08-03-2009, 08:24 AM
  3. [SOLVED] Firefox 3 + Zimbra 5 - TLS Interop issue
    By irvingpop in forum Administrators
    Replies: 21
    Last Post: 07-22-2008, 10:53 PM
  4. Installation Cancelled - Zimbra-spell !
    By Ledg in forum Installation
    Replies: 4
    Last Post: 10-19-2006, 02:54 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •