Results 1 to 4 of 4

Thread: [SOLVED] ldapsearch returns zero results

  1. #1
    Join Date
    Sep 2009
    Rep Power

    Default [SOLVED] ldapsearch returns zero results

    Hi guy,

    Our mac users have configured and Address book using the steps below from the wiki but the ldapserch returns zero results.

    Open either or Apple Address Book
    For Preferences -> Composing -> 'Configure LDAP...'
    For Address Book: Preferences -> LDAP
    Then enter the information for your Zimbra server
    Name - Enter an name
    Server - Enter your Zimbra Server hostname
    Search Base - Enter your domain like "dc=example,dc=com"
    Port - Enter 389 for standard, 636 and check 'Use SSL' if you have OpenLDAP in SSL mode.
    Scope - Subtree
    Authentication is Optional. If you want to authenticate enter your full Zimbra email address and password.

    I have also searched ldap from the command line and the results are the same.

    zimbra@host:~$ ldapsearch -x -b dc=doman,dc=com -h
    # extended LDIF
    # LDAPv3
    # base <dc=domain,dc=com> with scope subtree
    # filter: (objectclass=*)
    # requesting: ALL

    # search result
    search: 2
    result: 0 Success

    # numResponses: 1

    The server has multiple domains and the command above has been executed for all domains and the results are the same.

  2. #2
    Join Date
    Sep 2008
    Los Angeles, CA
    Rep Power


    I am getting the same thing when running ldapsearch on my LDAP replica.
    However, the master returns results. Perhaps it is preventing anonymous binds?

  3. #3
    Join Date
    Aug 2009
    The Hague -- The Netherlands
    Rep Power


    From the release notes of Zimbra 6:
    Anonymous searches of the LDAP directory are no longer enabled
    beginning with 6.0. Note: anonymous searches of the directory are allowed
    for upgrades.

  4. #4
    Join Date
    Sep 2009
    Rep Power



    Thank you! This explains why this is not a problem on my development server. It was upgraded to 6.0 and the server that returned zero results is a fresh installation of 6.0.

    Thank you,

Similar Threads

  1. search missing results
    By ZenMasta in forum General Questions
    Replies: 2
    Last Post: 08-19-2009, 08:32 AM
  2. [SOLVED] strange ldapsearch issues
    By aurfalien in forum Administrators
    Replies: 12
    Last Post: 03-03-2009, 01:17 PM
  3. HELP external AD or ldap query returns empty
    By JohnnieDrama in forum Installation
    Replies: 0
    Last Post: 05-28-2007, 09:09 AM
  4. AD GAL: successful, but empty, test results
    By tmadden in forum Administrators
    Replies: 0
    Last Post: 10-02-2006, 03:36 PM
  5. LDAP with AD returns blank results
    By Shurik in forum Administrators
    Replies: 1
    Last Post: 08-11-2006, 10:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts