Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: cant send email

  1. #1
    Join Date
    Sep 2009
    Posts
    7
    Rep Power
    6

    Default cant send email

    hello,

    i am using zimbra open source into a local network perfectly, i use a "domain.local" and i can send/receive mails. Now i need to use zimbra to send/receive mails from a "domain.org" and i can receive but cannot send it. i have this error when i try to send one mail.

    Code:
    "This is the mail system at host zimbra.down.local.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <count@domain.org>: host mail.domain.org[xx.xxx.xxx.xxx] said:
        501 Your domain does not seem to be valid. Could not find MX record for
        your domain. (in reply to MAIL FROM command)".
    Other information:

    Code:
    zimbra@zimbra:/home$ nslookup
    > set q=any
    > domain.org
    Server:         192.168.0.242
    Address:        192.168.0.242#53
    
    Non-authoritative answer:
    Name:   domain.org
    Address: xx.xxx.xxx.xxx
    domain.org nameserver = dns2.interdominios.com.
    domain.org nameserver = dns1.interdominios.com.
    domain.org
            origin = dns1.interdominios.com
            mail addr = plesk-panels.interdominios.com
            serial = 1238264179
            refresh = 10800
            retry = 3600
            expire = 604800
            minimum = 10800
    domain.org mail exchanger = 10 mail.domain.org.
    
    Authoritative answers can be found from:
    dns2.interdominios.com  internet address = 62.81.199.177
    dns1.interdominios.com  internet address = 93.174.4.16
    mail.domain.org    internet address = xx.xxx.xxx.xxx
    > set q=any
    > domain.local
    Server:         192.168.0.242
    Address:        192.168.0.242#53
    
    Name:   
    Address: 192.168.0.242
    Name:   domain.local
    Address: 192.168.0.200
    domain.local      nameserver = terminal02.domain.local.
    domain.local      nameserver = server2006.domain.local.
    domain.local
            origin = terminal02.domain.local
            mail addr = hostmaster.domain.local
            serial = 2651
            refresh = 900
            retry = 600
            expire = 86400
            minimum = 3600
    domain.local      rdata_65281 = \# 20 00010000000000020000038400000001C0A800C8
    I understand I have to tell "mail.domain.org" which is my mail server, but not how.

  2. #2
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    So local delivery also not working ? can you show me the o/p of zmproc gad please

  3. #3
    Join Date
    Sep 2009
    Posts
    7
    Rep Power
    6

    Default

    locally everything goes right...

    Code:
    zimbra@zimbra:/home$ zmprov gad
    zimbra.domain.local

  4. #4
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Your mail server isn't finding the MX record you have posted for some reason... could you paste the output of this command run on the Zimbra server (do not use nslookup!):
    Code:
    dig domain.org MX
    You should be getting something like the following:
    Code:
    ; <<>> DiG 9.4.2-P2 <<>> domain.org MX
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15705
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;domain.org.                  IN      MX
    
    ;; ANSWER SECTION:
    domain.org.           86400   IN      MX      0 mail.domain.org.
    
    ;; AUTHORITY SECTION:
    domain.org.           86400   IN      NS      ns2.domain.org.
    domain.org.           86400   IN      NS      ns1.domain.org.
    
    ;; ADDITIONAL SECTION:
    mail.domain.org.     86400   IN      A       192.168.1.6
    ns1.domain.org.       86400   IN      A       192.168.1.2
    ns2.domain.org.       86400   IN      A       192.168.1.3
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.2#53(192.168.1.2)
    ;; WHEN: Mon Sep 28 11:17:55 2009
    ;; MSG SIZE  rcvd: 136

  5. #5
    Join Date
    Sep 2009
    Posts
    7
    Rep Power
    6

    Default

    zimbra:/home# dig domain.local mx
    Code:
    ; <<>> DiG 9.5.1-P3 <<>> domain.local mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 3716
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;domain.local.                    IN      MX
    
    ;; AUTHORITY SECTION:
    domain.local.             3600    IN      SOA     terminal02.domain.local. hostmaster.domain.local. 2658 900 600 86400 900
    
    ;; Query time: 2 msec
    ;; SERVER: 192.168.0.242#53(192.168.0.242)
    ;; WHEN: Tue Sep 29 12:31:31 2009
    ;; MSG SIZE  rcvd: 86
    zimbra:/home# dig domain.org mx
    Code:
    ; <<>> DiG 9.5.1-P3 <<>> domain.org mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 48982
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;domain.org.               IN      MX
    
    ;; ANSWER SECTION:
    domain.org.        10690   IN      MX      10 mail.domain.org.
    
    ;; ADDITIONAL SECTION:
    mail.domain.org.   10684   IN      A       xx.xxx.xxx.xxx
    
    ;; Query time: 4 msec
    ;; SERVER: 192.168.0.242#53(192.168.0.242)
    ;; WHEN: Tue Sep 29 12:32:14 2009
    ;; MSG SIZE  rcvd: 70

  6. #6
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Could you post the full headers for the message you tried to send and it's b ounce message?

  7. #7
    Join Date
    Sep 2009
    Posts
    7
    Rep Power
    6

    Default

    hello,

    i try to sent:

    Code:
    Date: Wed, 30 Sep 2009 10:42:48 +0200 (CEST)
    From: Zimbra User <rdiazr@zimbra.down.local>
    To: 
    	=?utf-8?Q?Dpto=2E_Inform=C3=A1tica_Down_local?= <info@domain.org>
    Message-ID: <9689543.61254300168563.JavaMail.root@zimbra>
    Subject: Prueba
    MIME-Version: 1.0
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: 7bit
    X-Originating-IP: [192.168.0.199]
    X-Mailer: Zimbra 6.0.1_GA_1816.DEBIAN5 (ZimbraWebClient - FF3.0 (Win)/6.0.1_GA_1816.DEBIAN5)
    
    Probando
    and then i receive

    Code:
    Received: from zimbra.down.local (LHLO zimbra.down.local) (192.168.0.21) by
     zimbra.down.local with LMTP; Wed, 30 Sep 2009 10:42:51 +0200 (CEST)
    Received: by zimbra.down.local (Postfix)
    	id 755AD21E5F; Wed, 30 Sep 2009 10:42:51 +0200 (CEST)
    Date: Wed, 30 Sep 2009 10:42:51 +0200 (CEST)
    From: MAILER-DAEMON@zimbra.down.local (Mail Delivery System)
    Subject: Undelivered Mail Returned to Sender
    To: rdiazr@zimbra.down.local
    Auto-Submitted: auto-replied
    MIME-Version: 1.0
    Content-Type: multipart/report; report-type=delivery-status;
    	boundary="BE52921E63.1254300171/zimbra.down.local"
    Content-Transfer-Encoding: 7bit
    Message-Id: <20090930084251.755AD21E5F@zimbra.down.local>
    
    This is a MIME-encapsulated message.
    
    --BE52921E63.1254300171/zimbra.down.local
    Content-Description: Notification
    Content-Type: text/plain; charset=us-ascii
    
    This is the mail system at host zimbra.down.local.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <info@domain.org>: host mail.domain.org[xx.xxx.xxx.xxx] said:
        501 Your domain does not seem to be valid. Could not find MX record for
        your domain. (in reply to MAIL FROM command)
    
    --BE52921E63.1254300171/zimbra.down.local
    Content-Description: Delivery report
    Content-Type: message/delivery-status
    
    Reporting-MTA: dns; zimbra.down.local
    X-Postfix-Queue-ID: BE52921E63
    X-Postfix-Sender: rfc822; rdiazr@zimbra.down.local
    Arrival-Date: Wed, 30 Sep 2009 10:42:50 +0200 (CEST)
    
    Final-Recipient: rfc822; info@domain.org
    Original-Recipient: rfc822;info@domain.org
    Action: failed
    Status: 5.0.0
    Remote-MTA: dns; mail.domain.org
    Diagnostic-Code: smtp; 501 Your domain does not seem to be valid. Could not
        find MX record for your domain.
    
    --BE52921E63.1254300171/zimbra.down.local
    Content-Description: Undelivered Message
    Content-Type: message/rfc822
    Content-Transfer-Encoding: 7bit
    
    Return-Path: <rdiazr@zimbra.down.local>
    Received: from localhost (localhost [127.0.0.1])
    	by zimbra.down.local (Postfix) with ESMTP id BE52921E63
    	for <info@domain.org>; Wed, 30 Sep 2009 10:42:50 +0200 (CEST)
    X-Virus-Scanned: amavisd-new at zimbra.down.local
    Received: from zimbra.down.local ([127.0.0.1])
    	by localhost (zimbra.down.local [127.0.0.1]) (amavisd-new, port 10024)
    	with ESMTP id LsJV-BDQQHk2 for <info@domain.org>;
    	Wed, 30 Sep 2009 10:42:49 +0200 (CEST)
    Received: from zimbra.down.local (zimbra.down.local [192.168.0.21])
    	by zimbra.down.local (Postfix) with ESMTP id F222121E5F
    	for <info@domain.org>; Wed, 30 Sep 2009 10:42:48 +0200 (CEST)
    Date: Wed, 30 Sep 2009 10:42:48 +0200 (CEST)
    From: Zimbra User <rdiazr@zimbra.down.local>
    To: 
    	=?utf-8?Q?Dpto=2E_Inform=C3=A1tica_Down_local?= <info@domain.org>
    Message-ID: <9689543.61254300168563.JavaMail.root@zimbra>
    Subject: Prueba
    MIME-Version: 1.0
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: 7bit
    X-Originating-IP: [192.168.0.199]
    X-Mailer: Zimbra 6.0.1_GA_1816.DEBIAN5 (ZimbraWebClient - FF3.0 (Win)/6.0.1_GA_1816.DEBIAN5)
    
    Probando
    
    --BE52921E63.1254300171/zimbra.down.local--

  8. #8
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Try adding a MX record for domain.local pointing to zimbra.domain.local (or whatever the Zimbra server that handles domain.local's mail is).

  9. #9
    Join Date
    Sep 2009
    Posts
    7
    Rep Power
    6

    Default

    hi,
    i have reconfigured zimbra server from scratch. i have reconfigured my DNS (from ISP) to point my Ip public.
    Code:
    zimbra@zimbra:/home$ dig mydomain.es mx
    
    ; <<>> DiG 9.5.1-P3 <<>> mydomain.es mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41945
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;mydomain.es.            IN      MX
    
    ;; ANSWER SECTION:
    mydomain.es.     300     IN      MX      20 mail.mydomain.es.
    mydomain.es.     300     IN      MX      10 my public ip.
    
    ;; ADDITIONAL SECTION:
    mail.mydomain.es. 300    IN      A       ISP IP
    
    ;; Query time: 194 msec
    ;; SERVER: 192.168.0.200#53(192.168.0.200)
    ;; WHEN: Mon Oct  5 20:01:06 2009
    ;; MSG SIZE  rcvd: 102
    i have two domains on my zimbra server ( mydomain.es and zimbra.local) and mydomain.es is by default.
    Code:
    zmprov mcf zimbraDefaultDomainName mydomain.es
    Now i can send/receive mails from my network and i can send mails to internet (gmail,hotmail,etc...) but, now i
    cant receive mails on my zimbra accounts from internet.
    i have created user1@mydomain.es in my zimbra server and in my ISP so if i send an email from gmail to mydomain.es
    i can receive it in my ISP but not in zimbra.

    How can i receive emails? with fetchmail or i create a external account for each email i create in zimbra?

    sorry if you dont understand something of my post

  10. #10
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Ah ha, there is your problem:
    Code:
    ;; ADDITIONAL SECTION:
    mail.mydomain.es. 300    IN      A       ISP IP
    If your MX record is pointing to your ISP's mail server then of course the mail is going to go to your ISP and not your Zimbra server. If you intend on using your ISP's mail servers as a relay so they can hold the mail before sending it on to your Zimbra install then you want it configured this way. You will need to have your ISP's mail servers forward the mail to you though or it wont get to your server.

    However if you want mail to go directly to your Zimbra server then you need to have your MX record point directly to your Zimbra server, rather then your ISP's mail server.

    As it stands right now it looks like mail is getting delivered to your ISP's mail server and then staying there because as far as the world and your ISP's server are concerned the task of delivering the mail is complete.

Similar Threads

  1. [SOLVED] mailboxmanager does not start
    By jrefl5 in forum Administrators
    Replies: 18
    Last Post: 01-30-2012, 10:40 PM
  2. [SOLVED] Moving Zimbra to a new server
    By krolen in forum Administrators
    Replies: 109
    Last Post: 02-05-2009, 10:38 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 02:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •