Results 1 to 4 of 4

Thread: [SOLVED] dspam error during zmtrainsa

Hybrid View

  1. #1
    Join Date
    Jan 2008
    Location
    Michigan
    Posts
    174
    Rep Power
    7

    Default [SOLVED] dspam error during zmtrainsa

    I get this error when running zmtrainsa. It happens one system I am running that is version 5.0.18 when running zmtrainsa on 6.0.1 it runs fine. Where do I look for the problem?
    Bill B

    20090930111433 Starting spamassassin training.
    netset: cannot include 127.0.0.0/8 as it has already been included
    Learned tokens from 0 message(s) (81 message(s) examined)
    netset: cannot include 127.0.0.0/8 as it has already been included
    Learned tokens from 0 message(s) (0 message(s) examined)
    netset: cannot include 127.0.0.0/8 as it has already been included
    20090930111442 Finished spamassassin training.
    20090930111442 Starting dspam training
    Taking Snapshot...
    zimbra TP: 0 TN: 0 FP: 0 FN: 0 SC: 0 NC: 0
    Training /tmp/ham.NrK5361 / /tmp/spam.cIp5360 corpora...
    [test: spam ] 1240b8443f9-26 result: sh: /opt/zimbra/dspam-3.8.0/bin/dspam: Permission denied

    ===== WOAH THERE =====
    I was unable to parse the result. Test Broken.
    ======================
    dspam_clean starting
    PROCESSING USER: zimbra
    Processing sigs; age: 14
    Processing probabilities; age: 0
    Processing unused; any: 90 quota: 30 nospam: 15 onehit: 15
    20090930111442 Finished dspam training
    zimbra@ms1:~/clamav/scamp-5.2$

  2. #2
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Make sure /opt/zimbra/dspam-3.8.0/bin/dspam exists and is executable.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Jan 2008
    Location
    Michigan
    Posts
    174
    Rep Power
    7

    Default

    yes, everything is there in bin. When I execute from the folder I get 'dspam not installed' but I had it working earlier in the week. sometimes it works and then reads the spam and sometimes I get the message I posted here. I thought it might have to do with permissions so I ran zmfixperms from root but it didnt change anything. Is there a directory tree I could look at to see what folders in zimbra are supposed to be owned by zimbra and which ones are root?
    Bill

  4. #4
    Join Date
    Jan 2008
    Location
    Michigan
    Posts
    174
    Rep Power
    7

    Default

    after comparing both of my systems I found that the 6.0.1 had dspam folder owned by root but the dsapm-3.8.0 was owned by zimbra.
    my 5.0.18 had them both owned by root. When I changed it to match it ran without a problem.
    will mark this one solved.
    Bill

Similar Threads

  1. Enabling DSPAM
    By osiris in forum Administrators
    Replies: 80
    Last Post: 09-20-2012, 04:10 PM
  2. zmtrainsa + dspam = broken on 5.0.16GA network edition
    By shankwc in forum Administrators
    Replies: 1
    Last Post: 09-01-2011, 01:31 PM
  3. dspam broke after 4.5.7 upgrade?
    By Krishopper in forum Administrators
    Replies: 9
    Last Post: 09-24-2007, 08:07 AM
  4. Configuring and using DSPAM
    By JoshuaPrismon in forum Administrators
    Replies: 55
    Last Post: 03-02-2007, 08:08 AM
  5. Rewrote zmtrainsa for DSPAM
    By unilogic in forum Developers
    Replies: 18
    Last Post: 01-12-2006, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •