Results 1 to 5 of 5

Thread: zmstat crashes after upgrade to 6.0.1

  1. #1
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

    Default zmstat crashes after upgrade to 6.0.1

    Hi,

    one of the Zimbra's I manage is a 6.0.1_GA_1816.UBUNTU6 Network Edition that was upgraded from 5.x. We upgraded about 2 weeks ago, and I've had four alerts from my monitoring systems that one of zmstat's processes (zmstat-cpu) stops working.

    They all occur around 6:30 AM, which is (if I not mistaken) the time at which some cron/logrotate jobs should run.

    Anyone else seing this? Is it a know bug/issue?

  2. #2
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Are you seeing any errors in your log files /opt/zimbra/log/mailbox.log or /var/log/zimbra-stats.log?

    (Also you might want to update your forum profile if you have upgraded to 6.0.x)

  3. #3
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

    Default

    No errors what so ever. Still occurs from time to time, exactly at the time of the normal Ubuntu logrotate and daily system-cron. I suspect it's one of the processes that doesn't like the fact that it's logfile has changed?

    That box is still on 6.0.1 NE, I'll try to upgrade to 6.0.2 this weekend.

  4. #4
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Looks like 6:25 is when the daily crontab entries run, including logrotate.
    The only one that I see that might be causing the issue is /var/log/zimbra-stats.log. The relevant logrotate config on my system is:
    Code:
    /var/log/zimbra-stats.log {
        daily
        missingok
        notifempty
        create 0644 zimbra zimbra
        postrotate
          killall -HUP syslogd 2> /dev/null || true
          su - zimbra -c "/opt/zimbra/bin/zmlogswatchctl restart" > /dev/null 2>&1 || true
        endscript
        rotate 0
    }
    Does yours look any different?

  5. #5
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

    Default

    There are a few that seem logwatch related:

    /var/log/zimbra.log {
    daily
    missingok
    notifempty
    create 0644 zimbra zimbra
    postrotate
    killall -HUP syslogd 2> /dev/null || true
    su - zimbra -c "/opt/zimbra/bin/zmswatchctl restart" > /dev/null 2>&1 || true
    endscript
    compress
    }

    /var/log/zimbra-stats.log {
    daily
    missingok
    notifempty
    create 0644 zimbra zimbra
    postrotate
    killall -HUP syslogd 2> /dev/null || true
    su - zimbra -c "/opt/zimbra/bin/zmlogswatchctl restart" > /dev/null 2>&1 || true
    endscript
    rotate 0
    }

    /opt/zimbra/log/zmlogswatch.out {
    daily
    missingok
    copytruncate
    notifempty
    create 0740 zimbra zimbra
    postrotate
    su - zimbra -c "/opt/zimbra/bin/zmlogswatchctl stop"
    su - zimbra -c "/opt/zimbra/bin/zmlogswatchctl start"
    endscript
    rotate 5
    compress
    }

Similar Threads

  1. upgrade to 6.0.1 fails
    By evanmatre in forum Installation
    Replies: 4
    Last Post: 09-21-2010, 07:08 AM
  2. High Load amavisd after upgrade to 6.0.1
    By Nextasy in forum Installation
    Replies: 11
    Last Post: 05-19-2010, 11:51 AM
  3. Not found zmmsgtrace After upgrade to ZCS open-source 6.0.1
    By Fox_sibirsky in forum Administrators
    Replies: 3
    Last Post: 10-06-2009, 04:03 PM
  4. Recovering LDAP after upgrade to 6.0.1?
    By s0nspark in forum Administrators
    Replies: 6
    Last Post: 10-05-2009, 09:36 AM
  5. load doubles after upgrade from 5.0.14 to 6.0.1
    By gruad23 in forum Installation
    Replies: 3
    Last Post: 10-03-2009, 04:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •