Results 1 to 8 of 8

Thread: 6.0.1 Backups eating all drive space

  1. #1
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default 6.0.1 Backups eating all drive space

    I updated to 6.0.1 from 5.18 last month, Sep 21 to be exact. At that time only 40% of the available drive space was used. Today I noticed that 80% was used. Through looking at the stats log, I can see each time weekly full backup is run, it eats about 15%. This is really different from what happened with version 5.

    Will it keep doing this? I forsee running out of drive space really soon.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  2. #2
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default

    It looks like the /opt/zimbra/backup folder is sitting at 229gb, while /opt/zimbra/store is only 57gb. In 5.0.x we were using about 120gb total, now it's nearly 300gb.

    Why?Are backups not compressed at all?
    Last edited by quietas; 10-16-2009 at 12:03 PM.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  3. #3
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Posts
    291
    Rep Power
    10

    Default

    I noticed the same thing, and have subsequently reduced the amount of backups I keep, and ship the backups off to another server every night. I think they are compressed, but something is taking all the diskspace somehow. Maybe a stuck thread is not releasing it.
    http://www.solutionsfirst.com.au/hosting/zimbra/
    Australia's premier Zimbra Hosting Partner
    Resellers wanted!

  4. #4
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    backups can be compressed or uncompressed, it depends on hte -z argument to zmbackup in the crontab entries. it could be possible that you had this before, but the upgrade process removed it. i'd take a look

    you can maybe get a better idea by looking at the size of the backups you have in /opt/zimbra/backup/sessions. an easy way to get a listing would be like

    du -m -max-depth=1 /opt/zimbra/backup/sessions

  5. #5
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default

    Where would this hte setting be? I don't see it in /etc/crontab or in crontab.daily.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  6. #6
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    the best way to edit the cron files is using cron -e. make sure you're the zimbra user. it will spawn the default editor for this shell so if you have a favorite editor before you do naything else do

    Code:
    export VISUAL="nano -w"
    replace nano -w (the -w specifies no word wrap) with whatever editor you prefer . Then do

    Code:
    crontab -e
    you'll then be in the editor for the zimbra crontab entry. you want to find the backup lines that will look something like this

    Code:
    # BACKUP BEGIN
    0 0 * * * /opt/zimbra/bin/zmbackup -del 1m
    0 22 * * 5 /opt/zimbra/bin/zmbackup -f  -z -a all 
    0 19 * * 0-4,6 /opt/zimbra/bin/zmbackup -i -z 
    # BACKUP END
    Yours might be slightly different times, but the important thing is that -z option which tells the backups to compress. When you've added it to your full and incremental backups, exit your editor with saving and you should see a message at the prompt saying that the new crontab was installed.

  7. #7
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Posts
    291
    Rep Power
    10

    Default

    Interesting. my backups were not compressed anymore - just turned on that option and I will see how we go.
    http://www.solutionsfirst.com.au/hosting/zimbra/
    Australia's premier Zimbra Hosting Partner
    Resellers wanted!

  8. #8
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default

    I see that also. The -z option is not there for either of the last two lines in bdial's example.

    I don't suppose anyone has put in an RFE for having this added to the Admin Console?

    It seems that this should definitely be part of the config options. Turn off if it uses too much CPU time, too much drive space, or too much time to perform.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

Similar Threads

  1. Zimbra Eating Hard Drive Space
    By abhiz in forum Administrators
    Replies: 1
    Last Post: 03-24-2009, 02:14 AM
  2. Of backups and restoration
    By lcxe in forum Administrators
    Replies: 10
    Last Post: 11-20-2008, 10:13 AM
  3. [SOLVED] Error running mailboxd after script backup
    By ttortosa in forum Administrators
    Replies: 5
    Last Post: 10-22-2008, 02:33 AM
  4. old backups from 4.0.5_GA taking up too much space!
    By riccadus in forum Administrators
    Replies: 1
    Last Post: 04-04-2007, 01:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •