Results 1 to 4 of 4

Thread: Mail Relay Questions ? Local vs Outbound Relays

Hybrid View

  1. #1
    Join Date
    Oct 2009
    Location
    North Carolina, USA
    Posts
    58
    Rep Power
    6

    Default Mail Relay Questions ? Local vs Outbound Relays

    First - Let me say this product has replaced my old Postfix,Dovecot,MailScanner (SA,ClamAV) installation and given me a nice web and desktop tool for using a nice integrated collaboration suite - Good job.

    As I monitor my logs I have seen a issue that I am not sure how it was created or how to change it. Local accounts are being routed internally - just fine. However, my admin account is being relayed out as if it needs to go outside my domain to be delivered.

    example: internal mail routes fine.

    Oct 18 13:48:35 mail1 postfix/qmgr[2081]: E261A25782D: from=<steven@sprague-enterprises.com>, size=1845, nrcpt=1 (queue active)
    Oct 18 13:48:35 mail1 amavis[31539]: (31539-01) FWD via SMTP: <steven@sprague-enterprises.com> -> <shirley@sprague-enterprises.com>,BODY=7BIT 250 2.0.0 Ok, id=31539-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as E261A25782D
    Oct 18 13:48:35 mail1 amavis[31539]: (31539-01) Passed CLEAN, LOCAL [192.168.0.8] [192.168.0.8] <steven@sprague-enterprises.com> -> <shirley@sprague-enterprises.com>, Message-ID: <9009351.01255888112062.JavaMail.root@mail1.spragu e-enterprises.com>, mail_id: TjLQwkGuCZ7z, Hits: -4.399, size: 1141, queued_as: E261A25782D, 1804

    However, Mail "TO" Admin it going outside to my relay and back - it this normal? or should I change it? If so how.

    example:
    Oct 18 13:19:23 mail1 postfix/smtp[6299]: ACF4C25784F: to=<admin@mail1.sprague-enterprises.com>, relay=outbound.mailhop.org[204.13.248.71]:2525, delay=2072, delays=2071/0.63/0.24/0.17, dsn=2.0.0, status=sent (250 OK id=1MzZPf-000OT9-Le)

    Thanks, Steven

  2. #2
    Join Date
    Jul 2006
    Location
    Stuttgart / Germany
    Posts
    223
    Rep Power
    9

    Default

    Quote Originally Posted by tribear View Post

    example:
    Oct 18 13:19:23 mail1 postfix/smtp[6299]: ACF4C25784F: to=<admin@mail1.sprague-enterprises.com>, relay=outbound.mailhop.org[204.13.248.71]:2525, delay=2072, delays=2071/0.63/0.24/0.17, dsn=2.0.0, status=sent (250 OK id=1MzZPf-000OT9-Le)

    Thanks, Steven
    It looks, as though your admin account resides in a different domain (mail1.sprague-enterprises.com contrary to sprague-enterprises.com). I guess the domain mail1.sprague-enterprises.com is not known to your Zimbra server and MX points to some external host...
    Remember that Zimbra will always deliver locally if the destination Domain is existing on the Zimbra Server - no matter what MX settings look like...

    Regards
    Thomas

  3. #3
    Join Date
    Oct 2009
    Location
    North Carolina, USA
    Posts
    58
    Rep Power
    6

    Default

    Quote Originally Posted by deepblue View Post
    It looks, as though your admin account resides in a different domain (mail1.sprague-enterprises.com contrary to sprague-enterprises.com). I guess the domain mail1.sprague-enterprises.com is not known to your Zimbra server and MX points to some external host...
    Remember that Zimbra will always deliver locally if the destination Domain is existing on the Zimbra Server - no matter what MX settings look like...

    Regards
    Thomas
    Here's what I think has happened - on install the script does a nslookup or dig for my MX and corresponding A record for mail1.sprague-enterprises and failed - even though my DNS server has both and localhost entry too. All this resolves when nslookup is run here.

    The server install.sh script asks to change the domain name? I tried to change if from mail1..... to simply sprague-enterprises.com and fails. Later I ran used domain rename command to change domain mail1.sprague-enterpries.com to sprague-enterpries.com.

    So, some how admin is still linked to mail1..... and this may be forcing the routing.
    Does that sound right? Anyway, how can I fix it so Admin is part of my domain and not screw up it rolls and responsibilities? or other links that got installed.

    Steven

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    su - zimbra
    zmlocalconfig | grep mail1.sprague-enterpries.com
    That should list all the admin emails that will need to be changed eg. avnotify.

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. mta to not starting
    By cowanpf in forum Installation
    Replies: 2
    Last Post: 10-05-2009, 04:36 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 08:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •