First - Let me say this product has replaced my old Postfix,Dovecot,MailScanner (SA,ClamAV) installation and given me a nice web and desktop tool for using a nice integrated collaboration suite - Good job.

As I monitor my logs I have seen a issue that I am not sure how it was created or how to change it. Local accounts are being routed internally - just fine. However, my admin account is being relayed out as if it needs to go outside my domain to be delivered.

example: internal mail routes fine.

Oct 18 13:48:35 mail1 postfix/qmgr[2081]: E261A25782D: from=<steven@sprague-enterprises.com>, size=1845, nrcpt=1 (queue active)
Oct 18 13:48:35 mail1 amavis[31539]: (31539-01) FWD via SMTP: <steven@sprague-enterprises.com> -> <shirley@sprague-enterprises.com>,BODY=7BIT 250 2.0.0 Ok, id=31539-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as E261A25782D
Oct 18 13:48:35 mail1 amavis[31539]: (31539-01) Passed CLEAN, LOCAL [192.168.0.8] [192.168.0.8] <steven@sprague-enterprises.com> -> <shirley@sprague-enterprises.com>, Message-ID: <9009351.01255888112062.JavaMail.root@mail1.spragu e-enterprises.com>, mail_id: TjLQwkGuCZ7z, Hits: -4.399, size: 1141, queued_as: E261A25782D, 1804

However, Mail "TO" Admin it going outside to my relay and back - it this normal? or should I change it? If so how.

example:
Oct 18 13:19:23 mail1 postfix/smtp[6299]: ACF4C25784F: to=<admin@mail1.sprague-enterprises.com>, relay=outbound.mailhop.org[204.13.248.71]:2525, delay=2072, delays=2071/0.63/0.24/0.17, dsn=2.0.0, status=sent (250 OK id=1MzZPf-000OT9-Le)

Thanks, Steven