Results 1 to 4 of 4

Thread: all messages being deferred after server rename

  1. #1
    Join Date
    Oct 2009
    Rep Power

    Default all messages being deferred after server rename

    I have a problem with all emails (inbound and outbound) being deferred.

    I initially had some extra hostnames in my /etc/hosts file: somename demo was initially used for install of zcs-5.0.4 rhel4. ldap server details (as per localconfig) referenced this. The original server `hostname` was, but changed a few months ago to There were no issues with the server hostname change, as zimbra's naming stayed the same. I need to change the zimbra server name, so used the wiki as guidelines.

    Error from /var/log/zimbra.log is:
    status=deferred (Host or domain name not found. Name service error for type=A: Host not found, try again)

    /etc/hosts: localhost.localdomain somename

    /etc/resolv.conf (valid nameservers from service provider):
    nameserver x.y.z.w
    nameserver a.b.c.d

    dig mx: 300 IN MX 10 14400 IN A

    dig any: 10618 IN A
    ## nameserver info - all on servers in different networks, working correctly ##


    host `hostname`: has address

    seems resolution and dns is configured correctly, but all messages still getting deferred.

    1 thing that might be related is that i remember working with zmlocalconf to get mailman integrated with zimbra:
    postfix_mydestination = localhost

    also, zmlocalconfig shows ldap_host as instead of after changing this to, i get errors in zimbra.log:
    postfix/trivial-rewrite: error: unable tio set STARTTLS: -1: can't contact ldap server

    have just updated ldap_url from ldap:// to ldap:// to see if that helps.

  2. #2
    Join Date
    Nov 2006
    Rep Power


    Check /var/log/zimbra.log to see while Postfix is not delivering them.

  3. #3
    Join Date
    Mar 2007
    Plymouth, uk
    Rep Power


    Looks like its just DNS resolution thats broken (Host not found, try again), make sure you can resolve these hosts with dig/host/ping on the system before changing any zimbra stuff (check /etc/resolv.conf, add your dns server to that: nameserver your.dns.server.ip)

  4. #4
    Join Date
    Oct 2009
    Rep Power


    my resolution works fine. whether i use host / ping / dig, manually specifying nameservers or letting pam take care of name resolution order (i.e from hosts file first), it always seems to resolve.

    i just discovered selinux was enforcing, rebooting now with it disabled.

Similar Threads

  1. zmmailboxdctl is not running !!!!!!
    By olibite in forum Administrators
    Replies: 14
    Last Post: 04-28-2011, 06:50 AM
  2. Deferred messages from Mailer-Daemon
    By jpcaldwell in forum Administrators
    Replies: 11
    Last Post: 12-30-2009, 03:19 PM
  3. 340 deferred messages stuck in the queue
    By borngunners in forum Administrators
    Replies: 8
    Last Post: 10-05-2009, 06:32 PM
  4. Replies: 0
    Last Post: 08-20-2009, 01:19 PM
  5. Config forward of all messages to mailarchiva server
    By visualsoftspace in forum Installation
    Replies: 4
    Last Post: 05-02-2008, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts