Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: sending email from other address

  1. #1
    Join Date
    Oct 2009
    Posts
    8
    Rep Power
    6

    Default sending email from other address

    Hello

    I'm trying to implement te following
    I have a user who has multiple addresses in one mailbox

    whenever a mail is received on let' s say user@seconddomain.com
    and the user hit reply I want her to send an email from that address
    so not the standard user@primarydomain.com

    I know that can be done with the 'add persona' option
    but in this new version Zimbra 6.0 I can add new Persona
    BUT I cannot seem to enter an other email address
    I get a dropdownlist and all I can choose is user@primarydomain.com

    If I'm not mistaken... in the older version we had we could just type an emailaddress there...


    How do I solve this?

  2. #2
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    By default a user can only send messages from their main account or an alias specified on their account. You can allow them to send from any address by clicking the User -> Preferences tab -> Sending Mail section -> Allow sending email from any address option in the admin UI.

    This can also be defined in the COS.

  3. #3
    Join Date
    Jan 2008
    Posts
    223
    Rep Power
    7

    Default

    Quote Originally Posted by ArcaneMagus View Post
    By default a user can only send messages from their main account or an alias specified on their account. You can allow them to send from any address by clicking the User -> Preferences tab -> Sending Mail section -> Allow sending email from any address option in the admin UI.

    This can also be defined in the COS.
    I find after Upgrade from 5.02 to 6.02 the secondary account is unable to send mail.The Primary mail account & secondary account both of diff domains , but hosted on Same Server.The Config is when sending mail Promary account can nt send mails to internet , but secondary can.After Upgade when sending mails from secondary acount Zimbra log reports mails being sent from Promary account.

    Any Solution ?

  4. #4
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Uh... the mails should be showing as coming from whatever account the user has picked in the drop down list of available accounts if they have multiple configured (and are allowed to send from those addresses)

  5. #5
    Join Date
    Jan 2008
    Posts
    223
    Rep Power
    7

    Default

    Quote Originally Posted by ArcaneMagus View Post
    Uh... the mails should be showing as coming from whatever account the user has picked in the drop down list of available accounts if they have multiple configured (and are allowed to send from those addresses)
    Yes Correct ! But Suprizingly it appears from Primary account as per log , even though a secondary account is selected & even in sent mail the mail is being displayed as having sent from Secondary account.

  6. #6
    Join Date
    Jan 2008
    Posts
    223
    Rep Power
    7

    Default

    Quote Originally Posted by Himanshu View Post
    Yes Correct ! But Suprizingly it appears from Primary account as per log , even though a secondary account is selected & even in sent mail the mail is being displayed as having sent from Secondary account.
    Looks Like a Bug t me .How to overcome this till it gets resolved..? Any suggestions.. !!

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Himanshu View Post
    Looks Like a Bug t me .How to overcome this till it gets resolved..? Any suggestions.. !!
    You haven't given any information that shows this as being a 'bug', how about some headers from the email and a complete description of what the settings are for the primary account and secondary account (you can use zmprov to dump the data).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Jan 2008
    Posts
    223
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    You haven't given any information that shows this as being a 'bug', how about some headers from the email and a complete description of what the settings are for the primary account and secondary account (you can use zmprov to dump the data).
    Attached the File showing
    1.screenshot of log file
    2.Message Source of sent file of zimbra
    3.Message Source of mail with receipient.

    The mail was sent from secondary account as displayed in 2 and 3
    but the log file shows something else.This results in issues when Primary account is not allowed to send mail , but secondary is.
    Attached Files Attached Files
    Last edited by Himanshu; 11-16-2009 at 06:53 AM. Reason: Attachment Missing

  9. #9
    Join Date
    Jan 2008
    Posts
    223
    Rep Power
    7

    Default

    Quote Originally Posted by Himanshu View Post
    Attached the File showing
    1.screenshot of log file
    2.Message Source of sent file of zimbra
    3.Message Source of mail with receipient.

    The mail was sent from secondary account as displayed in 2 and 3
    but the log file shows something else.This results in issues when Primary account is not allowed to send mail , but secondary is.
    zmprov -gid attached.
    Attached Files Attached Files
    Last edited by Himanshu; 11-16-2009 at 09:36 AM.

  10. #10
    Join Date
    Jan 2008
    Posts
    223
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    You haven't given any information that shows this as being a 'bug', how about some headers from the email and a complete description of what the settings are for the primary account and secondary account (you can use zmprov to dump the data).
    Hello Bill,

    Is Data sufficient ? or need more...

Similar Threads

  1. Auto-respond to email sent to old address
    By mathew in forum Administrators
    Replies: 0
    Last Post: 04-22-2009, 07:35 AM
  2. Blocking a specific email address
    By SpEnTBoY in forum Administrators
    Replies: 10
    Last Post: 12-06-2007, 06:37 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  4. Problem in picking-up email address
    By mansuper in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 03-04-2007, 03:59 PM
  5. Replies: 1
    Last Post: 09-10-2005, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •