Results 1 to 7 of 7

Thread: Upgrade 5.0.19 to 6.0.2 ERROR

  1. #1
    Join Date
    Aug 2009
    Posts
    11
    Rep Power
    6

    Default Upgrade 5.0.19 to 6.0.2 ERROR

    I wish to refresh Zimbra to the last version. At attempt all starts normally, but I receive the following error:
    Code:
    Do you wish to upgrade? [Y] y
    
    Select the packages to install
        Upgrading zimbra-core
        Upgrading zimbra-ldap
        Upgrading zimbra-logger
        Upgrading zimbra-mta
        Upgrading zimbra-snmp
        Upgrading zimbra-store
        Upgrading zimbra-apache
        Upgrading zimbra-spell
    
    Install zimbra-memcached [N] n
    
    Install zimbra-proxy [N] n
    Checking required space for zimbra-core
    checking space for zimbra-store
    
    Installing:
        zimbra-core
        zimbra-ldap
        zimbra-logger
        zimbra-mta
        zimbra-snmp
        zimbra-store
        zimbra-apache
        zimbra-spell
    
    The system will be modified.  Continue? [N] y
    
    Shutting down zimbra mail
       zimbra-store...done
       zimbra-spell...done
       zimbra-apache...done
       zimbra-core...done
    
    Removing deployed webapp directories
    Installing packages
    
        zimbra-core......zimbra-core-6.0.2_GA_1912.SuSEES10-20091020145320.i386.rpm...done
        zimbra-ldap......zimbra-ldap-6.0.2_GA_1912.SuSEES10-20091020145320.i386.rpm...done
        zimbra-logger......zimbra-logger-6.0.2_GA_1912.SuSEES10-20091020145320.i386.rpm...done
        zimbra-mta......zimbra-mta-6.0.2_GA_1912.SuSEES10-20091020145320.i386.rpm...done
        zimbra-snmp......zimbra-snmp-6.0.2_GA_1912.SuSEES10-20091020145320.i386.rpm...done
        zimbra-store......zimbra-store-6.0.2_GA_1912.SuSEES10-20091020145320.i386.rpm...done
        zimbra-apache......zimbra-apache-6.0.2_GA_1912.SuSEES10-20091020145320.i386.rpm...done
        zimbra-spell......zimbra-spell-6.0.2_GA_1912.SuSEES10-20091020145320.i386.rpm...done
    
    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
       HOSTNAME=mail.domain.com
       LDAPHOST=mail.domain.com
       LDAPPORT=389
       SNMPTRAPHOST=mail.domain.com
       SMTPSOURCE=admin@domain.com
       SMTPDEST=admin@domain.com
       SNMPNOTIFY=yes
       SMTPNOTIFY=yes
       LDAPROOTPW=password
       LDAPZIMBRAPW=password
       LDAPPOSTPW=password
       LDAPREPPW=password
       LDAPAMAVISPW=password
       LDAPNGINXPW=password
    Restoring existing configuration file from /opt/zimbra/.saveconfig/localconfig.xml...done
    Operations logged to /tmp/zmsetup.10222009-110535.log
    Upgrading from 5.0.18_GA_3011 to 6.0.2_GA_1912
    Stopping zimbra services...done.
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql...done.
    This appears to be 5.0.18_GA
    Schema upgrade required from version 61 to 63.
    Running /opt/zimbra/libexec/scripts/migrate20090406-DataSourceItemTable.pl
    Thu Oct 22 11:05:51 2009: Verified schema version 61.
    ERROR 1005 (HY000) at line 2: Can't create table './mboxgroup10/data_source_item.frm' (errno: -1)
    Thu Oct 22 11:05:53 2009: Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=password --database=zimbra --batch --skip-column-names'.
    Script failed with code 256:  - exiting
    UPGRADE FAILED - exiting.
    Last edited by ArcaneMagus; 10-22-2009 at 02:25 AM. Reason: Removed passwords

  2. #2
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    The title of your post says 5.0.19 but your command line output says you are running 5.0.18. It's possible that you need to upgrade from .18 to .19 before making the upgrade to 6.0.2. ...Just an idea.
    A server I'm administering right now is also at 5.0.18 and I'm looking to upgrade it straight to 6.0.2 so your post caught my eye. Now I will go to .19 first!!

  3. #3
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    this is interesting, it almost does look like it failed going from 5.0.18 - 6.0.2.

    I too am on 5.0.18 and was going to go straight to 6.0.2, I think now I will also upgrade to .19 first. Even though the Release Notes indicate you should be able to upgrade from any version of 5.0.x to 6.0.x

  4. #4
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Did you allow it to run the mysql database check before the upgrade?

  5. #5
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    I realize that the release notes say you should be able to go from any version of 5 to 6 but it's not quite a perfect world we live in...

    Last night when I performed the update from 5.0.18 to .19 I let it perform the database integrity check and logger check. There were errors in both, so I ran the checks a second time, and the upgrade script's auto correct fixed them for me. The .19 upgrade went smoothly after that and I verified it's installation was working correctly after upgrade.

    Next, I did the 6.0.2 upgrade, and this time no database or logger errors as they had just been corrected, but was instead notified about sysstat which I needed to install from the command line or package manager. After sysstat was installed, smooth sailing again till I had to select weather to turn on or off automatic upgrade checks. That was no problem either, just part of the normal process for 6.0 that was not something in the 5.0 line install procedure. Overall this server had a very smooth transition from 5.0.18 to 6.0.2. Thank you Zimbra!! You rock!

    Make sure you are perform any integrity checks on MySQL/database and logger at least twice. ...The first to catch any errors, the second to fix them. And also, after sysstat was installed I manually changed the sysstat config file at
    Code:
    /etc/default/sysstat
    from "false" to "true" and then restarted sysstat with
    Code:
    sudo /etc/init.d/sysstat restart
    because I had read on another post that you can have small problems if you don't manually change this before implementing 6.0.
    Last edited by tikal; 10-22-2009 at 01:46 PM.

  6. #6
    Join Date
    Aug 2009
    Posts
    11
    Rep Power
    6

    Default

    Thanks all for responses!

    But I have solved this problem a little in another way. Yes, really, I used version 5.0.18. Following advices, I have refreshed ZCS to version 5.0.19. But at attempt to pass with 5.0.19 on 6.0.2 I has received the same error!!!
    The error arises by script operation/opt/zimbra/libexec/scripts/migrate20090406-DataSourceItemTable.pl. Experimentally it was possible to solve this problem, having substituted string
    ENGINE = InnoDB on ENGINE = MyISAM, thereby having changed table type.
    I do not know how much it correctly, but it works! I hope that my experience will help another...

  7. #7
    Join Date
    May 2009
    Location
    Jakarta
    Posts
    86
    Rep Power
    6

    Default

    Hmmm. curoiusly.....
    Today I've already finished upgrading zimbra from 5.0.18 to 6.0.2 and I don't get any error or problem, my zimbra running well...

Similar Threads

  1. Issue after upgrade from 5.0.18 to 5.0.19
    By joschi in forum Administrators
    Replies: 2
    Last Post: 10-05-2009, 03:20 PM
  2. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 05:42 PM
  3. Replies: 3
    Last Post: 01-07-2009, 01:44 AM
  4. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 04:58 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •