Results 1 to 2 of 2

Thread: error Resolving MX record

  1. #1
    Join Date
    Oct 2009
    Posts
    3
    Rep Power
    6

    Default error Resolving MX record

    hi ..........
    this is debasmita and am installing zcs 6.0 on linux platform.

    dns server and Zimbra are installed in the same system itself with IP 192.168.10.2 and FQDN mailadmin.hcl.org.

    configuration of /etc/hosts
    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain   localhost
    192.168.10.2     mailadmin.hcl.org       mailadmin
    Code:
    #vi /etc/resolve.conf
    nameserver 192.168.10.2
    domain hcl.org
    search hcl.org

    I have set up the same system as DNS server as well as Zimbra admin server....
    configuration of /etc/named.conf
    Code:
    zone "hcl.org" IN {
            type master;
            file "orgforward.zone";
            allow-update { none; };
    };
    
    zone "10.168.192.in-addr.arpa" IN {
            type master;
            file "orgreverse.zone";
            allow-update { none; };
    };
    configuration of forward and reverse zone files:
    Code:
    #cd /var/named/chroot/var/named
    # vi orgforward.zone
    $TTL    86400
    @               IN SOA  mailadmin.hcl.org root.mailadmin.hcl.org (
                                            42              ; serial (d. adams)
                                            3H              ; refresh
                                            15M             ; retry
                                            1W              ; expiry
                                            1D )            ; minimum
                            IN              NS      mailadmin.hcl.org.
                            IN              MX  10  mailadmin.hcl.org.
    mailadmin               IN A            192.168.10.2
    
    # vi orgreverse.zone
    $TTL    86400
    @       IN      SOA     mailadmin.hcl.org. root.mailadmin.hcl.org.  (
                                          1997022700 ; Serial
                                          28800      ; Refresh
                                          14400      ; Retry
                                          3600000    ; Expire
                                          86400 )    ; Minimum
                  IN      NS      mailadmin.hcl.org.
    
    2             IN      PTR     mailadmin.hcl.org.
    Code:
    # service named restart
    now the comaands
    Code:
    dig hcl.org any
    dig hcl.org mx
    are also giving the desired o/p.

    but while installing zcs 6.0 it is giving the error as
    ERROR RESOLVING MX RECORD FOR DNS mailadmin.hcl.org

    its getting installed and mails are getting delivered in lan within two different domains but its not getting delivered to gmail or yahoomail. Moreover while am checking the MX record from within the Zimbra Admin console ... its showing
    Failed to retrieve MX records for domain mailadmin.hcl.org.

    Please provide a solution.

    THANKS in Advance
    Last edited by ArcaneMagus; 10-26-2009 at 12:25 AM. Reason: Converted font to code blocks

  2. #2
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    debasmita you have setup MX records for hcl.org.... not mailadmin.hcl.org which it looks like is what you have configured as the domain in Zimbra. You might want to try setting up your zimbra server to have hcl.org as the domain (unless you specifically want mailadmin.hcl.org to be the domain in which case your DNS is totally wrong...

Similar Threads

  1. Issue: MX Record & Multi-domain
    By wcbenyip in forum Installation
    Replies: 5
    Last Post: 06-23-2009, 07:15 PM
  2. Replies: 11
    Last Post: 05-12-2009, 07:26 AM
  3. MX record not found problem
    By needhelpnow in forum Installation
    Replies: 29
    Last Post: 04-09-2008, 04:19 PM
  4. Mail sent to the A record of the server, not MX
    By BarthezZ in forum Installation
    Replies: 4
    Last Post: 06-22-2007, 04:16 AM
  5. MX record cannot deliver mail
    By computerguy24 in forum Administrators
    Replies: 3
    Last Post: 09-06-2006, 05:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •