Results 1 to 10 of 10

Thread: [SOLVED] Daily Reports stopped with 6.0.2 upgrade

  1. #1
    Join Date
    May 2008
    Posts
    4
    Rep Power
    7

    Default [SOLVED] Daily Reports stopped with 6.0.2 upgrade

    Since upgrading to 6.0.2 I stopped getting the daily report emails. I can manually run zmdailyreport -m and it works. So I checked the zimbra crontab and found that the Daily reports section was missing. Is it safe to just add the following block to my crontab or is there a better way of getting the daily report working again?

    Code:
    # Daily reports
    #
    10 1 * * * /opt/zimbra/libexec/zmdailyreport -m
    #

  2. #2
    Join Date
    Jan 2008
    Posts
    62
    Rep Power
    7

    Default

    It should have been uncommented and set to run at 23:30, rather than 1:10

  3. #3
    Join Date
    May 2008
    Posts
    4
    Rep Power
    7

    Default

    Thanks I've added it to my crontab to run daily at 11:30pm.

  4. #4
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    Ours is set to run at 11:30 but it doesn't appear to run until about 1 in the morning and when it does run it only shows the following.

    Code:
    zmdailyreport from 2009-11-12 00:00:00 to 2009-11-13 00:00:00
    
    2 messages found for 2 total recipients (1 unique)
    	           4234    total bytes
    	           2117.00 average bytes/msg
    	              1.00 average recipients/msg
    	             17.00 average delay/msg (sec)
    Any ideas on where to start looking?

    dj

  5. #5
    Join Date
    Jan 2008
    Posts
    62
    Rep Power
    7

    Default

    This does not appear to be a report from 6.0 but rather 5.0, can you verify your version of zcs and the help options you get when running /opt/zimbra/libexec/zmdailyreport -h

    Quote Originally Posted by dljordaneku View Post
    Ours is set to run at 11:30 but it doesn't appear to run until about 1 in the morning and when it does run it only shows the following.

    Code:
    zmdailyreport from 2009-11-12 00:00:00 to 2009-11-13 00:00:00
    
    2 messages found for 2 total recipients (1 unique)
    	           4234    total bytes
    	           2117.00 average bytes/msg
    	              1.00 average recipients/msg
    	             17.00 average delay/msg (sec)
    Any ideas on where to start looking?

    dj

  6. #6
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    Quote Originally Posted by pfnguyen View Post
    This does not appear to be a report from 6.0 but rather 5.0, can you verify your version of zcs and the help options you get when running /opt/zimbra/libexec/zmdailyreport -h
    zmcontrol -v gives me Release 6.0.2_GA_1912.UBUNTU8 UBUNTU8 NETWORK edition.

    And the zmdailyreport -h gives me

    Usage:
    Usage: zmdailyreport [options]

    Options:
    --mail Send report via email, default is stdout
    --help This help message


    dj

  7. #7
    Join Date
    Jan 2008
    Posts
    62
    Rep Power
    7

    Default

    That all looks correct, what happens if you run /opt/zimbra/libexec/zmdailyreport right now? It should produce a report valid up until now, for today.

    Can you determine why your cronjob is running at 1am instead of 11:30pm?

  8. #8
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    Quote Originally Posted by pfnguyen View Post
    That all looks correct, what happens if you run /opt/zimbra/libexec/zmdailyreport right now? It should produce a report valid up until now, for today.

    Can you determine why your cronjob is running at 1am instead of 11:30pm?
    ROFL

    Ok. I don't know if I want to admit what's going on or not Anyway, where do I set the email address for the daily report to go to? What is going on is we just migrated over to a new server and the old server was still running. So we were getting the reports from the old server and not the new one. The daily reports from the new server are just going to the new admin account and not to the list we set up

    dj

  9. #9
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Code:
    zmlocalconfg -e smtp_destination=listaddress@domain.com
    That should change the address the report gets delivered to.

  10. #10
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    Quote Originally Posted by ArcaneMagus View Post
    Code:
    zmlocalconfg -e smtp_destination=listaddress@domain.com
    That should change the address the report gets delivered to.
    Thanks.

    dj

Similar Threads

  1. Upgrade to 6.0.2 advice
    By sadams@bigrocksports.com in forum Zimbra Connector for BlackBerry
    Replies: 7
    Last Post: 10-27-2009, 10:42 AM
  2. [SOLVED] Upgrade from 6.0.1 to 6.0.2 fails
    By ianw1974 in forum Installation
    Replies: 2
    Last Post: 10-25-2009, 12:08 PM
  3. [SOLVED] Upgraded to 4.5.11 - Daily Reports Stopped
    By msf004 in forum Administrators
    Replies: 15
    Last Post: 07-27-2008, 11:11 AM
  4. Replies: 1
    Last Post: 10-28-2007, 02:35 AM
  5. Daily mail reports!
    By celeron in forum Administrators
    Replies: 7
    Last Post: 03-22-2007, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •