Results 1 to 8 of 8

Thread: Failure to create new cert

Hybrid View

  1. #1
    Join Date
    Nov 2005
    Posts
    108
    Rep Power
    9

    Default Failure to create new cert

    Hi all, need some help.

    I'm following the wiki tutorial to create a self-signed cert to replace an expired one. http://wiki.zimbra.com/index.php?tit...certificate%29

    When I get to step 2 and type the following:
    Code:
    keytool -delete -alias my_ca -keystore /opt/zimbra/tomcat/conf/keystore -keypass zimbra
    It responds with:
    Code:
    Enter keystore password:
    Where would I find this password? I've generated a cert before and never seen this. How do I progress beyond this step?

    Any help will be appreciated.

    Thanks!

    jimbo

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Try 'changeit' or 'zimbra'
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Nov 2005
    Posts
    108
    Rep Power
    9

    Default

    Kevin,

    As always, thanks for the response. You are always helpful.

    OK, I tried entering the password zimbra and now it responds with:
    Code:
    keytool error: java.lang.Exception: Alias <my_ca> does not exist
    any ideas what I'm doing wrong?

    jimbo

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Interesting.. What is you skip that step and continue. Do the rest of the steps work for you?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Nov 2005
    Posts
    108
    Rep Power
    9

    Default

    No, it says that <my_ca> doesn't exist.

    I have no idea what is up with that! ;-)

    james

  6. #6
    Join Date
    Jun 2006
    Location
    Washington DC
    Posts
    124
    Rep Power
    9

    Default

    Quote Originally Posted by jimbo
    No, it says that <my_ca> doesn't exist.

    I have no idea what is up with that! ;-)

    james
    I have same issue.
    Running zcs-3.1.2_GA_445.FC4 on FC4 ( Fedora Core 4 ).
    Tried both as zimbra user and as root doing via sudo -u zimbra .
    Same thing.
    Followed WIKI instructions to the letter.
    After each error, I started with new "instance" ( running via VMware so just recopied each time ).

    No other issues with Zimbra really. Just wanted to push the cert expiry date out further.
    The current cert will expire 9/11/06.

    Scotty

Similar Threads

  1. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  2. Cannot determine services - exiting
    By tawas in forum Installation
    Replies: 7
    Last Post: 04-25-2006, 02:47 AM
  3. Initializing ldap...FAILED (256)
    By CVD in forum Installation
    Replies: 17
    Last Post: 03-10-2006, 08:47 AM
  4. Yet another get.DirectContext issue
    By dccpark in forum Installation
    Replies: 5
    Last Post: 03-08-2006, 12:25 PM
  5. system failure: getDirectContext
    By avisser in forum Installation
    Replies: 3
    Last Post: 10-12-2005, 05:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •