Results 1 to 10 of 11

Thread: High CPU usage on server and client

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Posts
    10
    Rep Power
    9

    Default High CPU usage on server and client

    Hi,

    I am doing a test drive with Zimbra version 3.10.GA_332.FC4 on a PC with 2GB RAM and 2.6GHZ P4 CPU. There are just less than 10 users created and I found that CPU usage was very high from time to time, even though there is only one user trying to connect through web at the moment. Besides, on the client side we noticed the CPU usage hit 100% when trying to connect to Zimbra, we tried both firefox and IE on Windows XP.

    This box is dedicated for Zimbra only, I installed the Zimbra by following the instructions provided, nothing else not mentioned in the instructions is installed.

    Below is the "top" result I captured:

    [root@mail ~]# top
    top - 11:39:17 up 30 days, 13:02, 1 user, load average: 0.14, 0.15, 0.16
    Tasks: 111 total, 3 running, 108 sleeping, 0 stopped, 0 zombie
    Cpu(s): 26.2% us, 3.3% sy, 0.0% ni, 70.4% id, 0.0% wa, 0.0% hi, 0.0% si
    Mem: 2067660k total, 1988456k used, 79204k free, 78240k buffers
    Swap: 4192956k total, 0k used, 4192956k free, 1189664k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    12039 zimbra 19 0 461m 22m 10m R 28.3 1.1 0:00.85 java
    13972 zimbra 22 0 873m 245m 14m S 1.0 12.1 4:31.07 java
    14024 zimbra 16 0 737m 57m 3632 S 0.3 2.8 11:25.69 mysqld
    9745 root 16 0 2024 1008 784 R 0.3 0.0 0:01.24 top
    1 root 16 0 1744 568 492 S 0.0 0.0 0:01.57 init
    2 root 34 19 0 0 0 S 0.0 0.0 0:00.00 ksoftirqd/0
    3 root RT 0 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
    4 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 events/0
    5 root 12 -5 0 0 0 S 0.0 0.0 0:00.01 khelper
    6 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 kthread
    8 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 kacpid
    80 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 kblockd/0
    83 root 15 0 0 0 0 S 0.0 0.0 0:00.00 khubd
    129 root 20 0 0 0 0 S 0.0 0.0 0:00.00 pdflush
    130 root 15 0 0 0 0 S 0.0 0.0 0:01.67 pdflush


    Any suggestion is highly appreciated.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    First, you could try upgrading to the most recent release of Zimbra. High CPU usage can be caused by the logger, can you disable/stop that and see if the CPU usage goes down.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2006
    Posts
    10
    Rep Power
    9

    Default

    Just upgraded to the latest version - 3.13_GA_474.FC4, but still got high CPU usage:

    top - 23:07:05 up 32 days, 30 min, 1 user, load average: 0.25, 0.55, 0.51
    Tasks: 111 total, 2 running, 109 sleeping, 0 stopped, 0 zombie
    Cpu(s): 47.0% us, 5.3% sy, 0.0% ni, 47.7% id, 0.0% wa, 0.0% hi, 0.0% si
    Mem: 2067660k total, 1857432k used, 210228k free, 103480k buffers
    Swap: 4192956k total, 60k used, 4192896k free, 1234908k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    19885 zimbra 17 0 43248 8832 2972 S 0.3 0.4 0:00.18 slapd
    24382 zimbra 16 0 7060 3324 1736 S 0.3 0.2 0:00.10 zmmtaconfig
    1 root 16 0 1744 568 492 S 0.0 0.0 0:01.59 init
    2 root 34 19 0 0 0 S 0.0 0.0 0:00.00 ksoftirqd/0
    3 root RT 0 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
    4 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 events/0


    Any suggestions?

    Thanks!

  4. #4
    Join Date
    Feb 2006
    Posts
    10
    Rep Power
    9

    Default

    Here is another "top" capture:

    [root@mail zcs]# top
    top - 23:20:07 up 32 days, 43 min, 1 user, load average: 0.41, 0.25, 0.33
    Tasks: 122 total, 5 running, 117 sleeping, 0 stopped, 0 zombie
    Cpu(s): 81.6% us, 18.4% sy, 0.0% ni, 0.0% id, 0.0% wa, 0.0% hi, 0.0% si
    Mem: 2067660k total, 1933072k used, 134588k free, 103528k buffers
    Swap: 4192956k total, 60k used, 4192896k free, 1236268k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    25514 zimbra 16 0 104m 15m 3128 S 79.2 0.8 0:09.42 mysqld
    3472 zimbra 18 0 7288 4592 2132 R 19.6 0.2 0:00.89 zmlogprocess
    25988 zimbra 16 0 736m 53m 3356 S 0.7 2.6 0:00.69 mysqld
    26437 zimbra 16 0 866m 202m 15m S 0.7 10.0 0:11.82 java
    3458 root 16 0 2024 1012 784 R 0.3 0.0 0:00.02 top
    1 root 16 0 1744 568 492 S 0.0 0.0 0:01.59 init
    2 root 34 19 0 0 0 S 0.0 0.0 0:00.00 ksoftirqd/0
    3 root RT 0 0 0 0 S 0.0 0.0 0:00.00 watchdog/0

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Does this machine you're using as the zimbra server have hyperthreading? If it does adnd it's active try disabling it, you could also try disabling the logger as I mentioned in my last post. Try those test individually and see if you can narrow down the cause.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Feb 2006
    Posts
    10
    Rep Power
    9

    Default

    How to disable the logger? In admin concole I de-select the logger service, and restart the server by running "zmcontrol shutdown" and "zmcontrol start", is there anything else I need to do?

    Still notice high CPU usage, and most of them are from "java" as below:

    [zimbra@mail root]$ top
    top - 11:52:20 up 32 days, 13:15, 1 user, load average: 0.23, 0.26, 0.19
    Tasks: 112 total, 3 running, 109 sleeping, 0 stopped, 0 zombie
    Cpu(s): 67.4% us, 6.6% sy, 0.0% ni, 25.6% id, 0.0% wa, 0.3% hi, 0.0% si
    Mem: 2067660k total, 1820988k used, 246672k free, 107904k buffers
    Swap: 4192956k total, 856k used, 4192100k free, 1212856k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    5184 zimbra 25 0 461m 22m 10m R 27.6 1.1 0:00.83 java
    2835 zimbra 17 0 7072 3324 1736 S 0.3 0.2 0:00.09 zmmtaconfig
    4137 zimbra 16 0 2024 1008 784 R 0.3 0.0 0:00.49 top
    1 root 16 0 1744 568 492 S 0.0 0.0 0:01.59 init

    Will check what I can do with the CPU later.

  7. #7
    Join Date
    Oct 2007
    Posts
    55
    Rep Power
    8

    Default

    I have disabled the logger service and it appears that my high cpu issue has gone away. I would like the logger functionality. Is there a fix planned for this?

Similar Threads

  1. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  2. Zimbra client with another server
    By JayBee in forum Developers
    Replies: 6
    Last Post: 02-16-2007, 10:44 PM
  3. Caldav server and Zimbra client
    By pierreM in forum Developers
    Replies: 1
    Last Post: 07-03-2006, 01:56 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM
  5. Replies: 15
    Last Post: 11-17-2005, 12:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •